Ships & Modules

 
 

pyfa v1.27.0

Author
Gallente Federation
#301 - 2017-01-30 01:11:21 UTC  |  Edited by: Ebag Trescientas
Sable Blitzmann wrote:

I'm pretty picky over how things are done and it's best that I know what's happening - I don't like blind pull requests for new features ;)


/me whistles innocently


Sable Blitzmann wrote:

And I can of course give guidance around the codebase if needed


Don't forget about devfleet Slack, and now Pyfa has it's own Slack:
https://pyfainvite.azurewebsites.net/

Blitzmann is pretty good about being helpful to new devs. 10/10 would submit PRs again.
Shadow of xXDEATHXx
#302 - 2017-02-13 11:59:42 UTC  |  Edited by: Andrey Dragon
Pyfa 1.26.1 on MacBook Pro (15-inch, Late 2011) OC X - 10.12.3 -

does not start the character editor window, the rest works more please fix this error. And I can't add the character with its characteristics and generally anything to edit!
The program is just wonderful! ago correct this error!
With respect, Andrew.
P.S==> error any does not produce, simply does not start a window, the characteristics of a hero.
P.S.==> 1.24.0 - working version! checked!
1.25.0 - not a working version! checked! -OC X - 10.12.3
Minmatar Republic
#303 - 2017-02-13 14:17:04 UTC
Andrey Dragon wrote:
Pyfa 1.26.1 on MacBook Pro (15-inch, Late 2011) OC X - 10.12.3 -

does not start the character editor window, the rest works more please fix this error. And I can't add the character with its characteristics and generally anything to edit!
The program is just wonderful! ago correct this error!
With respect, Andrew.
P.S==> error any does not produce, simply does not start a window, the characteristics of a hero.
P.S.==> 1.24.0 - working version! checked!
1.25.0 - not a working version! checked! -OC X - 10.12.3


The pre-release does indeed have an issue with the character editor that has already been fixed. :)

1.25 should work though. Are you using the deprecated os x version or the non-deprecated?
Ivy League
#304 - 2017-02-17 05:03:39 UTC
I did a backup of all my fittings in case of a fatal database corruption.

I really dig the notes function since it's so cool to add notes about fittings, but those notes aren't saved anywhere I can back up in case of catastrophic failure of the database / back up of computer files or anything like that. Is there a way to do that easily?
Gallente Federation
#305 - 2017-02-17 05:32:51 UTC  |  Edited by: Ebag Trescientas
K950 wrote:
I did a backup of all my fittings in case of a fatal database corruption.

I really dig the notes function since it's so cool to add notes about fittings, but those notes aren't saved anywhere I can back up in case of catastrophic failure of the database / back up of computer files or anything like that. Is there a way to do that easily?


It's part of the saveddata.db file in your Pyfa folder. All fits, chars, etc are stored there.

It's just SQLite if you ever need to extract data from it.

https://github.com/pyfa-org/Pyfa/wiki/Database
#306 - 2017-02-17 16:15:46 UTC
mmm some issues with 1.27

"Could not parse out querystring parameters."
for crest request


did you guys disabled the "graphs" tool? i used to pass many hours on it :(


anyway always many thanks for improving pyfa, my favorite eve tool ever ^^
Gallente Federation
#307 - 2017-02-17 16:50:54 UTC
Soel Reit wrote:
mmm some issues with 1.27

"Could not parse out querystring parameters."
for crest request


I'm getting this as well. I'll look into it.


Soel Reit wrote:

did you guys disabled the "graphs" tool? i used to pass many hours on it :(


Graphs are working for me. Do you get any errors in the log.txt file?
#308 - 2017-02-17 17:03:23 UTC  |  Edited by: Soel Reit
Quote:

Graphs are working for me. Do you get any errors in the log.txt file?


sorry i'm noob, teach me where to look for that file, ty

edit: ok i found it on my own "pyfa.exe.log"..
last error on it is: 2015-09-27 14:15:47

so 2 years ago...

edit2: also one friend of mine can't import the fit from xml, trying to do so let pyfa crash O.o
#309 - 2017-02-17 19:08:36 UTC
Suggestion:
Import to sandbox.
Basicially an import where the fit gets deleted as soon as you close the tab it is in (80% of my fittings are imported junk)
Test Alliance Please Ignore
#310 - 2017-02-17 20:50:44 UTC
Hello!

I think pyfa is awesome. But I was wondering if there is a way to turn off the ship attributes that pop up when you hover the mouse over a fitting.

See this screen shot. http://imgur.com/a/7MaVl

I've looked under preferences but I don't see an option. Am I missing something?

Thanks!
#311 - 2017-02-17 20:53:00 UTC
BSTheo Aldent wrote:
Hello!

I think pyfa is awesome. But I was wondering if there is a way to turn off the ship attributes that pop up when you hover the mouse over a fitting.

See this screen shot. http://imgur.com/a/7MaVl

I've looked under preferences but I don't see an option. Am I missing something?

Thanks!


they disappear automatically after a couple of seconds, i like that feature
Gallente Federation
#312 - 2017-02-17 21:02:46 UTC
Nalles wrote:
Suggestion:
Import to sandbox.
Basicially an import where the fit gets deleted as soon as you close the tab it is in (80% of my fittings are imported junk)


I fail to see the problem. :D

All kidding aside, we have to save it all in order to be able to process and calculate off it. No way around that, I'm afraid. It's not terribly hard to delete after you import though (and IIRC, ctrl click will delete without the "are you sure" prompt).


BSTheo Aldent wrote:
Hello!

I think pyfa is awesome. But I was wondering if there is a way to turn off the ship attributes that pop up when you hover the mouse over a fitting.

See this screen shot. http://imgur.com/a/7MaVl

I've looked under preferences but I don't see an option. Am I missing something?

Thanks!


Good suggestion. I'll make a note of adding that to preferences.

When we're debugging, it stays up indefinitely (since the application is paused), which is *REALLY* annoying.
Test Alliance Please Ignore
#313 - 2017-02-17 22:14:36 UTC
Hopefully it's not a hassle to make this change! Thanks !
Praetoria Imperialis Excubitoris
#314 - 2017-02-17 22:57:59 UTC
Soel Reit wrote:


did you guys disabled the "graphs" tool? i used to pass many hours on it :(


Same here, Graphs is disabled, no errors found in the logs.

Lady Mitara Newelle of House Sarum, Holder of the Mekhios province of Damnidios Para'nashu, Champion of House Sarum, Sworn Upholder of the Faith, Divine Commodore of the 24th Imperial Crusade

Admiral of Praetoria Imperialis Excubitoris

Gallente Federation
#315 - 2017-02-17 23:02:37 UTC
Mitara Newelle wrote:
Soel Reit wrote:


did you guys disabled the "graphs" tool? i used to pass many hours on it :(


Same here, Graphs is disabled, no errors found in the logs.



Can you provide more info on what you're running on?

Ideally, fill out an issue here:
https://github.com/pyfa-org/Pyfa/issues/new

It'll provide a questionnaire which should ask the relevant questions.
Minmatar Republic
#316 - 2017-02-19 03:01:03 UTC
Hey all,

You can keep up with 1.27.0 bugs and their status from our issue page. Most of the ones we know about have been quenched, and hopefully a new release will be out in a few days.
#317 - 2017-02-19 03:04:14 UTC
Sable Blitzmann wrote:
Hey all,

You can keep up with 1.27.0 bugs and their status from our issue page. Most of the ones we know about have been quenched, and hopefully a new release will be out in a few days.


can confirm it! i've been spamming that issue page and till now 2/2 bugs resolved!
pyfa stuff is good stuff!
#318 - 2017-02-19 09:37:02 UTC
http://imgur.com/a/ZgSEE

Help me! I don't understand what to do about SadSad
Gallente Federation
#319 - 2017-02-19 14:40:01 UTC
XBLazeLX wrote:
http://imgur.com/a/ZgSEE

Help me! I don't understand what to do about SadSad


Can you please go here and post some information?
https://github.com/pyfa-org/Pyfa/issues/997

OS
Language and Locale setting
Actual path of your pyfa.exe and saveddata.db
#320 - 2017-02-21 17:37:51 UTC
Mitara Newelle wrote:
Soel Reit wrote:


did you guys disabled the "graphs" tool? i used to pass many hours on it :(


Same here, Graphs is disabled, no errors found in the logs.


My graphs don't work either :( Had to revert back to 1.26. To be more clear, the "Graphs" option is greyed out so I cannot even click it. CTRL+G does nothing either.
Forum Jump