Linux

 
2 Pages12Next page
 

DX11 is WORKING on wine 2.3!

Author
EvE-Scout Enclave
#1 - 2017-03-07 00:29:22 UTC  |  Edited by: Rhyme Bittern
Hooray! The day has come!

With wine-staging 2.3 (csmt enabled) on ubuntu 17.04, with a gtx770 nvidia card using proprietary drivers (378.13), I can run the game in glorious dx11 mode. The game looks great (most notably, the asteroid belts), and now I can set antialiasing on "high" (previously only "medium" was available).

In a glance, I found only three problems:
1. Window blur. It makes the windows completely opaque.
2. Full body character view. I get a black head with terrifying white eyes hovering over an ominous circle of darkness (when I get to a station I'll check captain's quarters - it probably doesn't work).
3. Several ship hulls are semi-transparent to some of their own lights (e.g. Dominix, Hel).

What a joy! I wonder if the devs can tell the wine developers what else is missing to have dx11 mode up and running. We'd like to learn about it too :-)
Brute Force Solutions
#2 - 2017-03-07 05:04:30 UTC
Rhyme Bittern wrote:
Hooray! The day has come!

With wine-staging 2.3 (csmt enabled) on ubuntu 17.04, with a gtx770 nvidia card using proprietary drivers (378.13), I can run the game in glorious dx11 mode. The game looks great (most notably, the asteroid belts), and now I can set antialiasing on "high" (previously only "medium" was available).

In a glance, I found only three problems:
1. Window blur. It makes the windows completely opaque.
2. Full body character view. I get a black head with terrifying white eyes hovering over an ominous circle of darkness (when I get to a station I'll check captain's quarters - it probably doesn't work).
3. Several ship hulls are semi-transparent to some of their own lights (e.g. Dominix, Hel).

What a joy! I wonder if the devs can tell the wine developers what else is missing to have dx11 mode up and running. We'd like to learn about it too :-)


Can you provide a performance index (FPS @ resolution with Interval immediate) ?
To see if it's worth it dumping gallium-9?
EvE-Scout Enclave
#3 - 2017-03-07 18:58:22 UTC  |  Edited by: Rhyme Bittern
Ravow wrote:


Can you provide a performance index (FPS @ resolution with Interval immediate) ?
To see if it's worth it dumping gallium-9?


With Interval set to Immediate, I'm on 60fps at 1920x1080.
Brute Force Solutions
#4 - 2017-03-07 19:21:28 UTC
Rhyme Bittern wrote:
Ravow wrote:


Can you provide a performance index (FPS @ resolution with Interval immediate) ?
To see if it's worth it dumping gallium-9?


With Intervalset to Immediate, I'm on 60fps at 1920x1080.


That's not sufficient as it will drop lower than that when you need it most (fights)

With Gallium-9, I get 95fps @ 3840x2160 in space near my outpost and +-65-75fps in a relic site and in 1920x1080 it stay > than 150fps all the time and in station and stuff like that It reach can 300.

With a Radeon RX480 (similar performance than your GTX770).

Hopefully CCP will not remove DX9 once Wine support DX11 ok as it will mean crappy fps for me (for some reason, the image quality of my screen is way crappier in 1080p than 2160p compared to my old 1080p screen). Especially now that it's a pita to debug since CCP removed stdout logging capability (that's what was used to make EVE work in Linux in the first place)
Corpse Collectors Group
#5 - 2017-03-10 11:08:26 UTC
Ravow wrote:
Rhyme Bittern wrote:
Ravow wrote:


Can you provide a performance index (FPS @ resolution with Interval immediate) ?
To see if it's worth it dumping gallium-9?


With Intervalset to Immediate, I'm on 60fps at 1920x1080.


That's not sufficient as it will drop lower than that when you need it most (fights)

With Gallium-9, I get 95fps @ 3840x2160 in space near my outpost and +-65-75fps in a relic site and in 1920x1080 it stay > than 150fps all the time and in station and stuff like that It reach can 300.

With a Radeon RX480 (similar performance than your GTX770).

Hopefully CCP will not remove DX9 once Wine support DX11 ok as it will mean crappy fps for me (for some reason, the image quality of my screen is way crappier in 1080p than 2160p compared to my old 1080p screen). Especially now that it's a pita to debug since CCP removed stdout logging capability (that's what was used to make EVE work in Linux in the first place)


Remember, Nvidiots can't use gallium-nine as they would be forced to use the garbage Nouveau driver.
EvE-Scout Enclave
#6 - 2017-03-12 09:16:49 UTC  |  Edited by: Rhyme Bittern
Some other problems I am currently having with DX11 on nvidia: sometimes framerate drops during warps, and after this happens sometimes I get complete system freeze on gate jump, requiring hard reboot.

Not a good time for a crash, during a gate jump in nullsec Blink
O.U.Z.O. Alliance
#7 - 2017-03-12 15:35:46 UTC
Ouuh that sounds promising. Will check it out!

Eve Minions is recruiting.

This is the law of ship progression!

Aura sound-clips: Aura forever

#8 - 2017-03-15 03:32:22 UTC  |  Edited by: guigui lechat
tested it on nvidia


sudo add-apt-repository ppa:wine/wine-builds
sudo apt update
sudo apt install wine-staging
#if you want to replace the wine version :
#sudo apt install winehq-staging winetricks


had to delete my old playonlinux prefix though … which I did, then placed a launcher on my desktop :


# where we want to create the wine prefix dedicated for Eve
EVEPREFIX="$HOME/wineprefixes/eve"
# where we want our launcher to be : get desktop variable
launcher=$(source ~/.config/user-dirs.dirs; echo $XDG_DESKTOP_DIR)/eve
mkdir -p "$EVEPREFIX"
echo '#!/bin/bash'$'\n'"cd $EVEPREFIX"$'\n'"WINEPREFIX=$EVEPREFIX /opt/wine-staging/bin/wine "'C:\\\\Eve\\eve.exe' >"$launcher"
#instead if you installed winehq-staging:
# echo '#!/bin/bash'$'\n'"cd $EVEPREFIX"$'\n'"WINEPREFIX=$EVEPREFIX wine "'C:\\\\Eve\\eve.exe' >"$launcher"
chmod +x "$launcher"


then started the installer

WINEPREFIX=$HOME/wineprefixes/eve /opt/wine-staging/bin/wine ~/EveLauncher-1104888.exe


choosing C:\\Eve as install path

after that,
WINEPREFIX=$HOME/wineprefixes/eve /opt/wine-staging/bin/winecfg
# or if you installed winehq-staging
#WINEPREFIX=$HOME/wineprefixes/eve winecfg
#WINEPREFIX=$HOME/wineprefixes/eve winetricks


to enable everything but the gdk theming in the "staging" and set compliance to windows 10.

I could not launch winetricks to get the corefonts without installing winehq (commented script).

on first log in press alt+enter to get the controls.

once Eve launched I needed to change option in display, untick "asteroid environment" cause it makes HUGE FPS drops. also set shaders to medium and post-process to low. However I noticed "antialising" went to low and I don't have high anymore, meaning I may have lost the dx11 … I got it again by selecting shader quality to high.
#9 - 2017-03-15 16:48:22 UTC  |  Edited by: guigui lechat
used winetricks to install corefonts and d3dx11 and got way better performances. Still issues in asteroids though Evil

also some strange freezes in station ..
Brute Force Solutions
#10 - 2017-03-15 17:18:10 UTC
I'm keeping DX9 until someone revive Gallium-10/11 as the old code got yanked out a while ago because it bit rotted out of useless (It was too early and about nothing was in DX11 in that epoch).
#11 - 2017-03-16 14:30:38 UTC
started Eve, tried to kill base angel.

15 minutes laters, several freezes and the burners killed, message "no more space on HDD"
/var/log/syslog was filled with

Quote:
org.freedesktop.FileManager1[2195]: fixme:d3d11:d3d11_immediate_context_DSSetShaderResources iface 0x19fdec, start_slot 15, view_count 1, views 0x33a6ac stub!
fixme:d3d11:d3d11_immediate_context_OMSetBlendState Per-rendertarget blend not implemented.
fixme:d3d11:d3d11_immediate_context_OMSetBlendState Color mask > 3 not implemented.
fixme:d3d11:d3d11_immediate_context_HSSetShader iface 0x19fdec, shader (nil), class_instances (nil), class_instance_count 0 stub!
fixme:d3d11:d3d11_immediate_context_DSSetShader iface 0x19fdec, shader (nil), class_instances (nil), class_instance_count 0 stub!
org.freedesktop.FileManager1[2195]: fixme:d3d11:d3d11_immediate_context_DSSetShaderResources iface 0x19fdec, start_slot 5, view_count 1, views 0x33a78c stub!


20minutes, 150GB eaten on my SSD. I'm not sure, but maybe there is something not working perfectly…
Gallente Federation
#12 - 2017-03-29 21:03:41 UTC
guigui lechat wrote:
started Eve, tried to kill base angel.

15 minutes laters, several freezes and the burners killed, message "no more space on HDD"
/var/log/syslog was filled with

Quote:
org.freedesktop.FileManager1[2195]: fixme:d3d11:d3d11_immediate_context_DSSetShaderResources iface 0x19fdec, start_slot 15, view_count 1, views 0x33a6ac stub!
fixme:d3d11:d3d11_immediate_context_OMSetBlendState Per-rendertarget blend not implemented.
fixme:d3d11:d3d11_immediate_context_OMSetBlendState Color mask > 3 not implemented.
fixme:d3d11:d3d11_immediate_context_HSSetShader iface 0x19fdec, shader (nil), class_instances (nil), class_instance_count 0 stub!
fixme:d3d11:d3d11_immediate_context_DSSetShader iface 0x19fdec, shader (nil), class_instances (nil), class_instance_count 0 stub!
org.freedesktop.FileManager1[2195]: fixme:d3d11:d3d11_immediate_context_DSSetShaderResources iface 0x19fdec, start_slot 5, view_count 1, views 0x33a78c stub!


20minutes, 150GB eaten on my SSD. I'm not sure, but maybe there is something not working perfectly…

export WINEDEBUG=fixme-al

will fix this (and many) similar issues. fixmes are not really interesting to a user anyway.
#13 - 2017-03-29 23:19:26 UTC
adding
WINEDEBUG=-all
before calling wine indeed got rid of this. Also I do not have freezes anymore.

two bugs :
- I can see my stratios' lights through it.
- if I set the shadder quality to high, then sometimes the screeen goes very dark with no reason.
#14 - 2017-03-31 01:46:21 UTC
when shaders are high, I can also see my bestower's reactors through it. when I put it to low it's OK.
#15 - 2017-04-17 10:49:18 UTC  |  Edited by: COMM4NDER
guigui lechat wrote:
when shaders are high, I can also see my bestower's reactors through it. when I put it to low it's OK.

Try turning off AA, seems its related since EVE uses shaders for AA.

Tried with Wine-Staging 2.5;
Nvidia drivers still can get a crash and kernel gets debugging and practically freeze, sometimes you will get out of the freeze quite fast sometimes you need to restart X. Crashes are because of the unfinished shader work in Wine that EVE uses.

I have posted this on devtalk and they are tracking the issue since even if shadercode is bad it should not crash the whole system.
So nvidia users are welcome to post nvidiabug info so they can get more info about your system and hopefully come with a updated driver that wont crash whole system.

https://devtalk.nvidia.com/default/topic/996333/linux/nvidia-driver-crash-with-wine-staging-amp-eve-online-w-dx11-enabled-amp-high-shaders-/

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

EvE-Scout Enclave
#16 - 2017-04-19 14:51:54 UTC
After upgrading from wine-staging 2.5 to wine-staging 2.6 I have a regression with DX11: on every anti-alias setting except "diabled", the scene is rendered completely black. The interface still shows and responds.
#17 - 2017-04-23 08:22:57 UTC  |  Edited by: COMM4NDER
Rhyme Bittern wrote:
After upgrading from wine-staging 2.5 to wine-staging 2.6 I have a regression with DX11: on every anti-alias setting except "diabled", the scene is rendered completely black. The interface still shows and responds.


Don't think it is a regression it newer worked correctly in 2.5 and lower. Ship details became transparent etc. If you have logs post a wine bug in buggtracker and hopefully someone takes a task to fix it, because AA is done on a shader level in EVE.

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

EvE-Scout Enclave
#18 - 2017-04-23 22:05:42 UTC
COMM4NDER wrote:
If you have logs post a wine bug in buggtracker and hopefully someone takes a task to fix it, because AA is done on a shader level in EVE.

Do you know how I get logs? I understood that wine output is masked using the launcher.
Ghost Legion.
#19 - 2017-05-10 18:55:19 UTC
Anyone manage to get their killmarks to show up? Running dx11 on Wine 2.7 and can`t seem to see any with the settings maxed.
System has been fairly stable so far.
I only get the ghostly head in character sheet on potato mode.
Framerates 60 @ 2160p, some tearing if I move the view around fast.
EvE-Scout Enclave
#20 - 2017-05-18 07:17:51 UTC
There is a new problem with the May release: the new suns flicker continuously on dx11 (wine-staging 2.8, nvidia).
This makes dx11 unplayable for me on linux.
2 Pages12Next page
Forum Jump