Linux

 
  • Topic is locked indefinitely.
 

RX 480

Author
Carnivorous Swarm
#1 - 2017-03-13 17:33:28 UTC
I am trying to get this GPU to work well but I can't seem to figure it. On Win10 I get 60fps at 1920x1080 with all settings on high including anti-aliasing. On Linux I get 29fps and sputtering with all on high, but no anti-aliasing.

I had a fresh install of Ubuntu 16.04, installed the playonlinux ubuntu package, and downloaded the launcher from these forums. I also downloaded the AMD driver tar and ran the install script. Next I downloaded and installed the debs for the 4.7.2 kernel, which is supposed to support the AMDGPU.

Now I'm at a loss on what to try next (or what I did wrong). Any tips are welcome.
Goonswarm Federation
#2 - 2017-03-13 22:07:45 UTC  |  Edited by: Neuntausend
AMDGPU works with the RX480 and it supports gallium nine. So, make sure your version of mesa is compiled with nine support (you will probably need to install it from a third party PPA - I don't use Ubuntu, so you'll have to google there) and use wine-staging instead of wine. Then in winecfg in the staging tab, you can enable native DirectX 9 support and enjoy all the FPSes. If gallium nine doesn't work properly for some reason, you can use CSMT (also in the staging tab) instead. It will give you an FPS boost as well, but not nearly as big as nine.

Another thing worth taking a look at is the desktop compositor ("desktop effects" or something along those lines). I'd recommend just turning it off to test if it makes any difference at all. If it does, you may be able to find some settings that allow you to turn it on and still get decent FPS in your games.

edit:

you can apparently get wine-staging from ppa:wine/wine-builds and mesa as well as xserver-xorg-video-amdgpu from ppa:oibaf/graphics-drivers by the looks of things. I give no warranties, though, for all I know those packages might set your computer on fire.

edit2: I just put wine and Eve on my RX480 machine, and it works just fine with amdgpu and nine. About 200-ish FPS in the Hangar, 100-160 (fairly unstable) in captains quarters, about 200 on jita 4-4 undock, 250 on an empty undock and it flatlines at 300 if I move the camera to just show empty space. 1920x1080, fixed window mode, all settings at max except for antialiasing, which is off (I sit too far off the monitor to really see the difference). Wine 2.3, Mesa 17.0.1 and xf86-video-amdgpu 1.2.0. I have not yet tested it in a mission or a fleet battle, though.

This card should do fine, given the right driver setup and wine patches.

PS: Get rid of the proprietary AMD drivers, though. Unless you intend to run Vulkan games or use the cards OpenCL capabilities, they are just crap.
Brute Force Solutions
#3 - 2017-03-14 05:41:56 UTC
Also check cooling and thermal throttling. I don't know the status of that on Windows and how card design are different but my RX480 was badly throttling until I edited the bios to unlock the max fan speed so it stop cooking at 1/3 fan speed. Windows have tools to do that on the driver side, AMDGPU don't yet.

You can check temps and fan RPM with lm_sensors once your running with AMDGPU.

Also, AMDGPU-PRO is not a reason for Vulkan, AMDGPU support vulkan, you just have to enable "radv" & of course "d3d9" when your compiling MESA. plus install some Vulkan loader&ICD (Note that might be inaccurate as I only used vulkan with Talos Principle (60fps at 4K res) and my one learning Vulkan with c++).
Carnivorous Swarm
#4 - 2017-03-16 17:03:25 UTC
Thanks guys! I'll try these suggestions out this weekend and report back.
Carnivorous Swarm
#5 - 2017-03-18 01:05:21 UTC
wine-staging + that amdgpu driver did it! Low 60s, high 130s now.

Thanks again!
Forum Jump