Linux

 
2 PagesPrevious page12
 

Linux launcher now supports custom Wine version

First post
Author
Gallente Federation
#21 - 2016-10-23 23:25:28 UTC
I am using Crossover as my wine server. Does any one know how I can try this package with Crossover as opposed to a standard wine installation. At one time I used a version of EVE in Crossover, but it has stopped working after a recent update to EVE.
The Volition Cult
#22 - 2016-12-07 09:31:20 UTC
can we have a native WINEPREFIX and WINEARCH as well please? it's so fiddly using that weird WINEPREFIX in SharedCache/wineenv. it's quite unwiedly and there isn't really a reason to use that prefix other than when using the builtin wine.
Aureus Alae
#23 - 2016-12-10 04:06:19 UTC  |  Edited by: Veldsper
have some problem with this.
debian-jessli amd64 - it worked but after perform apt-get update/upgrade it stops

error 2016-12-10T04:59:12 7269 /home/veldsper/evelauncher/evelauncher debian evelauncher wine "err:module:load_builtin_dll failed to load .so lib for builtin L\"WLDAP32.dll\": libldap_r-2.4.so.2: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu" <-- cant find file
error 2016-12-10T04:59:12 7269 /home/veldsper/evelauncher/evelauncher debian evelauncher wine "err:module:import_dll Loading library WLDAP32.dll (which is needed by L\"C:\\\\tq\\\\bin\\\\blue.dll\") failed (error c000007a)."
error 2016-12-10T04:59:12 7269 /home/veldsper/evelauncher/evelauncher debian evelauncher wine "err:module:import_dll Library blue.dll (which is needed by L\"C:\\\\tq\\\\bin\\\\exefile.exe\") not found"
error 2016-12-10T04:59:12 7269 /home/veldsper/evelauncher/evelauncher debian evelauncher wine "err:module:LdrInitializeThunk Main exe initialization for L\"C:\\\\tq\\\\bin\\\\exefile.exe\" failed, status c0000135"
info 2016-12-10T04:59:12 7269 /home/veldsper/evelauncher/evelauncher debian evelauncher default Process 7423 finished with exit code 53


solved the problem.
apt-get install libldap-2.4-2:i386
Goonswarm Federation
#24 - 2017-01-20 18:44:26 UTC
Work well for me after some tests Big smile

Many thanks
Iron Armada
#25 - 2017-02-04 23:29:03 UTC
Launching the EVE client would fail out quietly so I selected E->Run clients with logging. LogLite kept displaying this error:
wine client error:0: version mismatch 504/524.


To fix this I:

  1. Made sure the custom wine setting was set to my system /usr/bin/wine
  2. Moved the .eve/wine folder to .eve/wine-1.9.10-ccp-daily-16
  3. Moved the .eve/wineenv folder to .eve/wineenv-1.9.10-ccp-daily-16
  4. Started the launcher
  5. Copied the .eve/wineenv-1.9.10-ccp-daily-16/drive_c/users/andrew/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/ folder to the same spot in the new .eve/wineenv folder, overwriting all.


Voila.

For anyone wondering, "Run clients with DX9" is still required with Wine 2.1.
Goonswarm Federation
#26 - 2017-03-14 12:27:29 UTC
Get some artifacs in station since last patch (14/03/2017)
Curatores Veritatis Alliance
#27 - 2017-03-14 13:09:50 UTC
Same here. Many artefacts in close zoom.

dx9, latest dev wine.
NVIDIA GTX980, drivers 375.39

https://drive.google.com/file/d/0B0qud9gCG5z-NjFuNW9uVVI1WUk/view?usp=drivesdk
#28 - 2017-03-14 14:18:00 UTC  |  Edited by: Ravow
It does append with my rig too

native dx9 (gallium-9), yesterday git Wine, yesterday Mesa
Radeon RX480, Mesa-GIT drivers.

EDIT : Turning off post processing in gfx option "fix" the issue
2 PagesPrevious page12
Forum Jump