Linux

 
28 PagesFirst pagePrevious page262728
 

EVE Launcher for Linux

First post First post
Author
Gallente Federation
#541 - 2017-03-11 22:39:45 UTC
Might help for ubuntu 16.04x64 users (and probably for latest x64 debian too)
sudo apt-get install libldap-2.4-2:i386  
Caldari State
#542 - 2017-03-12 14:46:59 UTC  |  Edited by: Kuran Sincomil
Hi folks, trying to return back to EVE Universe, but faced with a problem in my home OS: Debian Stretch 9.
Trying to run ./evelauncher.sh but it runs without any errors and do nothing just hanging on terminal window and no output at all, and no launcher window appers :(.
I found EVE LogLite in "evelaucher" diretory, it runs ok and when I start ./evelauncher one client get connected with "[0]" ID, but no messages written in LogLite output. Where should I look to get game to run?
#543 - 2017-03-15 04:51:04 UTC
Kuran Sincomil wrote:
Hi folks, trying to return back to EVE Universe, but faced with a problem in my home OS: Debian Stretch 9.
Trying to run ./evelauncher.sh but it runs without any errors and do nothing just hanging on terminal window and no output at all, and no launcher window appers :(.
I found EVE LogLite in "evelaucher" diretory, it runs ok and when I start ./evelauncher one client get connected with "[0]" ID, but no messages written in LogLite output. Where should I look to get game to run?


I'm having the same problem. Looks like if I knew what I was looking at I could export each of these directories manually. After bricking my system though I don't think I want to try.
Fidelas Constans
#544 - 2017-03-16 19:12:02 UTC
Same here, blank terminal..
Minmatar Republic
#545 - 2017-03-17 00:50:14 UTC
A little late to the party, but just dropping in to say thanks to CCP Snorlax. I just heard about this launcher and it's the reason I came back to EvE. :)

Tested on Fedora 25 and the latest openSUSE Tumbleweed. both are working great so far.

Hopefully we will get an 'official' version one day, judging by the responses in this thread it seems quite a few players are friends of Tux.

Love Zap. x
Sev3rance
#546 - 2017-03-17 04:56:27 UTC
Not sure if it has been mentioned anywhere on this thread but 16.04 and Amd is a tad sketchy. Some AMD chipsets are in trouble, the propietary driver can not be installed (far as I've rad, if you manage to install them.. it will be auto removed) and the open source drivers are not up to par.

I read in the ubuntu-mate community forums that some AMD official announced that this will be fixed by the end of the year, so if you keep dabbling with 16.04 and you dont get results, I humbly suggest that you try either 14.04, 15.04 or 15.10 to see if it works better for you.

My Trinity HD 7650 is not supported in 16.04, the additional drivers section wont install the gallium as it does in 15.04, and the whole section regarding opensource or fglrx doesnt show.

I thought this should be announced somewhere.....

Ubuntu Mate 15.04 64bit // Amd A8-5600K with IGP Trinity 7650D // 6GB DDR3 // Sandisk 120GB SSD Plus // Wine 1.7.50 // Native Linux Launcher // TS3 working // Happy to be back in Ubuntu :)

#547 - 2017-03-19 22:18:46 UTC
Ok, so looks like launcher is launching (lol) but it shuts itself after second

[0319/231553:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale 
Installed Qt WebEngine locales directory not found at location /home/xiztnc/Pobrane/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/xiztnc/Pobrane/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0319/231553:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Setting breakpad minidump AppID = 8500
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198057427080 [API loaded no]
evelauncher: ../../nouveau/pushbuf.c:727: nouveau_pushbuf_data: Warunek zapewnienia `kref' nie został spełniony.
Aborted
#548 - 2017-03-19 23:48:19 UTC
Adara Starkiss wrote:
Not sure if it has been mentioned anywhere on this thread but 16.04 and Amd is a tad sketchy. Some AMD chipsets are in trouble, the propietary driver can not be installed (far as I've rad, if you manage to install them.. it will be auto removed) and the open source drivers are not up to par.

I read in the ubuntu-mate community forums that some AMD official announced that this will be fixed by the end of the year, so if you keep dabbling with 16.04 and you dont get results, I humbly suggest that you try either 14.04, 15.04 or 15.10 to see if it works better for you.

My Trinity HD 7650 is not supported in 16.04, the additional drivers section wont install the gallium as it does in 15.04, and the whole section regarding opensource or fglrx doesnt show.

I thought this should be announced somewhere.....



The problem seam to be on the Ubuntu side. AMD stopped supporting most of there chip except GCN3+ as Opensource drivers with gallium are simply better (on every aspect) and there proprietary drivers are utter crap. My guest is that you have to install the open gallium stack from PPA's if Ubuntu is not willing to ship with up to date libdrm/llvm/mesa (even 6 month old mesa should work fine for eve.).
#549 - 2017-03-22 18:33:31 UTC
Just chiming in with a "me too"-post. Eve is running wonderfully on my laptop: Asus machine with Intel and Nvidia discrete graphics running Fedora 25, using the binary blob Nvidia drivers under Xorg. If I try things under Wayland I either get the Intel side of things which is as slow as you would expect, and if I prefix the launcher with DRI_PRIME=1, it thinks I'm running a 9800 GTX or somesuch, with horrid performance as well. Running under Xorg correctly figures out I actually have a 920M.

Wayland aside, I'm very happy with this.

Shooting people in the face for fun and profit. Well, for fun, mostly.

28 PagesFirst pagePrevious page262728
Forum Jump