EVE Technology Lab

 
2 PagesPrevious page12
 

phpBB 3.2 EVE SSO / ESI extension [alpha]

Author
The Bloc
#21 - 2017-03-19 19:51:15 UTC  |  Edited by: Snitch Ashor
Felicity Stihl wrote:

To anwser my own post:
Found two issues,
1. had to explictly set the php variable "register_globals" to off
2. had to install php-curl (which is not mentioned as a requirement anywhere)

Seems to work now, except for the fact that when I log in, I get a error complaning about "INSECURE_REDIRECT".. (things still work if I refresh)


Thanks a lot.

Indeed php5.5+ with curl is a requirement for the API client library, added that to the opening post and readme.
I'm abit confused about the other part since register_globals = OFF should be default since php 4.x and phpBB itself should complain if its on...


The INSECURE_REDIRECT, is that a phpBB error message and when does it appear?

I uploaded a version 1.0.1 (Download Link in the opening post) which should fix the problem about databases not being created on install.

@Felicity Stihl could you try this commit that should fix your insecure redirect warnings.
#22 - 2017-03-20 18:18:42 UTC  |  Edited by: Felicity Stihl
Snitch Ashor wrote:
Felicity Stihl wrote:

To anwser my own post:
Found two issues,
1. had to explictly set the php variable "register_globals" to off
2. had to install php-curl (which is not mentioned as a requirement anywhere)

Seems to work now, except for the fact that when I log in, I get a error complaning about "INSECURE_REDIRECT".. (things still work if I refresh)


Thanks a lot.

Indeed php5.5+ with curl is a requirement for the API client library, added that to the opening post and readme.
I'm abit confused about the other part since register_globals = OFF should be default since php 4.x and phpBB itself should complain if its on...


The INSECURE_REDIRECT, is that a phpBB error message and when does it appear?

I uploaded a version 1.0.1 (Download Link in the opening post) which should fix the problem about databases not being created on install.

@Felicity Stihl could you try this commit that should fix your insecure redirect warnings.


It's a PHPbb error, and it occures right after you select your character on ccp:s site and hits submit.

Your newest commit seemes to have fixed that issue.

I did however notice an odd thing with the original build, I have phpbb's timeouts set to several days, but the user session will time out within less than an hour, and require relogging, is that by design, and/or can I change the timeouts somewhere , or is this something that the new commit may have fixed ? (Just applied it, so I'll know within a few hours)
EDIT: Seems like the timeout issues are fixed, my sessions even persisted between reboots...
EDIT2: Scratch that, times out after an hour..
The Bloc
#23 - 2017-03-20 23:04:22 UTC
Yeah I know about the persistent login problem, its on the todo list. Right now I try to use phpbbs builtin remember me function, but it still fails most of the time, need to do some diggin there.
Monyusaiya Industry Trade Group
#24 - 2017-03-21 16:42:34 UTC  |  Edited by: Milo Caman
Run into a new issue: I'm trying to enable another extension (specifically the phpbb google analytics package) and when I have Auth EVE SSO enabled, my session is cleared and I'm booted back to the forum index with the following message:

Access to the Administration Control Panel is not allowed as you do not have administrative permissions.


I can happily log back in and use the rest of the ACP after this. The issue only seems to occur on the 'Customise' tab when enabling new ones. Any ideas?

EDIT: It also appears to do the same when I hit 'Details' on each extension.

EDIT 2: Bizarrely I was able to enable extensions when I switched browsers. This might not actually be related to the SSO extension? Will investigate further.

EDIT 3: Definitely not related to the plugin, my bad!
#25 - 2017-03-22 22:32:05 UTC
Small issue here too : it seems that when the EveSSO auth method is selected, some part of the boad (home page, like "who is online, statistics ; few strings in UCP/ACP ; ...) are not in the default board language.
When I switched back to Db auth method everything was ok.

I also tried to reinstall the language but it did not change anything. Can it may come from the extension ?
2 PagesPrevious page12
Forum Jump