Linux

 
 

EVE Launcher for Linux

First post First post
Author
#601 - 2017-04-27 09:31:21 UTC
May be will be a good offer if Linux Native Launcher will be statically bundled in one package with all of the required dependencies, like it is done for QT-libs?
Scary Wormhole People
#602 - 2017-04-28 04:40:14 UTC
Norok wrote:
Aldrad wrote:
I solved this by doing the following.

gpg --recv-keys --keyserver hkp://pgp.mit.edu D9C4D26D0E604491
pacaur -S libopenssl-1.0-compat
cd launcher-dir
cp /usr/lib/libcrypto-compat.so.1.0.0 .
cp /usr/lib/libssl-compat.so.1.0.0 .
ln -s libssl-compat.so.1.0.0 libssl.so.1.0.0
ln -s libssl-compat.so.1.0.0 libssl.so
ln -s libcrypto-compat.so.1.0.0 libcrypto.so.1.0.0
ln -s libcrypto-compat.so.1.0.0 libcrypto.so
sh evelauncher.sh


Only thing is the libs will get removed every launcher updae - probably is a better way to do this.


Seconding this solution, works like a charm. I guess that for now we'll just have to recreate the symbolic links at each launcher update (not that cumbersome if you wrap it in a script)


Confirmed to work and a simple shell script can run all them and be called upon for each update as needed.
#603 - 2017-04-28 08:10:53 UTC  |  Edited by: Kuran Sincomil
I'm investigated further and found that in case of Debian Stretch there is still possible to run Linux Launcher, but it is not run very well it is white all entire window and not possible to enter login/password in it but launcher menu is working ok, and settings can be changed.

To run launcher in Debian you need to provide SSL libraries ( and I found that this libs actually installed in system), I have done it with this commands:
Quote:

cd evelauncher
ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 libssl.so
ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 libssl.so.1.0.0
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 libcrypto.so
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 libcrypto.so.1.0.0

this libs provided by installed package: libssl1.0.0:amd64
After this I run ./evelauncher and it showed up as white window, and on terminal I've got this output:
Quote:

./evelauncher.sh
[0428/104540:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/stannum/Soft/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/stannum/Soft/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0428/104540:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.



Launcher window screenshot

After click on some entries in Launchers menu got this on terminal window:
Quote:

kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by kde-open5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5Service.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5I18n.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5CoreAddons.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5JobWidgets.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5Completion.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5IconThemes.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5WindowSystem.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5ConfigWidgets.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5ConfigGui.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5ConfigCore.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5DBusAddons.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5Archive.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5ItemViews.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5Codecs.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5Auth.so.5)
kde-open5: /home/stannum/Soft/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5GuiAddons.so.5)



I've checked that all files that is listed in list above are installed as requierments of KDE SC:
Quote:

libkf5kiowidgets5:amd64
libkf5kiocore5:amd64
libkf5service5:amd64
libkf5i18n5:amd64
libkf5coreaddons5:amd64
libkf5jobwidgets5:amd64
libkf5completion5:amd64
libkf5iconthemes5:amd64
libkf5windowsystem5:amd64
libkf5configwidgets5:amd64
libkf5widgetsaddons5:amd64
libkf5configgui5:amd64
libkf5configcore5:amd64
libqt5xml5:amd64
libkf5dbusaddons5:amd64
libkf5archive5:amd64
libkf5itemviews5:amd64
libkf5codecs5:amd64
libkf5auth5:amd64
libkf5guiaddons5:amd64

DARKNESS.
#604 - 2017-04-28 10:23:17 UTC  |  Edited by: Tray Odin
Hey,

I have a fresh installed Archlinux with xfce and I am trying to run this Client.
My first problem I could solved by myself.

Now I can launch the Launcher. But when I press the play Button, he is not opening a new Window or anything. I try to get some Errors, but there isn't anything helpful for me...

Maybe somebody can help me..

Last Logs:
Quote:

2017-04-28T10:12:40.461Z default debug Last verify time: QDateTime(2017-04-28 08:04:56.962 UTC Qt::TimeSpec(LocalTime))
2017-04-28T10:12:40.461Z default debug "Scheduling refresh after 15 minutes"
2017-04-28T10:12:42.896Z default debug handleCommand: "{\"cmd\":\"launcheve\",\"server\":\"tq\",\"token\":\"HBzC4hg2\",\"settingsProfile\":\"Default\",\"username\":\"Derksi689\"}"
2017-04-28T10:12:43.897Z default debug Starting LogLite from "/home/patrick/evelauncher/LogLite"
2017-04-28T10:12:43.916Z default debug "/home/patrick/.eve//wine/bin/wine" ("/home/patrick/.eve//wineenv/drive_c/tq/bin/exefile.exe", "/noconsole", "/server:tranquility", "/triPlatform=dx9", "/ssoToken=HBzLDgR-k6AgD9YvhrIrC4hg2", "/settingsprofile=Default", "", "/remotefilecachefolder=Z:/home/patrick/.eve//ResFiles")
2017-04-28T10:12:43.916Z default debug Preparing wineenv
2017-04-28T10:12:43.954Z default debug wineenv exists
2017-04-28T10:12:43.954Z default debug Copying Arial font
2017-04-28T10:12:43.954Z default debug ("WINEDLLOVERRIDES=mscoree,mshtml=", "SESSION_MANAGER=local/Derks-Laptop:@/tmp/.ICE-unix/484,unix/Derks-Laptop:/tmp/.ICE-unix/484", "GDMSESSION=xfce", "XDG_RUNTIME_DIR=/run/user/1000", "XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0", "XDG_CONFIG_DIRS=/etc/xdg", "WINEPREFIX=/home/patrick/.eve//wineenv", "GTK_MODULES=canberra-gtk-module:canberra-gtk-module", "COLORTERM=truecolor", "PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl", "XDG_SESSION_DESKTOP=xfce", "SHELL=/bin/bash", "PWD=/home/patrick/evelauncher", "XDG_MENU_PREFIX=xfce-", "DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus", "SHLVL=4", "XDG_DATA_DIRS=/usr/local/share:/usr/share", "TERM=xterm-256color", "SSH_AGENT_PID=491", "XDG_SESSION_TYPE=x11", "DYLD_FALLBACK_LIBRARY_PATH=/usr/X11/lib", "GLADE_MODULE_PATH=:", "VTE_VERSION=4803", "XDG_SESSION_ID=c2", "GLADE_PIXMAP_PATH=:", "DISPLAY=:0.0", "QTDIR=/home/patrick/evelauncher/.", "LD_LIBRARY_PATH=/home/patrick/evelauncher/.:", "XDG_SEAT=seat0", "QT_PLUGIN_PATH=/home/patrick/evelauncher/./plugins", "GLADE_CATALOG_PATH=:", "WINEDEBUG=", "WINDOWID=44040744", "SSH_AUTH_SOCK=/tmp/ssh-yLL6V4xlvtzA/agent.490", "MAIL=/var/spool/mail/patrick", "XDG_VTNR=7", "DESKTOP_SESSION=xfce", "force_s3tc_enable=true", "XAUTHORITY=/home/patrick/.Xauthority", "USER=patrick", "LANG=en_US.utf8", "HOME=/home/patrick", "_=/home/patrick/evelauncher/./evelauncher", "LOGNAME=patrick", "XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0", "OLDPWD=/home/patrick", "XDG_CURRENT_DESKTOP=XFCE", "XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/patrick")



Edit: Modified token
#605 - 2017-04-28 12:06:18 UTC
Tray Odin, try to install Steam, to be sure that all required driver dependecies and etc. are satisfied
DARKNESS.
#606 - 2017-04-28 12:41:39 UTC
Kuran Sincomil wrote:
Tray Odin, try to install Steam, to be sure that all required driver dependecies and etc. are satisfied


Big thanks to you :)

Seems working now.
#607 - 2017-04-29 11:11:31 UTC  |  Edited by: Kuran Sincomil
Now I've got evelauncher work properly, but on home computer not on work, ssl symlinks did the trick and launcher works ok.
But errors on clicking menu entries in Show in File Browser cause error that I've listed above.
Quote:

kde-open5: /Steam/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by kde-open5)
kde-open5: /Steam/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /Steam/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5)
...


Another thing that I found: after entering a game any external links from chat channels can not be opened by clicking on them - just silently nothing happens there. So I think this is related to the same issue with kde-open5 above. It is very inconvient to copy things to clipboard and paste them in external browser.

On the same computer when EVE Online running with Windows launcher from WINE and all external links there working ok
Universal Consortium
#608 - 2017-04-30 20:09:31 UTC  |  Edited by: Samwise Dagordae
Well, now it's broken for me, but trying to open the logs via "Show in File Browser" opens EasyTag instead of opening Firefox.

I'm not certain what's broken. I don't have Qt 5.7 installed, but I don't know for certain if that's going to be the issue.
#609 - 2017-05-02 09:56:54 UTC
Kuran Sincomil wrote:
Now I've got evelauncher work properly, but on home computer not on work, ssl symlinks did the trick and launcher works ok.
But errors on clicking menu entries in Show in File Browser cause error that I've listed above.
Quote:

kde-open5: /Steam/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by kde-open5)
kde-open5: /Steam/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5)
kde-open5: /Steam/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5)
...


Another thing that I found: after entering a game any external links from chat channels can not be opened by clicking on them - just silently nothing happens there. So I think this is related to the same issue with kde-open5 above. It is very inconvient to copy things to clipboard and paste them in external browser.

On the same computer when EVE Online running with Windows launcher from WINE and all external links there working ok


I am getting the following error when I click any link on the launcher. Both the links on the launcher and in the game that opens external browser (and they don't execute any steam browser as well even if I launch the game from steam) throws the same error.
bedri@linux-z7d3:~/Downloads/evelauncher$ ./evelauncher.sh
[0502/124712:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/bedri/Downloads/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/bedri/Downloads/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0502/124712:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Setting breakpad minidump AppID = 8500
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197993302480 [API loaded no]
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by kde-open5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5KIOWidgets.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5KIOCore.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5I18n.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5CoreAddons.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5JobWidgets.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5Service.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5Completion.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5IconThemes.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5WindowSystem.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5ConfigWidgets.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5WidgetsAddons.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5ConfigGui.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5ConfigCore.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libQt5Xml.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7.1_PRIVATE_API' not found (required by /usr/lib64/libQt5Xml.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5DBusAddons.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5Archive.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5ItemViews.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5Codecs.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5Auth.so.5)
kde-open5: /home/bedri/Downloads/evelauncher/./libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib64/libKF5GuiAddons.so.5)


I tried to change the path of QT libs to the path on my system (OpenSuSE Tumbleweed) but it throws the same error.
The version on my system is 5.7 but the version of the QT libs coming with the evelauncher is 5.6. Although script forces Eve Launcher to work with QT 5.6, it cannot force KDE to use local QT 5.6 libs so KDE tries to use QT 5.7 system libraries and then throwing this error. I thought to change launcher libs to 5.7 but i am not sure if it will screw up the game so I did not do anything until hearing something from CCP Snorlax.

Hope this will be fixed. For now it does not affect the game at all and I am not too much disturbed by copy-paste the links but of course if this is fixed it will be great :)

And thank you CCP Snorlax for your great work for us Linux users.
Brothers of Tangra
#610 - 2017-05-02 12:05:30 UTC  |  Edited by: SoundKonducta
Aldrad wrote:
I solved this by doing the following.

gpg --recv-keys --keyserver hkp://pgp.mit.edu D9C4D26D0E604491
pacaur -S libopenssl-1.0-compat
cd launcher-dir
cp /usr/lib/libssl-compat.so.1.0.0 .
ln -s libssl-compat.so.1.0.0 libssl.so
sh evelauncher.sh


Only thing is the lib will get removed along with every launcher update. There is probably a better way to do this.


Thank you very much.
Mercenary Coalition
#611 - 2017-05-09 23:20:11 UTC  |  Edited by: Suleyk Maulerant
Aldrad wrote:
I solved this by doing the following.

gpg --recv-keys --keyserver hkp://pgp.mit.edu D9C4D26D0E604491
pacaur -S libopenssl-1.0-compat
cd launcher-dir
cp /usr/lib/libssl-compat.so.1.0.0 .
ln -s libssl-compat.so.1.0.0 libssl.so
sh evelauncher.sh


Only thing is the lib will get removed along with every launcher update. There is probably a better way to do this.

For Arch, all I had to do was install extra/openssl-1.0 via pacman and perform a link between the /usr/lib/libssl.so.1.0.0 and the evelauncher directory:

ln -s /usr/lib/libssl.so.1.0.0 /Path/To/evelauncher/libssl.so


~S~
Goonswarm Federation
#612 - 2017-05-11 22:42:24 UTC
Aldrad wrote:
I solved this by doing the following.

gpg --recv-keys --keyserver hkp://pgp.mit.edu D9C4D26D0E604491
pacaur -S libopenssl-1.0-compat
cd launcher-dir
cp /usr/lib/libssl-compat.so.1.0.0 .
ln -s libssl-compat.so.1.0.0 libssl.so
sh evelauncher.sh


Only thing is the lib will get removed along with every launcher update. There is probably a better way to do this.


this works. only the one lib needs linking. tyty!
#613 - 2017-05-16 16:17:27 UTC  |  Edited by: Aemergin Milesios
I've been running Eve under Ubuntu 16.04 for the last month and it works great, thank you!

The only thing I am still having trouble with is when I ALT-TAB between two clients, the ALT key ends up sticking. This is causing all sorts of mayhem, especially when dual boxing during PVP. Last night I lost a rattlesnake because I tabbed back to it and after years of habit, hit F1, F2, F3 expecting weapons and such to fire but instead turned off my all of my active shields. Sad.

Anyone have a fix or tweak that I can try? This only seems to happen when switching between Eve clients, does not happen between other windows that are open. I've double checked sticky keys, etc. looking for a problem but everything checks out.

Help?
#614 - 2017-05-17 02:05:07 UTC
Hello, i recently updated my system and now the Launcher won't start anymore, the evelauncher.sh just hangs doing nothing and starting evenlauncher directly as i did beforehand spits out 2 errors:

./evelauncher: error while loading shared libraries: libsteam_api.so: cannot open shared object file: No such file or directory


After finding an libsteam_api.so i could copy i get another error:
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
zsh: abort (core dumped)  ./evelauncher


ldd ./evelauncher gives this:

    linux-vdso.so.1 (0x00007ffe663f3000)
    libsteam_api.so => /home/aurora/Drive/evelauncher/libsteam_api.so (0x00007fc551311000)
    libQt5WebEngineWidgets.so.5 => /home/aurora/Drive/evelauncher/libQt5WebEngineWidgets.so.5 (0x00007fc5510df000)
    libQt5Widgets.so.5 => /home/aurora/Drive/evelauncher/libQt5Widgets.so.5 (0x00007fc55086d000)
    libQt5Gui.so.5 => /home/aurora/Drive/evelauncher/libQt5Gui.so.5 (0x00007fc550076000)
    libQt5WebSockets.so.5 => /home/aurora/Drive/evelauncher/libQt5WebSockets.so.5 (0x00007fc54fe4d000)
    libQt5Network.so.5 => /home/aurora/Drive/evelauncher/libQt5Network.so.5 (0x00007fc54faee000)
    libQt5Concurrent.so.5 => /home/aurora/Drive/evelauncher/libQt5Concurrent.so.5 (0x00007fc54f8e8000)
    libQt5Core.so.5 => /home/aurora/Drive/evelauncher/libQt5Core.so.5 (0x00007fc54f1d6000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fc54ee4e000)
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fc54ec37000)
    libc.so.6 => /usr/lib/libc.so.6 (0x00007fc54e893000)
    libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fc54e68f000)
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fc54e471000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fc551545000)
    libQt5WebEngineCore.so.5 => /home/aurora/Drive/evelauncher/libQt5WebEngineCore.so.5 (0x00007fc549b2f000)
    libQt5Quick.so.5 => /home/aurora/Drive/evelauncher/libQt5Quick.so.5 (0x00007fc549540000)
    libQt5Qml.so.5 => /home/aurora/Drive/evelauncher/libQt5Qml.so.5 (0x00007fc548f46000)
    libQt5WebChannel.so.5 => /home/aurora/Drive/evelauncher/libQt5WebChannel.so.5 (0x00007fc548d29000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0x00007fc548a9e000)
    libm.so.6 => /usr/lib/libm.so.6 (0x00007fc54878b000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007fc548539000)
    libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x00007fc548337000)
    librt.so.1 => /usr/lib/librt.so.1 (0x00007fc54812f000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007fc547e1b000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fc547c09000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fc5478ca000)
    libz.so.1 => /usr/lib/libz.so.1 (0x00007fc5476b3000)
    libicui18n.so.56 => /home/aurora/Drive/evelauncher/libicui18n.so.56 (0x00007fc547219000)
    libicuuc.so.56 => /home/aurora/Drive/evelauncher/libicuuc.so.56 (0x00007fc546e61000)
    libicudata.so.56 => /home/aurora/Drive/evelauncher/libicudata.so.56 (0x00007fc54547e000)
    libsmime3.so => /usr/lib/libsmime3.so (0x00007fc545257000)
    libnss3.so => /usr/lib/libnss3.so (0x00007fc544f2c000)
    libnssutil3.so => /usr/lib/libnssutil3.so (0x00007fc544cfe000)
    libplc4.so => /usr/lib/libplc4.so (0x00007fc544af9000)
    libnspr4.so => /usr/lib/libnspr4.so (0x00007fc5448b9000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007fc544675000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007fc5443b4000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0x00007fc5441a3000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007fc543f98000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007fc543d92000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007fc543b87000)
    libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00007fc543984000)
    libasound.so.2 => /usr/lib/libasound.so.2 (0x00007fc543676000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007fc543473000)
    libXtst.so.6 => /usr/lib/libXtst.so.6 (0x00007fc54326d000)
    libxml2.so.2 => /usr/lib/libxml2.so.2 (0x00007fc542f05000)
    libxslt.so.1 => /usr/lib/libxslt.so.1 (0x00007fc542cc5000)
    libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007fc542a75000)
    libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007fc542843000)
    libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007fc54258d000)
    libffi.so.6 => /usr/lib/libffi.so.6 (0x00007fc542384000)
    libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007fc542111000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fc541ee8000)
    libplds4.so => /usr/lib/libplds4.so (0x00007fc541ce4000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fc541aba000)
    libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007fc5418aa000)
    libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007fc541674000)
    libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007fc5413e0000)
    libicuuc.so.59 => /usr/lib/libicuuc.so.59 (0x00007fc54102f000)
    liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007fc540e09000)
    libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007fc551683000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fc540c05000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fc5409ff000)
    libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007fc5407d3000)
    libicudata.so.59 => /usr/lib/libicudata.so.59 (0x00007fc53ecc0000)
    libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007fc53eaaa000)
    libcap.so.2 => /usr/lib/libcap.so.2 (0x00007fc53e8a6000)
    liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007fc53e692000)
    libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007fc53e383000)
    libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007fc53e16e000)


Would love if anyone knew how to fix this.
Dawn of Transcendence
#615 - 2017-05-17 16:50:11 UTC  |  Edited by: Roesjka
I am running Debian Stretch 64bit (Mul;tiarch) on my notebook Lenovo y50-70 and
desktop pc. See my bio ingame for full hardware and software spec.

Shortlist:
Wine-Staging 2.80
EVELauncher Linux (no steam needed) with Custom Wine (Wine-Staging)
libcrypto.1.0.2
libssl.1.0.2
No need anymore for libcrypto.1.0.0 or libssl.so.1.0.0

Make a script i.e "eveliblinks.sh" or something like it in the directory above evelauncher with the
following lines:

---

#!/bin/bash

CRYPTLIB="/usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2"
SSLLIB="/usr/lib/x86_64-linux-gnu/libssl.so.1.0.2"
# Change the paths to wherever you have installed evelauncher
EVECRYPT="/path/to/evelauncher/libcrypt.so"
EVESSL="/path/to/evelauncher/libssl.so"

# Check if libcrypt.so exist in evelauncher directory, if not create it.
if [ ! -f "$EVECRYPT" ] ; then
ln -s "$CRYPTLIB" "$EVECRYPT"
fi

# Check if libssl.so exist in evelauncher directory, if not create it.
if [ ! -f "$EVESSL" ] ; then
ln -s "$SSLLIB" "$EVESSL"
fi

---

Run this if evelauncher doesn't start.
For me without libcrypt.so the launcher doesn't work.
Even tested the evelauncher with DX11 and I must say kudo's to the Wine devs
for the progress they made in the last 6 months.
Only had to turn the brightness higher and Shader Quality to medium in EVE
under DX11.

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Dream Fleet
#616 - 2017-05-19 16:50:50 UTC
Tried script above with no success:( Debian testing 64-bit - launcher still hangs with no errors. Any other solutions maybe?
#617 - 2017-05-20 05:22:22 UTC
Chupalav Al-Caucasus wrote:
Tried script above with no success:( Debian testing 64-bit - launcher still hangs with no errors. Any other solutions maybe?

see https://forums.eveonline.com/default.aspx?g=posts&t=517871&find=unread
Dream Fleet
#618 - 2017-05-20 06:20:08 UTC
God bless you,man :D
Will leave it here in the main thread


Boyamin wrote:
I am running stretch and have the same issue after updating. I solved it by running:

apt-get install libssl1.0-dev


Background: QT does not support the openssl version 1.1 shipped by debian, which is linked by default as a shared library. Installing the dev header files the evelauncher linker switches to the older version of libssl.

Minmatar Republic
#619 - 2017-05-24 06:03:02 UTC
helloo

been playing eve for about a month now. I have had occasional issues with the launcher that i've been able to resolve with systemlinks and such from this thread, but it seems like after a recent update the launcher no longer works correctly.

I currently get the following after running sh evelauncher.sh in terminal:

[0523/230042:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /(launcher)/translations/qtwebengine_locales. Trying application directory
[2 lines indicating Steam API failed which are normal since I’m not running steam]

The window for Eve Launcher appears, but does not render and just appears as a white screen. The status bar icon appears which allows me to change settings, but I'm unable to log-in and launch the game.

let me know if any additional information might be useful. running Arch with i3wm and dmenu, hardware: 6600k, 980gtx with proprietary nvidia drivers, 16gb ram.


gonna go to bed. wondering if anyone else is encountering this or not... hmmm...
Getting There... Eventually...
#620 - 2017-05-24 07:19:17 UTC
Sabrina Winslow wrote:


The window for Eve Launcher appears, but does not render and just appears as a white screen. The status bar icon appears which allows me to change settings, but I'm unable to log-in and launch the game.


Does it make a difference if you change the 'Enable hardware rendering' checkmark?


The message about Steam and the translations are harmless, since I have the same messages and the launcher works just fine.
Forum Jump