Macintosh

 
^ Back to top

Topic is locked indefinitely.

 

EVE Online: Crucible 1.5.3 patch for Mac

Jump to first DEV post
Author
C C P Alliance
#1 Posted: 2012.03.20 11:51  |  Edited by: CCP Navigator
Due to deployment issues, the EVE Online: Crucible 1.5.3 Mac patch is being delayed. We are working on resolving this problem as soon as possible and will announce the patch availability in due course.

Thank you for your understanding.
CCP Spitfire | Marketing & Sales Team
@ccp_spitfire
C C P Alliance
#2 Posted: 2012.03.20 12:10
The Mac patch has now been deployed. Players may initially experience a slow download speed and we are investigating this right now.
CCP Navigator -Community Manager
#3 Posted: 2012.03.20 20:29
Didn't work.

http://pastebin.com/mZCHHa6G
http://pastebin.com/6XBZ0Z8v

same error I've been seeing for the last week.

How can i bypass the broken launcher and apply patches manually? It's been a week since I could run eve on my macbook pro.
#4 Posted: 2012.03.21 12:35
Glarbl Blarbl wrote:
Didn't work.

http://pastebin.com/mZCHHa6G
http://pastebin.com/6XBZ0Z8v

same error I've been seeing for the last week.

How can i bypass the broken launcher and apply patches manually? It's been a week since I could run eve on my macbook pro.


Same error here, downloaded client afresh today. Filename was eve-premium_007867_352940-mac.dmg - just to make sure we're talking about the same file here.

As mentioned in 1.5 Mac issues thread, the launcher version included is still 1.04. I understand the Windows version was 1.11 for 1.5.3. Will the Mac client launcher be updated soon?
Goonswarm Federation
#5 Posted: 2012.03.21 13:53
started client, and it says 17mb patch - press yes, it downloads and does nothing, tried the common.ini delete and tried a reinstall from an old .dmg file i have of the client - i don't really want to have to download 5gb again....
Gallente Federation
#6 Posted: 2012.03.21 14:17
I reverted my MacBook Pro back to January using time machine. Reinstalled the latest Eve, and the launcher worked on a non-updated OSX.

After installing this patch on my OSX http://support.apple.com/kb/DL1505 (Mac OS X Update Combined 10.7.3) And running the Eve launcher I get this error
"No connection could be made to the content server. Please make sure that your Internet connection is up and retart the Launcher."

If I open the Eve file directly by "Applications > Eve online (show package contents) > Contents > Resources > Eve Online"
It starts the game, however asks to install a patch, if you select yes Eve will shut down and nothing else happens. Nothing installs. If I rerun the game, same issue.

Hope this helps narrow the issue.
Goonswarm Federation
#7 Posted: 2012.03.21 15:38
Stavos Kelley wrote:
I reverted my MacBook Pro back to January using time machine. Reinstalled the latest Eve, and the launcher worked on a non-updated OSX.

After installing this patch on my OSX http://support.apple.com/kb/DL1505 (Mac OS X Update Combined 10.7.3) And running the Eve launcher I get this error
"No connection could be made to the content server. Please make sure that your Internet connection is up and retart the Launcher."

If I open the Eve file directly by "Applications > Eve online (show package contents) > Contents > Resources > Eve Online"
It starts the game, however asks to install a patch, if you select yes Eve will shut down and nothing else happens. Nothing installs. If I rerun the game, same issue.

Hope this helps narrow the issue.



i have 10.7.3 installed so that might be related to it, but there is no way in hell I'm reinstalling osx my os tanked when 10.7.3 released so current install is like a month old - guess ill just use parallels....
Liberty Alliance
#8 Posted: 2012.03.21 16:17  |  Edited by: oldfrogger's broda
I tried to update via launcher (from the yesterday working patched client )
got message on update failure ...

next time launcher showed full yellow bar ... and PLAY button ...

start lead only to showing message
Verification Failure

======

workaround found !

open Applications in finder
-> Eve online.app (or just Eve Online)

-> right click Show Package Contents

then
Contents/Resources/EVE Online.app/Contents/Resources/transgaming/c_drive/Program Files/CCP/EVE

(or just Find .ini in "Eve Online.app")

and delete
common.ini

then restart client
#9 Posted: 2012.03.21 20:04
So since we're still on launcher v1.04 I assume my macbook will still not be able to run eve.

And no word from any CCPers aside from "We successfully released a patch".

Hope they have fun at the fanfest, it's probly going to be the last one anyone attends, having given up on this game that has been fubar'ed.

At least I'm back at home so I can play on my desktop... Until I have to go on the road again.

I will never buy another plex with dollars from CCP again. They have lost all the goodwill they gained with Crucible version 1.
Gallente Federation
#10 Posted: 2012.03.21 21:33
Just in case anyone is wondering. It does not appear that the multithreaded open-gl issue is resolved with this patch or the 1.5.4 one.
#11 Posted: 2012.03.22 22:42  |  Edited by: chbm
The updater fails on both my Macs. I won't renew my subs till the mac client is fixed.

Btw, for me it fails cause the installer assumes I'm on a case insensitive FS.
DORKS.

Glarbl Blarbl wrote:
So since we're still on launcher v1.04 I assume my macbook will still not be able to run eve.

And no word from any CCPers aside from "We successfully released a patch".

Hope they have fun at the fanfest, it's probly going to be the last one anyone attends, having given up on this game that has been fubar'ed.

At least I'm back at home so I can play on my desktop... Until I have to go on the road again.

I will never buy another plex with dollars from CCP again. They have lost all the goodwill they gained with Crucible version 1.
#12 Posted: 2012.03.23 00:17
I don't think it's due to case-insensitivity. I have two computers I run eve on which are case-sensitive, but only the macbook pro has been borked by the launcher.

Funny thing is that the desktop is a hackintosh.

Anyway... tried doing a fresh install, again for the millionth time since the launcher was spawned of the demon.... At least this time I got different errors.

Behold:
http://pastebin.com/1n90wDWe

Thanks for making it easier to get at the logs devs. That is definitely appreciated.
C C P Alliance
#13 Posted: 2012.03.26 16:24
Glarbl Blarbl wrote:
I don't think it's due to case-insensitivity. I have two computers I run eve on which are case-sensitive, but only the macbook pro has been borked by the launcher.

Funny thing is that the desktop is a hackintosh.

Anyway... tried doing a fresh install, again for the millionth time since the launcher was spawned of the demon.... At least this time I got different errors.

Behold:
http://pastebin.com/1n90wDWe

Thanks for making it easier to get at the logs devs. That is definitely appreciated.

Do you happen to have the rest of the launcher.log to go with that exception? I've been looking at the exceptions you posted on your pastebin account, and having the full log is very useful.

Also, did you rename your share? I noticed in one log, your share was apps_music and now it's appsmusic (without the underscore) and I'm just trying to establish what you've changed and what's stayed the same.
EVE Launcher - Team Special Circumstances
Caldari State
#14 Posted: 2012.03.27 15:28
The patch still isn't working for me and I've been unable to access EVE and change my training cue since this whole Mac patch disaster started. Seriously thinking of quitting EVE for good. This is just insane.

I launch EVE then get a mandatory patch install. That runs (ostensibly installing the launcher), then it closes after a few minutes. Later I try to launch EVE again, but it just repeats the process... again and again.
#15 Posted: 2012.03.27 23:25  |  Edited by: Glarbl Blarbl
CCP Atropos wrote:
Glarbl Blarbl wrote:
I don't think it's due to case-insensitivity. I have two computers I run eve on which are case-sensitive, but only the macbook pro has been borked by the launcher.

Funny thing is that the desktop is a hackintosh.

Anyway... tried doing a fresh install, again for the millionth time since the launcher was spawned of the demon.... At least this time I got different errors.

Behold:
http://pastebin.com/1n90wDWe

Thanks for making it easier to get at the logs devs. That is definitely appreciated.

Do you happen to have the rest of the launcher.log to go with that exception? I've been looking at the exceptions you posted on your pastebin account, and having the full log is very useful.

Also, did you rename your share? I noticed in one log, your share was apps_music and now it's appsmusic (without the underscore) and I'm just trying to establish what you've changed and what's stayed the same.


Thanks for the response, Atropos.

It looks like it may well be a case-sensitivity issue, the root partition on my desktop is indeed case-insensitive.

I'll try another go at re-installing from scratch in a bit here and post the log files -- they're too big to post on pastebin currently since I tried to launch eve once after the initial run.

There is a workaround that was developed when steam made the same error and failed to correct it, but it's extremely painful and must be done each time the launcher (or steam) is updated.

EDIT:

Log file is still too big to post to pastebin, can you PM me Atropos and I'll email the file to you? Ofc, looking at the log file I would lay money it's on the case-sensitivity issue. And can we please avoid telling me I'm using my computer wrong for having a case-sensitive filesystem: I have my reasons and no-one on the eve forums is going to convince me to reformat.
Forum Jump