Linux

 
 

DX11 with Dev Version

Author
Ushra'Khan
#1 - 2017-05-02 23:09:03 UTC
Ok. So the other day I had some horrible horrible instability and crashing. I cleared the cache, and then used the settings in the launcher to bump up to 'dev versions' wine. This fixed my instability. I Selected ccp-master dev branch and wine version currently is sitting at wine-2.6-ccp-master-27.

I still need to run it with DX9 turned on though. Are some of you getting DX11 working with this particular build or are you rolling your own?

Video driver version is nvidia-375.39 if it happens to make any sort of difference.
Ushra'Khan
#2 - 2017-05-12 03:42:23 UTC
Alright, so I'm guessing after a week of no reply, that nobody is getting dx11 to work on the supplied version of wine 2.6.

I've tried a few things and not gotten anywhere it seems.
Roughly 60% of the way through the log I see a little red error stating:

(info) Found video adapter output "\\.\DISPLAY1"
(error) No valid display adapter found
(info) Terminating process by request - returning 12


Yet the log doesn't end there, it continues trucking along just fine it seems. Near the end of the logs before it actually ceases to excecute it says a lot of:

(info)"fixme:d3d:wine3d3_check_device_multisample_type multisample_type17 not handled yet."
(info)"fixme:d3d:wine3d3_check_device_multisample_type multisample_type18 not handled yet."
(info)"fixme:d3d:wine3d3_check_device_multisample_type multisample_type19 not handled yet."

up through number 32.

It finally dumps out with handful of (info)....not error...:
"fixme:dxgi:dxgi_output_GetDisplayModeList iface 0x1b2fa0, format DXGI_FORMAT_B8G8R8A8_UNORM, flags 0, mode_count 0x339370, desc (nil) partial stub!"
"fixme:dxgi:dxgi_output_GetDisplayModeList iface 0x1b2fa0, format DXGI_FORMAT_B8G8R8A8_UNORM, flags 0, mode_count 0x339370, desc 0x2482b58 partial stub!"
"A traceback has been generated. It has been logged in the log server as stacktrace #1\r"
"C:\\tq\\code.ccp\\certifi\\core.pyj:53: DeprecatedBundleWarning: The weak security bundle is being deprecated.\r"
"\r"
"Terminating process by request - returning 12"
Process 23510 finished with exit code 12


I'm not much of a troubleshooter when it comes to DirectX or wine. I have a very strong urge to run winecfg and click around in it though, but can't seem to figure out how to run the included version of wine's winecfg. The game runs beautifully on dx9, just seems to puke out on dx11 and all I seem to get is a crappy message about a display suddenly not being found when it finds it fine with 9, and errors that I imagine go away if people with other builds have it working.

Anybody have any thoughts?
Dawn of Transcendence
#3 - 2017-05-17 17:47:06 UTC
Which distro do you use?

See for some ideas

https://forums.eveonline.com/default.aspx?g=posts&m=6943810#post6943810

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Ushra'Khan
#4 - 2017-06-07 01:53:11 UTC
I think you misunderstand the point. The point is to find out if dx11 works on the 'stock' supplied by the launcher, or dev version wine supplied by CCP...just like on the mac clients.

I was asking with the intent of figuring out if it all worked on dx11 without mucking about building wine-staging / custom wine.

It doesn't work. Which is sort of implied by the fact that you made a long post finding the way to custom build a working one. If it worked out of the box only the best masochists would bother building their own each tiny little wine/nvidia/kernel revision to try and squeeze .2% framerate increases out. :) Most of us don't care that much about a couple percent.
#5 - 2017-06-14 13:16:06 UTC
I had crashes on wine… I think 2.7 and since then have stayed on dx9.
The kind of crash that actually crashes my computer. Like, for no reason, my comp freezes. with or without the staging options.

I think ill give it another try since I just updated to wine 2.10 and graphic drivers update.
Forum Jump