Arch Linux. Executable closes immediately upon opening

Not sure what the problem is, it was working fine up until a few days ago. Here are my logs. Can anyone help me make sense of this?

The relevant bit seems to be:

2017-10-05T15:56:41.516Z default debug "X Error of failed request: BadWindow (invalid Window parameter)“
2017-10-05T15:56:41.516Z default debug " Major opcode of failed request: 10 (X_UnmapWindow)”

But my searches into opcode 10 “X_UnmapWindow” haven’t led me to any solutions.

What version of wine are you running? What drivers are you using?

I’ve tried with the wine bundled with the linux launcher, which is I am not sure what version, and have tried with my system wine, which is version 2.18

Okay, and what graphics drivers are you using?

Also, check these out, maybe they’ll help:
Steam Community

I have just been using my integrated graphics card and whatever driver the archlinux wiki suggested for my model. Have had no problems with it thus far. I checked those links but unfortunately none of them seem related to my issue. I’m really not sure where to go from here.

I’m also running Arch, and I’m experiencing the same issue, executable closing instantly after start, after switching the game to fullscreen mode. Before switching to fullscreen mode, the game started, but would close immediately when I clicked outside of the chat and menus, such as to move the camera. I actually switched to fullscreen from windowed to try to diagnose that issue.

I have an NVIDIA GeForce GTX 765M, and use the nvidia proprietary drivers.

I, too, have this problem. Thinkpad T430s with an NV5200 with Bumblebee; no difference if the card is enabled or not. EDIT: I saw someone had a similar-sounding problem and fixed it by rolling back libdrm (both 32-bit and 64-bit libraries). I tried doing this but it made no difference.

Problems here as well. Game closes as soon as I try to drag something. Viewing emails, reading chats all works fine, but if I try to drag something (like a window or camera) the game crashes.
Running arch 4.13.5, Nvidia 970 gtx with Nvidia drivers 387.12.

017-10-05T15:56:41.516Z default debug " Serial number of failed request: 267"
2017-10-05T15:56:41.516Z default debug " Current serial number in output stream: 270"

Mismatched there? Not sure how that would happen… perhaps you have the nvidia prop driver but ‘nv’ instead of ‘nvidia’ in your xorg.conf? Badwindow is typicaly a display mode problem or lack of DISPLAY env at all. xrandr issue maybe? Direct3d Alwaysoffscreen might help you?

Good Luck

  • M

So it seems that this bug is Arch-linux specific, for now. If anyone has a counterexample, please post.

Running the client with logging gives me two interesting errors before the client crashes.

“err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.”


“err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.”

I have tried putting my system’s libgnutls into the launcher directory (stripping version number, as with openssl), to no avail, the error still persists.

Do any other Arch Linux users see these errors when running the client with the “run clients with logging” setting enabled in the launcher?

Some of the errors that I get are:
err:module:load_builtin_dll_failed to load .so lib for builtin L"winemp3.acm": libmpg123.s0.0: cannot open shared object file: No such file or directory

Device reset attempt failed - 9976086C: D3DERR_INVALIDCALL

Second device reset attempt failed - 8876086C: D3DERR_INVALIDCALL

err:winsock:interface_bind Failed to bind to interface, receiving broadcast packets will not work on socket 05a8

err:winsock:interface_bind Failed to bind to interface, receiving broadcast packets will not work on socket 05a8

Worth mentioning is that the client crash doesn’t generate any errors of visible logs in EVE LogLite.
I wouldn’t mind uploading a log file to CCP if they are interested.

Same issue here on Arch Linux. It was working perfectly fine until a few days ago. The final error with logging enabled is “BadWindow”, but I don’t see any other errors in the log.

I as well have been experiencing the same issue. Running Antergros’ version of Arch with the KDE Plasma desktop on AMD R9 270X. Up until 10/6 everything was working great. And now either the client crashes as soon as I see the window or crashes when I click anywhere outside of the overlay / menu windows.

EVE LogLite is not providing much but I am seeing the same errors as others here,

"err:ntdll:RtlpWaitForCriticalSection section 0x19b888 \"xaudio_dll.c: XA2SourceImpl.lock\"

and this one

"err:module:load_builtin_dll failed to load .so lib for builtin L\"winemp3.acm\": cannot open shared object file: No such file or directory"

When I first started playing with EVE on linux I had an issue with some files not being the correct version, more specifically not the correct file name. I wonder if the same thing is happening with
Will try playing around with it today and report back later with what I find if anything.

Is there some way to check what packages were recently updated? Maybe we can find something there

Did you enable client logging in the launcher settings? For me I don’t see the BadWindow error in the client logger, only in the launcher logs. I think the BadWindow error is the result of X trying to perform an operation on a window that has crashed previously due to another error.

Yes, I’ve been watching the client logs as it starts the game. Actually, now I also see “err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.”. There are also these lines. Relevant?

What are those lines from the pastebin from? I haven’t seen those before. I also did get the libgnutls error, was there an update to that that broke it or something?