Client start exception after today update - steam [SOLVED]

Hi, any one else is getting this?

"EXCEPTION #1 logged at 10/13/2021 12:09:44 : Unhandled exception in <TaskletExt object at 0xd7e3808, abps=1001, ctxt=None>

Formatted exception info: ImportError: DLL load failed: Powodzenie.

Common path prefix = c:/buildagent/work/d2d8a22a74178531/eve/release/release

Caught at:

/packages/bluepy/ CallWrapper

Thrown at:
/packages/bluepy/ CallWrapper
/carbon/common/lib/ Startup
/carbon/common/script/sys/ Run
/carbon/common/script/sys/ _BuildClassMap
__builtins__ = {'AUR': 30,
'ArithmeticError': ,
'AssertionError': ,
'AttributeError': ,
__doc__ = None
__file__ = None
__loader__ = None
__name__ = None
__package__ = None
__path__ = None
_make_user_object = None
client = None
client_instance = None
ext = None
get_client = None
imp = None
json = None
logger = None
logging = None
monolithconfig = None
on_client = None
os = None
platform = None
sdk = None
set_user = None

Thread Locals: session was 
Stackhash: 1824858896
Reported from: logmodule

It worked today morning no game don't start ... tried with proton 5, experimental and 6.19-GE-2

Not only Steam, also the Windows Launcher under wine …




My man… thank you! Will update and verify/confirm once I have a chance.

I guess we should keep a copy of the pyd file in case this change gets pushed to the TQ launcher before it’s resolved via Wine?

Update - Just tried this out. It works.
Wanted to point out that you need to run the launcher first, then copy while it’s running. If you copy before the launcher is run, the launchdarkly_client.pyd will be deleted when the launcher starts. Also, similarly you will have to cp the file into the directory again every time you run the launcher, as when the launcher starts, it will delete the launchdarkly_client.pyd file

Workaround …


Client not starting after todays patch on linux using wine staging 6.8, launcher version 1950381

there are workaround just in this topic.

1 Like

Works 4 me 2.

Thank’s a lot for putting this workaround here, saved my day.

It works thx

And for those who are still scratching their heads about where launchdarkly might actually be located on their system (since Windows addresses aren’t very informative), mine on a Linux Mint system was in ~/.local/share/Steam/steamapps/compatdata/8500/pfx/drive_c/EVE/SharedCache/tq/bin64/launchdarkly_client.pyd. You may need some adjustment if Steam stores the game’s files somewhere different.

than you @ mrkaczor

your workaround works for me


its not mine :slight_smile: thank guys who are testing SISI clients on linux haha

FYI for perm fix change launchdarkly_client.pyd file access to read-only launcher wont delete it :smiley:


After copying launchdarkly_client.pyd once, setting the file permission to read-only solved the issue of Launcher deleting this file for me.

If this works for you, essentially a permanent fix until CCP decides to break again :slight_smile:


For those that don’t have SISI installed, where can we get a working launchdarkly_client.pyd?

I have that file but it’s not launching the game on TQ.

copy it from wherever you have it ( [EVE Folder]/SharedCache/tq/bin64/launchdarkly_client.pyd) to [EVE Folder]/SharedCache/tq/launchdarkly_client.pyd … change file permissions to read-only


That would be

~/.steam/debian-installation/steamapps/common/Eve Online/SharedCache

That works, thanks.


Thanks, it works for Tranquility

Solution for me (Linux Mint MATE 20.2, I use Lutris (Steam version hates me…))
For some reason I have both sisi and tq folders in
(and both are created at next lauch if I delete them)
So from sisi or tq /bin64 I copied launchdarkly_client.pyd to
set permissions to read only and game launched.
Copying file to sisi folder didn’t work.

1 Like

Hmmm, this is not working for me. I tried

cp ~/.eve/wineeve/drive_c/tq/bin/launchdarkly_client.pyd ~/.eve/wineenv/drive_c/tq

while the launcher is running but no joy. This appears to me machine specific, as it works on another one. I am guessing there is a random copy of launchdarkly around somewhere.

Thoughts welcome.

Found the reasons for the difference between machines. The one using a custom wine (i.e. /usr/bin/wine) fails, the one using the internal version succeeds. So unchecking “Use Custom Wine” in the launcher settings is my workaround.

I am using pop-os 21.04, today before DT (before the new patch) everything working fine using PROTON 5.0-10 since like forever ! After DT game launcher runs but when launching a client CPU shows its doing stuff but no EVE Character login window appeared. I tried different PROTON version and only the Experimental version would get to the same position with the same results.
I uninstalled EVE and went into the directory deleting what was left 18.6gb !
The directory Steam installs eve into is .steam/debian-installation/steamapps/common/Eve Online
In this directory is SharedCache which has a tq directory with the said launchdarkly_client.pyd file, this file exists no where else. I don’t have a sisi directory either. When running EVE the launchdarkly_client.pyd like all of the files in that directory are not recreated.
I think CCP need to fix this. I prefer not to use the PROTON Experimental as issues like this can occur at random times when they are continually updating PROTON thats why I stuck to a version that worked up until now that is !
Ok finally found the issue for me. Basically doing the copying of launchdarkly_client.pyd makes the game run, but for me I cannot use the Hardware Renderer setting in the launcher because when starting the launcher next time around the launcher will just crash and since you can’t or at least I can’t see how to undo this setting this means an uninstall/re-install ! Maybe for most users this wont be a problem running without using the GPU but since I am a multi-boxer, to have fps at 8-12 fps instead of a solid 60fps and CPU usage at 90-96% rather than 75% makes EVE unplayable. AMD 3900 + RTX 2070 using 470.63.01 driver, 32Gb Ram.