EVEMon 4.0.11 - ESI Edition

(Shuckstar) #246

Getting the same thing, 1 job finished yet EvE Mon says 2.

(Rapscallion Jones) #247

It’s a long standing issue, and not a killer but when you can look into it the Refinery and service modules do not appear in EVEMon properly, see the pntscrn EVEMon vs. Eve jobs.

The Athanor lists as a Medium Drilling Platform BPO and only the Standup Moon Drill I BPO lists as the Structure Moon Drilling BPO. The others do not even appear in EVEMon’s list of active jobs.

Again, thanks for all the great work guys!

EveMon Eve

1 Like
(Peter Han) #248

Version 4.0.6 has been released, with updated links in the original post. Users of version 4.0.1 or later will receive an automatic update prompt.
This release fixes more bugs and crashes; thanks to all in the community who reported bugs and contributed fixes for some of them. Key changes include fixes to some causes of duplicate industry job notifications and TrustFailure errors, along with further improvements for private citadels (including showing assets in locked out structures with “Inaccessible Structure” as the location).

1 Like
(Krysenth) #249

The chances of that are lower than the chances of your pod tanking the damage from a Doomsday. ESI is a character-based API. Account level information (plex, omega/alpha time, MPTC queue time, all of it) will not be exposed.

1 Like
(Artrat Otsada) #250

I have version 4.0, not 4.0.1, so i do not get the automatic update notification. How do I go about applying the update? Just to be clear I already have the 4.0 version and have sorted out all the developer signon stuff. I don’t see an installer file in the zip folder.

1 Like
(Peter Han) #251

Version 4.0.7 has been released, with updated links in the original post. Users of version 4.0.1 or later will receive an automatic update prompt. Users of earlier versions should install over using the EXE file in the release (not the ZIP), but see the warnings in the OP.

This release fixes more bugs and crashes; thanks to all in the community who reported bugs and contributed fixes for some of them. The Help and About menus have also been updated to EVEMon’s current website.

2 Likes
(Kiramatzu) #252

the assets searcher dont work

2 Likes
(Dacurly Dac) #253

Assets searcher works fine for me.

1 Like
(Mintoko) #254

As of 4.0.7, a character’s account status (Alpha/Omega) is reported only for the character that is currently training. When training was switched to another character, the account status was properly reflected on that second character. The first character maintained the status as before.

Update: After the client updated the skill queues, it was found that the account status stays with the character that is training. I had switched back to training the first character and the second character lost the status.

1 Like
Need dev help on character import on evemon ...didn't pay thousands of dollars all these years for this crap esi
(Werre) #255

Just thinking of ways to track subscription expiration dates. Would it be possible to add an editable field/date selector, maybe in the ESI Keys Selector window, to manually enter the subscription expiration date so EVEMon can pop up a reminder when the date is getting close? Can only add subs in 30 day chunks so maybe also a simple “+30” button to add 30 days when you plex or resub?

1 Like
(Golden Gnu) #256

@Peter_Han
Thank you porting EveMon to ESI and maintaining it. :+1:

1 Like
(Hendrik Tiberius) #257

Thank you very much for your work! This is great.
I’ll send some ISK as soon as I’m logged in next.

1 Like
(The Larold) #258

I only had 2-3 minutes to hit the forums - saw this thread. What’s the general consensus - safe to use the latest version to replace 4.0.0 with? 4.0.0. has its share of bugs, but it works for what I need. Thanks!

1 Like
(Cypher Fallen) #259

Good day!
Can anyone tell me why I show the current queue of skills, but does not show what has already been learned and also character sheet does not show implants, wallet and other information?
Thank you!
And sometimes show this error:
EVEMon 4.0.7.4839

API Error:
Error querying the EVE server status. Check EVE server uptime on http://eve-offline.net/
HTTP error: A request to esi.evetech.net failed with status: SendFailure.

1 Like
(Nyalnara) #260

Hello there. Having trouble adding api.

The app was created just fine.
Scope only includes esi-something.*:

esi-calendar.read_calendar_events.v1
esi-mail.organize_mail.v1
esi-wallet.read_character_wallet.v1
esi-wallet.read_corporation_wallet.v1
esi-clones.read_clones.v1
esi-characters.read_contacts.v1
esi-bookmarks.read_character_bookmarks.v1
esi-corporations.read_corporation_membership.v1
esi-assets.read_assets.v1
esi-planets.manage_planets.v1
esi-ui.open_window.v1
esi-characters.read_chat_channels.v1
esi-characters.read_agents_research.v1
esi-industry.read_character_jobs.v1
esi-markets.read_character_orders.v1
esi-characters.read_blueprints.v1
esi-characters.read_corporation_roles.v1
esi-contracts.read_character_contracts.v1
esi-killmails.read_corporation_killmails.v1
esi-corporations.read_contacts.v1
esi-assets.read_corporation_assets.v1
esi-corporations.read_blueprints.v1
esi-bookmarks.read_corporation_bookmarks.v1
esi-contracts.read_corporation_contracts.v1
esi-industry.read_corporation_jobs.v1
esi-markets.read_corporation_orders.v1
esi-corporations.read_container_logs.v1
esi-industry.read_character_mining.v1
esi-industry.read_corporation_mining.v1
esi-alliances.read_contacts.v1
esi-characterstats.read.v1

I then proceeded to add my characters with the SSO login button, which spectacularly failed: {"error":"invalid_scope","error_description":"The requested scopes either don't exist, or are not valid for this client"}
The url evemon redirect to was the following:

https://login.eveonline.com/oauth/authorize/?response_type=code&redirect_uri=http%3A%2F%2Flocalhost%3A4916%2Fcallback&client_id=THERE_IS_NO_REASON_FOR_YOU_TO_SEE_THIS&scope=esi-wallet.read_character_wallet.v1%20esi-calendar.read_calendar_events.v1%20esi-location.read_location.v1%20esi-location.read_ship_type.v1%20esi-mail.read_mail.v1%20esi-skills.read_skills.v1%20esi-skills.read_skillqueue.v1%20esi-clones.read_clones.v1%20esi-characters.read_contacts.v1%20esi-universe.read_structures.v1%20esi-killmails.read_killmails.v1%20esi-assets.read_assets.v1%20esi-planets.manage_planets.v1%20esi-markets.structure_markets.v1%20esi-corporations.read_structures.v1%20esi-characters.read_loyalty.v1%20esi-characters.read_medals.v1%20esi-characters.read_standings.v1%20esi-characters.read_agents_research.v1%20esi-industry.read_character_jobs.v1%20esi-markets.read_character_orders.v1%20esi-characters.read_blueprints.v1%20esi-characters.read_corporation_roles.v1%20esi-contracts.read_character_contracts.v1%20esi-clones.read_implants.v1%20esi-characters.read_fatigue.v1%20esi-killmails.read_corporation_killmails.v1%20esi-wallet.read_corporation_wallets.v1%20esi-characters.read_notifications.v1%20esi-corporations.read_divisions.v1%20esi-corporations.read_contacts.v1%20esi-assets.read_corporation_assets.v1%20esi-corporations.read_blueprints.v1%20esi-contracts.read_corporation_contracts.v1%20esi-corporations.read_standings.v1%20esi-industry.read_corporation_jobs.v1%20esi-markets.read_corporation_orders.v1%20esi-corporations.read_medals.v1%20esi-alliances.read_contacts.v1%20esi-characters.read_fw_stats.v1%20esi-corporations.read_fw_stats.v1%20esi-corporations.read_outposts.v1&state=131805872380540435

Not sure what went wrong. Removing the scope part of the url properly proceed to the character selection so something in there is obviously wrongly spelled. And callback worked properly too, which proceeded to crash Evemon because scope was empty, which was expected.

As a workaround, could someone just copy-paste me the scope part of his url so that i can just ignore the one provided by my evemon client?

EDIT: Nevermind, adding all scopes to the app fixed it.

1 Like
(Rapscallion Jones) #261

Does anyone know of a fix for losing visibility for your current contracts upon upgrade to the next version? Each upgrade causes my current contracts to disappear. Once I let new contracts they appear on my contracts page until the next upgrade comes out.

Thanks in advance.

1 Like
(Fonsui) #262

Small suggestion: The display on the skill plan window at the bottom where it indicates how many injectors would be needed would be more useful if it listed, say, for instance, 4.1 injectors as “4 large injectors and 1 small” instead of “5 injectors”.

1 Like
(Peter Han) #263

Version 4.0.8 has been released, with updated links in the original post. Users of version 4.0.1 or later will receive an automatic update prompt. Users of earlier versions can install over using the EXE file in the release (not the ZIP), but see the warnings in the original post.

This release fixes more bugs and crashes; thanks to all in the community who reported bugs and contributed fixes for some of them. A data file update pre-release should have fixed an additional issue with ship traits.

New features include the ability to show character locations (system name only) on the overview, and the ability to add custom labels to each character (possibly to denote their purpose, or account name).

5 Likes
(Giddy McFee) #264

I am getting some issues. I had previous characters from the old evemon so reset settings. I set up all the ESI things and have the client ID and secret key, when I click file there is just add character or manage characters, when I click either of those I get a box telling me to log on with eve online, I choose that and get …

error “invalid_scope”
error_description “The requested scopes either don’t exist, or are not valid for this client”

if I choose reset again, i get the screen where I can enter the client ID etec, do that, click apply or ok and I still do not get add API, only add character again

Not sure whats going wrong, can you help?

2 Likes
(Giddy McFee) #265

Looks like it was down to some of the esi scopes I had chosen. there are a lot of scopes which I dont think are neccesary, medlas, FW stats etc, allI want evemon for is to create a training plan and know what implants i have to alter the training time, which scopes do I need just to perform that task?

1 Like