EVEMon 4.0.11 - ESI Edition


(Andre Iv) #103

Yes, can confirm the same problem.
Clean install does not help


(Taji Kann) #104

+1 too.

Char summary stats are broken for me as well since 4.0.1.
Can see wallet balance by looking at journal latest entry only.
Ship/location stuck on pre latest 4.0.1 values (or perhaps 1st update thereafter)

If it matters I used:
4.0.0, then 4.0.1 then newer version of 4.0.1 as shown below

13/05/2018 16:33 7,200,572 EVEMon-install-4.0.0.exe
14/05/2018 19:42 7,193,761 EVEMon-install-4.0.1-older.exe
20/05/2018 23:07 7,197,579 EVEMon-install-4.0.1.exe <== this one broke it for me.

Indy jobs seem to be still working for me… Too scared to disable/enable :open_mouth:

update: Only thing I’ve tried to rememdy this is ‘clear cache’ form file menu. Doesn’t seem to help.


(Cookie Omega) #105

Character Balance:
4.0.0 - Working
4.0.1 - Broken


(Boothen) #106

Can’t this to work at all. Have followed the instructions to the letter. Yet after I’ve added the Client ID and Secret Key to the program, I click ‘Add Character’ and get screen asking me to ‘Log in with EVE Client’ which then just gives me this error

{“error”:“invalid_request”,“error_description”:“The callback URI doesn’t match the value stored for this client”}


(Huren Ogeko) #107

This means you entered an incorrect callback URL when you created the application on the dev page. Go back to that app you created on the CCP site edit the callback url to match exactly what you see on the instructions.


(Huren Ogeko) #108

just found this project and got it working just fine. thanks for doing this you just saved me a bunch of time making an xml to esi gateway which I was about to begin work on. Running 4.0.1 right now and its mostly working fine but very slow which is to be expected as I know first hand how clumsy it is to get bulk data calls.

The main issue I have is an odd one. When I add a char it shows up fine in terms of skills from charsheet and skill queue. But after a short while, likely on the next charsheet/skillquerue pull evemon does, it begins to think a lot of skills from my queue are actually complete in the skill plans I made.
I noticed a pattern to this: If there is more then one level a certain skill in the skill queue then all skill levels except the highest one in the queue will show up in the skill plans as completed as in no time remaining. When you click the “Obsolete Entries” link at the bottom it lists all those skills but they show up as unconfirmed because clearly they are not verified by charsheet pull.
^^SOLVED in 4.0.2

Also not all my industry jobs show up. Actually one out of 10 jobs show up and that job happens to be the only one not in a sotiyo. Its being researched in a nullsec outpost which are to be removed and replaced into citadels soon. I expect this is due to evemon not being able to see inside non-public structures as its an issue I am having right now with apps I am working on. But I just have not had time to sort out yet because my TODO list for that project is longer than Santa’s naughty list right now. Although I noticed the assets tab actually sees inside every place I have stuff as far as I can tell so its working fine from that side.

Also, it seems all my chars are located in “lost in space”. That is actually more accurate then you know.

Besides all that I really have not had time to dig into everything. and for now its an awesome program and more then I imagined would exist since api went offline. My only regret is not knowing about this project last month.
Thanks for the awesome work.


(Peter Han) #109

Version 4.0.2 has been released, with updated links in the original post. Users of version 4.0.1 or later will receive an automatic update prompt.

This release fixes a bug where character location and wallet balance may not be queried in some circumstances, and a race condition which might sometimes (depending on server latency) double count implant attributes. The invalid data will only be updated after the next character sheet update, so users may need to wait an hour before EVEMon begins to show corrected data.


(elektro drell) #110

why such a mistake?


(Huren Ogeko) #111

4.0.2 fixed almost all my issues. the problem with skills showing done in plans that were actually in the queue is solved. my guys are no longer “lost in space” although they might be lost in other ways. The only thing missing is non-public sotiyo research jobs not showing up.


(Huren Ogeko) #112

Half the time that is on the ccp end probably. The old API Evemon used to throw random timeout messages like that from time to time. Evemon will retry the query after a short break and it will likely work next time.


(Brock Khans) #113

My issues with the attributes which affected skill plans is good to go now as well in 4.0.2


(JuuR Zibaoo) #115

got no update info so far
where can i download the installfile?

edit:
found it https://github.com/peterhaneve/evemon/releases/tag/4.0.2

JuuR


(GargantorX) #116

Still no industry job displaying with 4.0.2 :sob:


(JuuR Zibaoo) #117

hi @Peter_Han

i know its not that important but is it possible to update the About EVEMon page?
insert a downloadlink?
insert a forum link?
take out eve-central link?
maybe get in contact with the guy who owns https://evemondevteam.github.io/evemon/
maybe contact the guy who own the EVEMon Twitter channel?

thx

JuuR


(Dyver Phycad) #118

I see industry jobs at least since 4.0.1.


(Rapscallion Jones) #119

Same here


(Erik Kalkoken) #120

Indeed an app can decide to use just a subset of Oauth scopes that are included in the token. Assuming your statements are correct evemon is apparently only using read scopes. Still the app technically has full write access to everything and can request additional tokens at any time, which was my point in the first place.

You may not be aware, but most big alliances are not using any web based tools, because some are used to gather intelligence. e.g. Peter is part of TEST and you can be sure that any non-friendly alliance will refrain from using it.


(Alexander Sinclair) #121

EveMon 4.00 is hanging on Minmatar Tactical Destroyer 5 and any future skills I train it keeps re notifying me they finished I updated to 4.02 and it said Minmatar Tactical Destroyer 5 is complete I will check back in if it keeps re notifying me along will all future skills so far though so good, even though it notified me Minmatar Tactical Destoryer 5 is complete despite it not being the most recently completed it seems to have only done that once, if it happens again I will bring it to a bug report.

EDIT: 4.02 really loves telling me minmatar tactical destroyer 5 is done, seriously its like the program has a thing for that skill. EDIT: I reset some of the settings it doesn’t seem so hooked up on Minmatar Tactical Destroyer 5, I will see how this goes. EDIT: it stopped annoying me about it because I backed up to a pre-ESI version, I just tried deleting the character and it still keeps saying Minmatar Tactical Destroyer 5 was recently completed along with 4 other skills.


(Huren Ogeko) #122

If your jobs are in an outpost or npc station they show up. If in a citadel then they only show up if it is a public citadel. this is due to the way esi handles private citadels. It also affects what market orders the market endpoints will display as well. I think there is a way to get the station ids of private citadels then manually check each one individually but its likely a bit of work if even possible in terms of industry or market orders. I have not gotten that far into using ESI to know how to get those stationids of the private stations but its on my todo list for one of my own projects.


(Huren Ogeko) #123

It is probably because you are using a non-public citadel/engineering complex. I am sure evemon will eventually have a workaround for getting those via stationids