Help us test Beta build for Android compatibility improvements

Hey pilots,

First of all, many thanks for reporting compatibility issues on Android devices! We started off supporting a certain range of phones, but certainly not the full range (we will share more details in the near future for those who are curious to know why).

We now have a beta build with compatibility improvements for those of you who would like to give it a try and report issues if any. We understand that our testlab doesn’t cover the full range of Android phones, therefore we expect bugs in this beta build.

If you are willing to give the beta build a try, you can open the following link on your Android phone’s browser and follow the instructions to install the beta build
https://play.google.com/apps/testing/com.ccpgames.eveportal2android

Note that if the build is not visible to you, that might be the build hasn’t been fully rolled out to all of the regions, although we started the roll out several hours ago, the full roll out may take up to 24 hours to complete.

Please do let us know if the build works for your Android device or not; either way, we will appreciate if you can please provide the following information:

  • OS version, for example “Android 7” or “iOS 12.4”. This info can usually be found under your phone’s Settings
  • Device Name, for example “Pixel 2” or “iPhone 7”. This info can usually be found under your phone’s Settings
  • Model Number, if applicable, for example “SM-G975U1” or “MT1J2CH/A”. This info can usually be found under your phone’s Settings

You are welcome to reply to this post to share your results if you like. Alternatively, if you would like to report issues to us privately, feel free to send your bug reports to eveportalbugs@ccpgames.com

Looking forward to hearing from you!

o7
The EVE Portal Team

4 Likes

Samsung Galaxy A10e Model number SM-A102U running Android 9 seems to be working fine. Had to open the google play store page in my PC browser instead of my phone to see an install option.

1 Like

Works fine on my HTC Desire 555 phone that runs Android 7.

1 Like

Thanks for the quick update! Much appreciated!:upside_down_face:

Android 9
Samsung Galaxy S9+
SM-G965F

Works fine (it did before too)

1 Like

Android 9.
Pixel2 XL rev_10

Problems with it marking mail as read and updating the number of unread mails and the read mails then becoming “unread” again.
Otherwise, loads and runs happily, no other issues spotted.

1 Like

Works on
LineageOs 14.1 / Android 7.1.2
Nexus 5

1 Like

Android 9
Oneplus 5 (Oneplus A5000)

Works great.

1 Like

Android Nougat 7.1.1
Motorola Nexus 6
XT1103

Install, launch, UI, functionality all good. :ok:

1 Like

Android 9
Samsung Galaxy J7
SM-S767VL

It seems to work fine, but it didn’t before… Thanks!!!

Edit: I mean that the Google Play Store showed that it was incompatible before so I couldn’t download/install it.

1 Like

Android 6.0.1
Blackberry DTEK 50
STH100-2

Worked fine with the normal app. As soon as i installed the Beta in it chrashed on startup 100% of the time, even after restart, on wifi and mobile data. The first background picture still shows up and than it crashes. It is the same error other people noted already: “Unable to find native library: UE4”
It should be noted that notifications still show up, so I guess the app does actually run in the background but just doesn’t open.

From what I saw in the non beta app, honestly a great start for a proper eve app.

1 Like

Android 5.0.1
Samsung Galaxy S4
GT-I9505

Beta working fine so far
Published version shows “device not compatible” in Google Play

Findings, that requires improvement:

  1. App ignores mute setting of device and plays music and sound in muted status: It should respect muted status … or provide an option to override mute

  2. App can not be closed normally. The only way is to force displaying the home screen via home button and shut it down under Active Apps, which is technically a “hard shutdown” like using the task manager on PC.

  3. The option to move the App on SD card is not available.

That’s it from my side so far.

1 Like

Currently not working for me:

Galaxy S5 Neo (SM-G903F), Android 6.0.1

Application seems to start, I can see the background image but then I get the “… stopped working” popup.

The actual error seems to be “Unable to find native library: UE4”

I also sent a report using the resulting feedback option. I have no idea who got it, though.

Android 7.0
Samsung Galaxy Note 5
SM-N920V (SM-N920V.04)

Seems to work fine! Added 7 or 8 characters to it, just couldn’t figure out if there’s a way to reorder them.

is there a beta version for iOS? If so I would love to test it also.

works on Pixel 2 Android 10
works on Nexus 5X Android 8

ok i tryed to install it on my old tablet its a LG V500 G Pad 8.3 with a custom 9
i could install it from the market … i can start the app … i can login a char … its slow as hell but its a VERY old tablet … if it is running on this thing … its running nearly everywhere

thanks guys

JuuR

I was able to successfully and easily download, install, and log on with my primary account using this beta version of the app. My phone is a Samsung Galaxy J7 Refine, model #SM-J737P, running Android v. 9.

As was mentioned before, there really needs to be a scroll option for the log in screens because keyboard covers over the password field, as well as the security verification code field. I’ve gotten real good at blind typing my password but would be nice if you offered the little “view password” option as well as making it so that the screens scroll to allow you to see both keyboard and field you’re typing in. I know I’m beating the dead horse but maybe the more you hear it the faster it gets fixed: :wink: :sunny:

Once I’m in the app, it seems to work perfectly. The different pages load quickly. I was able to easily manipulate my skill queue. The NES – dare I say it – is actually easier to browse on the phone app than ingame, in my opinion, so that’s nice. Not sure how much I’m going to be buying skins via my phone, but it’s surely a nice option for when I see a news item about skins while I’m at work.

So, mail. I don’t know if this is so much a bug as a design issue. I am in a NPC corp on my main (CAS forever). 99% of my communications that I care about are not showing up in my inbox, and definitely not under the corp/alliance tabs, as the CAS groups use mailing lists to notify people of stuff and to hold our discussions. In the old app, I could see the mails I’d recently received from the mailing lists under the Activity section (where the contracts and skill completions also showed up), but I’m not seeing a place in this app where I can actually view my mailing list mails. Please, please, please, include a way to view mails from mailing lists in this app before you phase out the old version of the app. Now, I do note that the home screen has a bar stating “No activities,” which may be the replacement for the Activities tab in the old app, but since I just downloaded the app it may not be detecting any of the more recent (but already viewed) mailing list items. I will keep an eye out.

Visually, it looks good. Much nicer looking than the previous app, which did look a bit dull.

I noted previous commenters mentioning the app doesn’t close normally … I did not have an issue with this. I was able to close it and reopen it without an issue.

I like the sounds, but I would also like an option to turn them off (edit: found it). I do play eve with all sounds on normally, as well, but on my phone I generally turn music off on my apps, because it tends to interfere with actual music apps.

Overall this is nice. Seems like a very nice improvement to the previous app. Please do keep up the good work on making this compatible on more devices!

1 Like

same issue, same phone

Not working (Crashing in loading screen) on my Gigaset GS270 with android 8.1.0

1 Like