Help us test Beta build for Android compatibility improvements

Device name: Nokia 1

Model: TA-1047

Android Version: 9 (was 8.1, but it made an update)

The official app is not compatible with Nokia 1.

The beta app seems to be compatible, which is great, thanks!

One major issue was the fact that when I used the phone navigation buttons to open the mail with the verification code, the app forgot its open page (I was on the verification code input page, after typing in username and password), so when I got back to it, it showed me the username and password input page again. I had to open the verification code mail on my PC in order to keep the verification code page on the phone.

Keyboard obscuring the input field was really annoying, just like other folks already reported.

App performance:

The initial loading (loading local data) is a bit slow, it loads quickly up to 49%, then it pauses and after a while it loads the rest of the data.

When browsing through mails, the app is a bit unresponsive, takes time to load, takes minutes to load a large mail. A bit unstable in that regard. Freezes the phone while loading a mail and almost nothing can be done to exit the app or use navigation on the phone. It is scary. Today I tested it again and when loading a mail it froze and the app went into “not responding” state. I had to close it. I barely managed to do it actually, since the phone was unresponsive for a minute.

When browsing through other pages, it is a bit unresponsive too, had to tab twice in order to browse between my character info and jump clones info. Today it feels more responsive, loads faster, I guess data has been cached.

Overall it seems that Nokia 1 hardware is modest and has some hard time running the app. But the app is working, so that is great. Thanks for your effort to make it compatible for more phones, you guys are awesome! Keep up the good work! :heart:

Will you be able to see wallet transactions and market/contract orders in the future?

Google Pixel 3 XL, up to date.

Works like a charm. Only issues are:

  • the fullscreen is a little annoying, need to swipe up to show the navigation buttons.
  • back button doesn’t quit the app.

LG G3
Android 6.0

I get the “stopped working” soon after the app background is displayed.

Sent in the report which included the system log files so hope that helps.

Pixel 2 XL rev_10
Now Android 10.

Loads and runs without issue (I don’t know if the mail read/unread issue is resolved though - I’ll put a better report in e-mail when/if I can replicate it).

Can’t isntall on
Samsung Galaxy A6+
SM-A605FN
Android 9

Pixel XL
Android 10 now (was using it on Android 9 previously without issue)

No issues, seems to work fine.

Samsung Galaxy J7
Model # SM-J727U
Android 8.1.0

Everything seems to work. 2 factor authentication works

Works on Moto E5 plus now thanks for the speedy update will post any issues if I run I to any

When I open it, there is a Triglavian photo in background and the crash (Sorry, EPB stopped working). I ve also sent a detailed report.
Device: LG K8 LTE
OS: Android 6.0
Model n: LG-k350n

Device: Sony Z5 compact
Model: E5823
Android: 7.1.1

Basically works.

Bug that I found: if I browse skills and want to add one to the queue, I can click front or end. In both cases, I get a message ‘code=400: msg=user already has skill in training’. Skill is not added to queue.

I do have a couple skills in queue, but the queue is paused and should work anyways. Further, clicking inject sp next to a skill does nothing.

And please, could you introduce decimal points to prices shown? If you select buy skill, you have a hard time figure out if it is 16 million or 160 without those points.

After some deeper testing i can add the following:

  1. The app needs between 20 and 30 seconds (!) to launch every time.
    Ok, the device is 6 years old and on it’s 3rd battery but still … if you just want to quickly check the newly arrived mail, this is very inconvenient.

  2. Notifications have only worked once for the 3rd mail, that i received after installing the beta app, before and after it never worked again. I didn’t notice it earlier as i still have the old Portal app installed and the notifications were triggered by this one.

  3. The mail function itself is very unreliable. Loading an email takes between 10 seconds and never.
    It seems that these effects depend on links inside the email. Email without links load relatively fine while emails with links (especially ingame links like contracts or fittings) it is a game of luck if the mail gets ever displayed or not.

Will keep updating if i find further issues

1 Like

Its ok now ! App is smooth and fast, good job.

  • Android 5.0
  • Galaxy Note 3
  • SM-N9005

Small improvements:

  • Exit button
  • In character sheet, SP and ISK numbers need separator (space or .): 15.576.025.890 instead of 15576025890
  • And yes a jukebox would be nice :smile:

Works perfectly after the latest update.

Android 6.0.1
Samsung Galaxy J5 (2016)
SM-J500FN

So. Tried to change back to the Non beta version. That has now the same problems as posted above.
Even though the non beta worked flawlessly before i tried the beta.

So I joined the beta branch again and hope I will be able to start the app at some point.

Both beta and non beta have the same error as posted above.

Working on that, will post for that shortly.

After the latest updates, the app runs smoother on my device (Nokia 1, Model: TA-1047, Android Version: 9), the mails can be open with ease, they load instantly.

The only two issues are the initial loading screen, which seems to take too long to load and the fact that when I minimize the app (using the square navigation button on the phone) and when I get back to the app, it starts the loading procedure again.

Error here… oneplus7T… No Google Play Store Key…can you do something CCP please? I am not able to launch the app for this. Thanks
@CCP_Time_Runner

Hello! As a temporary solution, please download and install the apk file from the “Install Android build from web” link in this post: New Portal Android test build available. Please let us know if it works for you.

still no number seperators, still servertime in anoying american time format instead of 24h. whats so hard to fix it?