jEveAssets 6.0.4 (2019-05-16)

esi
tool
(Luscius Uta) #408

I recently had a hard drive failure, jEveAssets was on another disk but settings were lost and now I can’t add my characters. When I go to “Authorize” my web browser gives me “localhost didn’t send any data” message and jEveAssets is stuck on “Validating API key” screen. Is there something I forgot to do? Program version is 5.9.0 and I’m on Windows 10.

(Golden Gnu) #409

@Luscius_Uta
Thank you for your bug report.
Please, email me the logs (see the wiki: email bug reports)
Do also include your what browser you use and what version of java you have installed.
I will look into it as soon as you have emailed me.

(Luscius Uta) #410

I have just solved my problem by reinstalling Java. I wonder how jEveAssets even managed to run without errors if Java wasn’t installed properly, though :hushed:

1 Like
(Golden Gnu) #411

@Luscius_Uta
That is a good question, that I’m not able to answer with certainty, so, I won’t try.
But, good to hear your problem have been resolved :slight_smile:

(Koolook Ongrard) #412

Hi! Shortly after my trade session, after I pushed multiple items to sell orders, I checked out an update in jEveAssets and found a very unexpected boost on my account total. I inspected the assets table and shortly found that most recent and valuable assets are present both in Hangar and Sell orders. Roughly an amount of boost.
Anyone experienced similar behavior? Should I wait some time after I move assets before I can should run the program to update?

(Golden Gnu) #413

@Koolook_Ongrard
I will see if I can do anything about that.
Until then you will have to ensure everything is ready to update when you update, that is roughly once every hour, updating more than that may lead to the problem you’re having.

EDIT:
Small update on this:
It is possible to exclude sell orders that have been issued after the last asset update (fixing this problem), however, this may exclude orders that was already removed from the assets list, as editing an order also update the issued date (creating a new problem, where some valid sell orders may be missing from the tracker).
I’m not sure how to proceed, let me know what you think.

(fielix) #414

Hi Folks, I am having an issue setting up my account with EveKit. I get an error saying the entered credentials were not valid. I have hand typed and copied pasted the values from EveKit to Assets and am still getting the error.

I have waited almost 24 hours thinking maybe it was a sync issue but am still receiving it today. I generated new access keys and received the same error for all of them. Not sure if anyone else has had any similar issues to this

This is what I found in the error log:

INFO: [SwingWorker-pool-13-thread-8] net.nikr.eve.jeveasset.io.shared.ThreadWoker - Starting 1 main threads
ERROR: [pool-96-thread-1] net.nikr.eve.jeveasset.io.shared.AbstractGetter - EveKit Account failed to update for: Owner #0 ERROR: INVALID ACCESS KEY ID
enterprises.orbital.evekit.client.ApiException: Not Found
at enterprises.orbital.evekit.client.ApiClient.handleResponse(ApiClient.java:958)
at enterprises.orbital.evekit.client.ApiClient.execute(ApiClient.java:874)
at enterprises.orbital.evekit.client.api.AccessKeyApi.getKeyInfoWithHttpInfo(AccessKeyApi.java:146)
at enterprises.orbital.evekit.client.api.AccessKeyApi.getKeyInfo(AccessKeyApi.java:131)
at net.nikr.eve.jeveasset.io.evekit.EveKitOwnerGetter.update(EveKitOwnerGetter.java:46)
at net.nikr.eve.jeveasset.io.evekit.AbstractEveKitGetter.run(AbstractEveKitGetter.java:81)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

(Golden Gnu) #415

@fielix
Thank you for your bug report.
Make sure you have no leading and trailing space when you enter the api key.
I will test to see if I can reproduce it and get back to you.

(salacious necrosis) #416

You did nothing wrong. The EveKit replica fell over again (and no warning, monitoring still broken). Things are working again although may be slightly slower until the replica fully catches up. You should have access to all your data.

2 Likes
(Golden Gnu) #417

@salacious_necrosis
Thank you for the super fast fix :+1:

@fielix
Please, reply here if this did not fix your problem, otherwise I will assume this is now fixed.

1 Like
(Golden Gnu) #418

jEveAssets 6.0.0 released

New Features:
-Added Contracts Appraisal API
-Regular Expression Filter
-Added Planetary Facilities
-Added undo/redo to all text components
-Better planetary assets integration throughout the program

Bug Fixes:
-Stockpile always showed location all
-Excluded planets from the routing tool and UI menu (not valid destinations)
-Possible fix for BugId: 750

Changed:
-Tracker now ignore sell orders that is still in assets (to avoid duplicates)

Code:
-Optimization of the Routing and Overview tools
-Fixed issues found by LGTM.com
-Better Uncaught Exception Handling
-Better error handling for JSon reading and writing (BugId: 744)
-Fixed problem with Java 11 and Java 12 (still primarily developed on Java 8)

1 Like
(Kwa Zulu) #419

Getting an error when running the updater: https://i.imgur.com/az38asT.png

Windows 10

Great tool btw :wink:

(Golden Gnu) #420

@Kwa_Zulu
Thank you for your bug report, looking into it now. Will edit this post when I have more info.

EDIT 1:
I have re-deployed jEveAssets 6.0.0 and the update should work now.
The problem you’re having was from the fallback installer (used when the user don’t have write permission to the jEveAssets directory), I will continue to investigate why the installer is not working and update this post when it’s resolved.

(Kwa Zulu) #421

Works now, thanks!

1 Like
(grenville averti) #422

Is there a way to use the stored data to track down what has contributed most to a change in wealth over a period of time? The switch to 6 coincided with an almost 10% increase in my assets value over a period when assets quantity did not change (not using BPC values from contracts) and I’d like to know which price changes are accountable.

(oodell) #423

Likewise had a 10% jump in wealth, can’t figure out why

(oodell) #424

Actually figured it out, partially

Electron Bomb Blueprint (BPC) 18,001,568,700.00

Where is it getting this price from? A lot of other BPC’s have pretty wild valuations, that bomb is just the worst of them.

(Golden Gnu) #425

@grenville_averti and @oodell
The problems with the new contract prices are being tracked in the following issue: Very odd value calculations.
Please, post the blueprints you have problems with in that issues. be sure to include me/te/runs. The issue also have info on how to disable the BPC prices.

There is no way to identify the items responsible for the tracker jump in value. However, please, note that disable the BPC prices will only work for new tracker points.

(Vicktor Bout) #426

Hi,
It is possible to manually update static data, some items id-names seems missing?
If no, when are you planning to do this?
Thanks

(Golden Gnu) #427

@Vicktor_Bout
I update the static data whenever a new SDE is released by CCP.
The last one was released 2019-02-19
The following issue tracks getting static data from ESI, however, not everything needed is included in ESI at the moment so, it’s not possible to do yet.