jEveAssets 7.4.0 (2022-11-24)

The 404 on the asset endpoints is because they’re offline. As always, we (the 3rd party community) have tried to reach out to CCP to get it fixed. However, during the weekend there may not be anyone working with the expertise to fix it. It’s also a public holiday in Iceland today, so, it’s up in the air if it’s going to be fixed today or not.

2 Likes

i found a bug and im not sure if this is the place to tell. if you run jeveassets -u from a scheduled task (i like having a consistant tracker interval) then i get a negative number for contract values (i checked in game and i have nothing) if i run with UI and do a normal update then the value imports right.

Email me the log and I will look into it: How to email the log

emailed with the details - pucture too that shows the bug

I have a question about the Stockpile section of jeveassets, which looks incredibly handy.

If I have a stockpile set up for an item on the market in one particular station, is it possible for it to see ALL the orders in that station when determining surplus, or will it only ever do my characters’ orders?

It only include your orders from accounts you have added to jEveAssets. Including all orders would be possible too, but, would require I code it first. If that is something you’re interested in, please make a feature request on GitHub. The most important thing to include in the feature request is what the feature will allow you to accomplice AKA why you need it and how the feature should work, in as much detail as possible.

1 Like

a problem: Everything seems to work except for contracts.

I have 9 chars and my corp added and all of them have outstanding sell-contracts worth billions all together.
in the ‘Contracts’- tab all these contracts are shown correctly, but on the ISK-Tab the ‘Contracts’-Column shows 0.00 in each row (for all chars and the corp).
And this also affects the values in ‘Values’ and ‘Tracker’-tabs . . .
the tracker-graph for contracts is on zero since i started to use the app 4 weeks ago.

any advise ?

Maybe you’re doing corporation contracts? Those need a corporation account, see the jEveAssets wiki.
Also note that only outstanding contracts are tracked. Completed contracts are not counted, as the value is already “resolved” to either isk or assets.

all chars are in one corp and the corp is also added correctly (can see corp-assets) - contracts are individual and corp - many outstanding public sell-contracts on each char and corp - as i said i see all contracts on the ‘Contracts’-tab of your program, but the values are not added anywhere.

It’s possible it’s a bug. Please, see the OP for details about how to report a bug.

jEveAssets 7.3.0 released

New Features:
-Added filters to the Overview Tool (Issue #336)
-Added Janice as a price source (Issue #328)
-Price History (Issue #76)
-Added category column to stockpile table (contributed by Lazaren)
-Added various values to the industry slots tool statusbar (Issue #337)
-Added various values to the industry slots tool table popup menu (Issue #337)
-Added various values to the contracts tool statusbar (Issue #333)
-Added various values to the contracts tool table popup menu (Issue #132)
-You can now copy statusbar values by clicking on them
-Added tool tips explain you can click to copy to the info menu and statusbar
-Added Context Type and Context ID columns to the Journal tool
-Added ContractID and RecordID columns to the Contracts Tool
-Added Market Value and Market Price columns to the Contracts Tool
-Added ItemID/Runs/ME/TE columns to the Contracts Tool (only public contracts)
-The tracker tool now have prices for blueprints in public contracts
-Added placeholder examples for filter import (Issue #282)
-Improved market details character selection in the Stockpile tool (Issue #307)
-Added mnemonic to the main menu
-Added available label to stockpile separator row (Issue #341)

Bug Fixes:
-Ignore profiles with invalid names
-Include private structures in the contract appraisal settings reset on save
-Refining equipment option did not accept decimal values (Issue #340)

Changed:
-Made the business tool menu a bit nicer
-Added warning message when hitting the maximum of 25000 blueprints
-Better warning for orders in unknown locations on outbid update (Issue #327)
-Show warning when Nahimic Overlay is detected (Issue #313)

Code:
-Update eve-esi to 4.7.0
-Optimized table main menu to only be updated before showing
-Updates from setting changes now only update what is needed (Issue #334)
-Added info level to UpdateTask (Used by “NOT ALLOWED YET”)
-Replaced OSXadapter with FlatDesktop from flatlaf (Issue #329)

2 Likes

jEveAssets 7.3.1 released

Bug Fixes:
-Fixed NPE in MyIndustryJob from MyBlueprint (Issue #342)

2 Likes

jEveAssets 7.3.2 released

Bug Fixes:
-Fixed NPE crash in FilterManager (BugID: 1028, 1029)

1 Like

I just started getting the following errors in my log:
ESI > Contract Items > Name of one of my corporation
Error Code: 404
{“error”:“Contract not found”}

ESI > Contract Items > Name of one of my characters (not in that corp)
Error Code: 420
{“error”:“This software has exceeded the error limit for ESI. If you are a user, please contact the maintainer of this software. If you are a developer/maintainer, please make a greater effort in the future to receive valid responses. For tips on how, come have a chat with us in #esi on tweetfleet slack. If you’re not on tweetfleet slack yet, you can get an invite here → Tweetfleet Slack Invites - Fuzzwork Enterprises”}

Please email me the logs files

I can’t figure out, in what way exactly I am stupid.

The “transaction price” and “transaction margin” columns for me are exactly the same, no matter what the buy price is. The columns are the same, and the number does not seem to depend on the buy price. They do differ for different items though.

It’s hurting my brain.

Options > Options… > General > Margin
Allow you to added a fixed percent margin to the transaction price.
The default is zero, hence identical to transaction price.

I will update the column header tool tip to include the settings location to hopefully avoid hurting any more brains!

Thanks! But my brain also hurts because the transaction price is the same, regardless, what the buy price is. :slight_smile:

Transaction Price is the opposite price. For buy transaction it use the price of sell transactions and vice versa.
The parameters for how the price is generated is in the same place as the Margin settings.

First you have the Transaction Age, which dictates how many days back are going to be used for the calculating the price, the default is 0 (zero), mean all transaction history is used.
The second is the Default Price, the options are:
Latest: Simple use the most recent opposite transaction price
Average: The average price in the time set in Transaction Age
Minimum: The minimum price in the time set in Transaction Age
Maximum: The maximum price in the time set in Transaction Age
The settings are global AKA they’re not calculated per Transaction, but, rather calculated once and used on all transactions

1 Like

jEveAssets 7.4.0 released

New Features:
-Added evemissioneer.com to the lookup menu (Issue #351)
-Added option only including contracts with all the stockpile items (Issue #266)
-Blueprint copying output as assets (Optional, off by default)
-Set status for Contracts and Market Orders no longer in ESI (Issue #349)
-Added Stockpile filter for industry job duration (Issue #348)
-Added volume column to the Transaction tool (Issue #350)
-Added Completed Date and Paused Date columns to the Industry Jobs tool
-Added import to the reprocessing tool (Issue #335)
-Display total minerals (minerals*count) in the reprocessed tool (Issue #302)
-Added avg/count/max/min of selected numeric cells/column to the table menu
-Added market orders and contracts to the slots tool (Issue #347)
-Added Availability column to the contracts tool (Public or Private)

Changed:
-Improved the ToolTip for the Transaction Margin columns
-Only include industry jobs if not delivered to assets yet

Bug Fixes:
-Handle space and comma thousands separators when editing in tables (Issue #344)
-Added sum table menu tooltip (was null)
-Fixed table header not resizing on sorting (if the table didn’t change)
-Fixed StatusPanel icon labels having the copy tooltip + handle dynamic icons
-Fixed Stockpile text import/export
-Do not try to update public market orders with invalid accounts
-Exclude invalid accounts from structure updates

1 Like