Your device isn't compatible

I have a Galaxy A10e and this isn’t compatible. So a phone running Android 9 that was released 3 months ago can’t run this? Is this a region lock issue? I can’t even find it when I search the Google Play store. Only the direct link from the blog post brings it up. Seen lots of people with this issue and no responses from CCP. Here’s hoping.

3 Likes

Hi, Am I right to assume that the beta build has resolved your issue? Once that build has passed further testing we will release it to the store. :slightly_smiling_face: