jEveAssets 7.2.1 (2022-05-30)

Can we please see your
FTYPE .jar
And corresponding ASSOC entry?

So I’m new to using jeveassets. I do a small amount of station trading and some regional trading and was hoping I could use this tool to easily see what my total margin is between a buy and sell for an item. In the market orders tab, it seems to have all the info to calculate that (perhaps minus knowing what taxes you are paying) ie on the completed sell order entry it shows the broker fees you paid (I assume this includes relisting), the original transaction price to buy it, and then the profit per item. It doesn’t seem to use those though to show a column for your overall profit (it knows the fees, quantity, and per item margin so I would think it could do that). I may just not be looking in the right place, but is that not a feature in the tool? I know I can do this with my own spreadsheet but it would be nice to not have to keep exporting from this tool to a spreadsheet to see that information.

@Eddie_Pollard
The main problem with linking the 3 sources of information:
-Journal (have tax and broker fee entries)
-Transactions (Have the same datatime as journal tax, so that is easy to link)
-Market Orders (Have the same datetime as journal broker fee, so that is easy to link)
However, linking market orders and transactions, is only possible by comparing a bunch of stuff (type, quantity, location), it will always be imperfect and it’s rather complicated to program.
Here is the issue: https://github.com/GoldenGnu/jeveassets/issues/147
It’s is something I want to do, but, It’s going to take time to get right.

1 Like

jEveAssets 6.9.4 released

Bug Fixes:
-Fixed tree tool totals (parent items, statusbar, table menu)
-Fixed Formula columns not working with results like 1.333…
-Fixed price update failing (now fail when 25% of all price are zero, was 10%)
-Table menu sum did not work correct for values between 0.0 and 1.0 (Ex: 0.14)

Code:
-Better handling of error throwables during update
-Optimized Tree tool collapse and expand all
-Hopefully fixed very slow sorting with many active filters in the Tree tool

2 Likes

Edit: Think it’s a bug. I’ve opened an issue.

I started getting 404 errors yesterday when updating my character in jEveAssets. Is it related to this maybe?

I tried re-authorizing my account and got a 404 error there as well.

I am having the same issue. Given the timing, it does look like it is related. Hopefully the devs are aware! :slight_smile:

1 Like

Trying to add characters but all get the same message, any ideas?
image

I am having the same issue as well

jEveAssets 6.9.5 released

Bug Fixes:
-Removed incorrect column tooltip for formula columns
-Formula columns did not work with infinity decimals (1.333) AGAIN! (Issue #268)
-Exporting table data used disabled filters resulting in incomplete output

Code:
-Updated eve-esi library to version 4.6.0 (fixing account update)

@Caffeine_Coma @Judge_Chuck @Jaster_Caen @Zelysthe_Ambramotte
This release fix your issue. Thank you for reporting it. I’m really sorry for the inconvenience!

2 Likes

This fixed it, thanks very much.

1 Like

Hello,
Thanks for the info on how to launch jEveAssets on macOS, but I have this error with the terminal :

MacBook-Pro:~ xxx$ java -jar .jeveassets.jar
Error: Unable to access jarfile .jeveassets.jar

Do you have any idea on how to make it work ?

Thanks :slight_smile:

@Galac_Sticott
Try: java -jar jeveassets.jar in the directory where you unzipped jEveAssets

1 Like

Don’t you see a difference between “./jeveassets.jar” and “.jeveassets.jar” ?

Ok don’t be rude I tried multiple times. It seems that last time I tried I made an error and replicated it on copy pasta.

I’m having the issue with the line you gave.

MacBook-Pro:~ xxx$ java -jar ./jeveassets.jar
Error: Unable to access jarfile ./jeveassets.jar

@Galac_Sticott
You need to change the directory to unzipped jEveAssets directory, before running the java command.
You shouldn’t need the ./ at all, just: java -jar jeveassets.jar should work.
Also, be sure that you unzipped the jeveassets-x.x.x.zip file (that is a common problem): Help with unzipping file on Max OSX
For further support, I would suggest you join the jEveAssets discord.

1 Like

jEveAssets 6.9.6 released

Bug Fixes:
-Possible fix for CtD (BugID: 973, 974, 975, 976, 977, 978)

Changed:
-Ships are now included in their own totals in the Tree Tool (Issue #271)

1 Like

Thanks for an awesome app…

Question, when adding an account and updating, the market orders display are as far back as July, but when removing the account and deleting the backup files file located in C:\Users\parrot.jeveassets it makes no difference when I re-add the same account and update, It all just adds the same data again, am I being retarded, how can I fix this? - Thanks!

@Riddick_Korth_Virpio Market orders always include 90 days of history, this is directly from ESI (the eve online API). If you use jEveAssets longer, it have the option to keep all the old orders, or you can make jEveAssets delete them after they’re no longer in ESI:
Options > Options… > Market Orders > Save Market Order history
If you only want to see active orders, it’s super simple to make a filter for that.
jEveAssets already have two filters for that: Press “Load” on the toolbar to find them.

1 Like

Thank you, this helps, any idea how long the orders stay in the esi/cache