jEveAssets 5.8.2 (2019-03-04)

esi
tool

(Golden Gnu) #307

@Paula_Myok
Could you verify that you’re getting the right volume for packed stuff in version 5.7.3? :slight_smile:


(Zanaris) #308

Im trying to learn picking out good data with the help of spreadsheets and i’ve been using your #default xml document to make tons of tables in excel. I hope that’s alright!
One thing i cant figure out is the date format in the xml. There’s for instance 1534073520000 instead of 2018-08-12 11:32 and no matter how i try i can’t seem to find the pattern in order to convert them. What is this mystery format?!
Please help :slight_smile:


(Black Pedro) #309

It almost certainly Unix Time:

https://www.epochconverter.com

Basically the number of seconds (or milliseconds) since January 1, 1970.


(Zanaris) #310

Haha thanks Black Pedro! That i would not have figured out!


(Lesch) #311

I have added my accounts and am attempting to use the Tracker feature to follow my combined Net Worth. Currently it is picking up Sell Orders made on behalf of my corporation along with my own personal stuff. Is there a way for me to filter these out?

Thanks,
Lesch


(Johann Hemphill) #312

Did you add a corp API or is it picking these orders up from your character API?


(Lesch) #313

I haven’t added a corp API yet. It seems to see them via personal API somehow


(Johann Hemphill) #314

That sounds like unintended functionality. I’d suggest two workarounds for now:

  1. If your corp name is listed in the lower right-hand panel of the tracker screen then you can un-highlight it to remove its assets from the tracker.
  2. Or you can remove all sell orders from the tracker by unchecking that box from the upper right-hand panel. That’ll block out your personal sell orders too but perhaps you don’t have any.

(Golden Gnu) #315

All orders made by the character are included, no matter if they’re are on behalf of a corporation or not.
There is no way to filter those out in the tracker.
Feel free to make a feature bug suggestion on GitHub :slight_smile:

Edit: I should note, this only happens if you don’t have access to the orders via the corporation. If you add the corporation, the orders will be included there. I’m okay with calling this a bug, though.


(Lesch) #316

Ok, thank you for the responses


(Androix) #317

I can’t update my account. Writes: Unknown Error: java.net.ConnectException: Connection timed out: connect. Previously, everything worked.

Probably, the matter is that it is impossible to connect to EveKit. Although, again, earlier it was possible with the same key. Now, when connecting to the old and even using new keys, writes:
The API returned the following error
EveKit Account failed to update for: Owner # 0 ERROR:
Java.net.ConnectExeption: Connection timed out: connect


(salacious necrosis) #318

I’m looking. Haven’t seen this one before.

By the way, I see you have one account marked for removal. I’m assuming you aren’t trying to use the access key for that account.


(Androix) #319

I created this account to check if it will work with another account. But it still did not work, so I deleted it. Previously, I used the first account, which is now not deleted.


(salacious necrosis) #320

So I just tried this now and had no issue accessing your account either from https://evekit.orbital.enterprises or via jEveAssets. I went so far as to import daily trackers which should be the most time consuming import, and didn’t have any issues. That doesn’t prove anything other than that your account isn’t obviously broken. I’m going to look further back in the logs to investigate further (I’m guessing this blew up sometime in the last 24 hours). Any other info you could share about what you were doing around the time of the failure would be helpful. For example, was this just a standard jEveAssets update? Were you trying to import trackers? Etc.

For troubleshooting purposes, you may wish to try one of the model URLs directly if jEveAssets fails. For example:

https://evekit-model.orbital.enterprises//api/ws/v1/char/sheet?accessKey=YOUR_KEY_ID&accessCred=YOUR_KEY_HASH

Putting that in a browser (with your credentials substituted) should show your character sheet. If that works, but jEveAssets still fails, then that localizes the bug.

I’ll keep looking. Sorry for the outage.

sal


(Androix) #321

I can not load this page. I replaced the data with my access key and access credential. The browser says: “Connection timeout”.

I do not remember anything special that I did before the error occurred.

Imports stopped working for a long time, but I hoped that it would fix itself with time and this is a temporary problem. The last time a successful update was 04/09/18.

Now I have the version of the application 5.7.3. After the problem occurred, I once reinstalled the application.

The application successfully updates the citadels, contracts and prices, but everything else can not.


(salacious necrosis) #322

Weird. I don’t see any attempts in my nginx log which suggests a routing issue. The only thing of any significance that has happened recently is that I moved the model service to a new machine. It’s possible you have a stale DNS entry although that was 11 days ago. If your browser allows proceeding past invalid SSL certificates, you can try the following:

https://159.65.42.28//api/ws/v1/char/sheet?accessKey=YOUR_KEY&accessCred=YOUR_CRED

evekit-model.orbital.enterprises should resolve to that address. You can also try host or nslookup (depending on you OS) to see if this is a DNS issue.


(Androix) #323


Now I received such a message. I also received similar messages before.

This link also does not work.

After nslookup I get:

Default Server: UnKnown

and

Name: evekit-model.orbital.enterprises
Address: 159.65.42.28

Is this a problem with dns?


(salacious necrosis) #324

That result from nslookup seems normal. You often see “Default Server: Unknown” if you’re trying a reverse lookup, e.g. nslookup 159.65.42.28.

If you tried nslookup evekit-model.orbital.enterprises, you should see something like this:

# nslookup evekit-model.orbital.enterprises
Server: 67.207.67.2
Address: 67.207.67.2#53

Non-authoritative answer:
Name: evekit-model.orbital.enterprises
Address: 159.65.42.28

“Non-authoritative answer” just means the result has been cached. The fact that you are getting elsewhere on the web suggests things are basically working, but the fact that I can’t see any of your requests in my log suggests you are getting blocked somewhere.

The other error message you’re seeing is a standard timeout on the front end. I’ve upped the proxy timeout for that site to make this less frequent on slow connections.

There are two other diagnostics I can think of to try:

  1. Login to EveKit and go to the model view: https://evekit.orbital.enterprises/#/sapi/model/-1/-1
    That should bring up a frame with the Swagger UI showing the EveKit endpoints. If that works, then it proves you can get to evekit-model.orbital.enterprises. If you like, select the appropriate key from the upper right and try executing one of the character endpoints with default arguments (just “Try it out” and “Execute”).

  2. If that doesn’t work, try:
    traceroute evekit-model.orbital.enterprises
    Give it some time (it takes a few minutes for me), but if that doesn’t terminate then it’s likely something is blocking the route (why, I have no idea). For comparison, you can try:
    traceroute evekit.orbital.enterprises
    which works since we know you can see the website.

I’ll keep pondering what else might be causing this.


(Androix) #325

tracert evekit-model.orbital.enterprises
...
...
10   143 ms   144 ms   143 ms  evekit-frontend.orbital.enterprises [159.65.42.28]
Trace complete.

As I understand everything went right.

P.S.
Now jeveassets writes:
EveKit> Account> Androix
Unknown Error: java.net.SocketException: Connection reset
(It used to be a bit different.)


(Golden Gnu) #326

@Androix
Can you email me the log (see the wiki)

Here are a few suggestion:

  1. Use another DNS provider: 1.1.1.1 or google
  2. Ensure your anti-virus/firewall is not resetting the connection. Adding exception for jEveAssets (java) could be a solution.
  3. Update to the latest version of Java (see the wiki)