No map, fitting window and shield booster effects broken for DX11?


(Meditril) #1

Hi guys, any idea what to do to enable the shield booster effects for DX11?
I am playing on Ubuntu 18.04 LTS with Nvidia GTX 1050 Ti card.


(Whitehound) #2

I don’t am anywhere near a ship with a shield booster to test it right now, but do Adaptive Invulnerability Fields show their effects? Because mine do. Is this just with shield boosters or do none of the effects show?

First thing you should check is that when you press Ctrl-F and it shows you the framerate to look for “dx11” in the lower-left corner.


(Whitehound) #3

I have good news and bad news.

Good news is, I’ve tested the shield booster and it displays just fine and produces a sound.

Bad news is, when I tried to record it as a video did it in fact only render the ship and the sound of the booster, but not the actual visual effect.

So if you’re using some overlay system or window compositor then it may just be that it runs into the same exact problem as my video recorder and thus you don’t see it being rendered. If you have the chance to turn off any overlay and window compositor and try again then you might just get it working.


(Meditril) #4

Unfortunately this doesn’t work for me. Even if I switch to dedicated Full Screen mode booster doesn’t work. Even worse I noticed that the Fitting Window doesn’t show the ship and the new map isn’t working properly.
Even after upgrading wine to version 3.14 the problem didn’t got resolved.
So looks like I have to stick with DX 9 for some longer time :frowning:


(Meditril) #5

I am still on this and I am now trying to upgrade my Nvidia Driver from 390 to 396… but I seem to be missing something, can you help?

So what I did is the following:
sudo apt-get purge nvidia*
sudo add-apt-repository ppa:graphics-drivers
sudo apt-get update
sudo apt-get install nvidia-396

Unfortunately this results in an error telling me that “nvidia-396” is not existing. What did I do wrong?


(Whitehound) #6

Which window manager are you using?

I use Xfce4 and have turned the window compositor off and since I have an Nvidia card did I turn on “force composite pipleline”.


(Meditril) #7

I use the default installed GNOME.


(Whitehound) #8

I happen to read about it. The problem is that it’s called nvidia-driver-396 and not just nvidia-396.


(Meditril) #9

Gosh! Thank you… installing it now…


(Whitehound) #10

Look for Xfce4 and install it, too. You should then be able to choose which of the window systems you want to use at the login prompt. When you use Xfce4 do you get a small performance boost on top of it, because GNOME sucks up some of it and it uses a composite window manager, which will make things worse.

Once you have Xfce4 installed and logged in with it see if you can find the settings to it. Disabling the Xfce4 compositor should be under Window Manager Tweaks.


(Meditril) #11

Dear Whitehound, I really appreciate your help and the time you have dedicated. But unfortunately I have seem to have bad luck today. The issue didn’t got solved even with Xfc4. But now I learned Xfc4 a bit better and I am really impressed with its quick responsivity compared to GNOME.


(Whitehound) #12

Did you try to disable the Window Compositor like I suggested?


(Meditril) #13

Unfortunately I was unable to find the option “force composite pipleline”.
However, I found the following option “Settings => Windows Manager Tweaks => Compositor => Enable display compositing”, which I have disabled.
But it did not help, Map and Fitting window are not working properly…


(Whitehound) #14

In the Nvidia driver settings, under “X Server Display Configuration” -> “Advanced…”.


(Meditril) #15

Thank you for this screenshot!
This was it, you are my hero!


(system) #16

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.