Pyfa - The Python Fitting Assistant - v2.3.0 (Mutaplasmids!)


(Neugeniko) #61

With capacitor boosters, reloads are always taken into account irrespective of the ‘factor in reloads’ setting. I don’t think the code for factor in reloads for aar and asb made it into 2.0.0b5 but it is in 1.36.0.


(Neugeniko) #62

There is a new cap simulator for pyfa that is waiting to be integrated that should address cap issues/sustained tank issues. Unfortunately ESI integration takes priority and blitzmann is currently focusing on it, and atm is very busy in rl too.


(Fred Pirkibo) #63

HI. Does not work properly on Mac OS. After registering new character in Character editor this char does’t appear in main window’s menu “character”. This menu is still inactive. Also impossible to create new fit for the ship because there no any other buttons except “New”. When you enter name of the ship button for saving doesn’t appear.
Tried v2.0.0b5, 1.36.0-yc120.3-1.8. pyfa-1.35.2-yc120.2-1.2. All the same


(Bo Dauphin) #64

Getting the following error when using the new 2.0.0 stable release and trying to log in with EVE SSO:

OS version: Darwin-15.6.0-x86_64-i386-64bit
Python version: 3.6.3 (default, Oct 22 2017, 22:24:50)
[GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.72)]
wxPython version: 4.0.0b2 (wxWidgets 3.0.4)
SQLAlchemy version: 1.1.10
Logbook version: 1.0.0
Requests version: 2.18.4
Dateutil version: 2.6.1

####################

Traceback (most recent call last):
File “/Users/ryan/pyfa/gui/esiFittings.py”, line 329, in addChar
File “/Users/ryan/pyfa/service/esi.py”, line 209, in login
AttributeError: ‘Esi’ object has no attribute ‘settings’

####################

Traceback (most recent call last):
File “/Users/ryan/pyfa/gui/characterEditor.py”, line 784, in addCharacter
File “/Users/ryan/pyfa/service/esi.py”, line 209, in login
AttributeError: ‘Esi’ object has no attribute ‘settings’


(Jenne Wain) #65

Same issue here. It’s an odd error though, as my user folder is definitely not named “ryan”…


(Finala Durosdottir) #66

When switching between fits (windows) in the new version it often gets stuck on the old one for some reason. Only a restart helps. Anyone got similar issues?


(ROSSLINDEN0) #67

I’m getting the same error, does anyone know where the fits are saved so i can make a copy and try a fresh install?


(Jenne Wain) #68

All- Blitzmann pushed a new point release last night, and this has resolved the SSO issue for me. I can log in and get my characters now (I’m on a Mac).

If you were having this issue, download the latest version and see if that sorts it for you.


(Hetty Lang) #70

Hi
I may be having a senior moment but I have added a new char into pyfa and linked in the eve sso for it but pyfa stubbornly says that no skills have been learnt in the char editor window

Am i missing something or is pyfa not retrieving any data?

Any help is welcome

Cheers


(Lulu Aeschee) #71

Hello,
For myself I dont get any error message, it just dont work.

I log into the EVE SSO and get this message :
pyfa
If you see this message then it means you should be logged into EVE SSO. You may close this window and return to the application.

So I think it’s good but can’t select anything on the main pyfa page I mean it’s “All 5” and nothing else, not even without skills or wathever…

What to do :frowning:


(Daimyo Sengoku) #72

how to fix it?

Summary

Unhandled exception: unimplemented function api-ms-win-core-path-l1-1-0.dll.PathCchCombineEx called in 32-bit code (0x7b43c6dc).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:7b43c6dc ESP:0033c2c4 EBP:0033c348 EFLAGS:00000212( - – I -A- - )
EAX:7b428f59 EBX:00000004 ECX:0033c2f0 EDX:0033c374
ESI:f78bec10 EDI:1e28d4e8
Stack dump:
0x0033c2c4: 000002cc f78c110c f78c11e4 1e28d3b0
0x0033c2d4: f78c118c f78b0000 80000100 00000001
0x0033c2e4: 00000000 7b43c6dc 00000002 f78bec10
0x0033c2f4: f78becec 0033c348 7bc58a15 7bce69c0
0x0033c304: 00110760 00110760 0033c328 0033c330
0x0033c314: 00000000 0033c370 0033c374 1e28d3b0
1ef1600c: sel=f78b0067 base=00000000 limit=00000000 32-bit rw-
Backtrace:
=>0 0x7b43c6dc in kernel32 (+0x2c6dc) (0x0033c348)
1 0xf78bebf7 in api-ms-win-core-path-l1-1-0 (+0xebf6) (0x0033c388)
2 0xf78be801 in api-ms-win-core-path-l1-1-0 (+0xe800) (0x0033ce18)
3 0x1e143863 in python36 (+0x143862) (0x0033ce18)
0x7b43c6dc: addl $12,%esp
Modules:
Module Address Debug info Name (73 modules)
PE 400000- 453000 Deferred pyfa
PE 1e000000-1e33a000 Export python36
ELF 7b400000-7b7e9000 Dwarf kernel32
-PE 7b410000-7b7e9000 \ kernel32
ELF 7bc00000-7bcfa000 Deferred ntdll
-PE 7bc10000-7bcfa000 \ ntdll
ELF 7c000000-7c004000 Deferred
ELF 7e635000-7e659000 Deferred imm32
-PE 7e640000-7e659000 \ imm32
ELF 7e6de000-7e708000 Deferred libexpat.so.1
ELF 7e708000-7e751000 Deferred libfontconfig.so.1
ELF 7e751000-7e77c000 Deferred libpng12.so.0
ELF 7e77c000-7e797000 Deferred libz.so.1
ELF 7e797000-7e847000 Deferred libfreetype.so.6
ELF 7e869000-7e8a2000 Deferred ws2_32
-PE 7e870000-7e8a2000 \ ws2_32
ELF 7e8a2000-7e91a000 Deferred advapi32
-PE 7e8b0000-7e91a000 \ advapi32
ELF 7e91a000-7ea49000 Deferred gdi32
-PE 7e930000-7ea49000 \ gdi32
ELF 7ea49000-7ec29000 Deferred user32
-PE 7ea60000-7ec29000 \ user32
ELF 7ec29000-7ec3c000 Deferred libnss_files.so.2
ELF 7ec3c000-7ec57000 Deferred libnsl.so.1
ELF 7ef89000-7efde000 Deferred libm.so.6
ELF 7efe6000-7f000000 Deferred version
-PE 7eff0000-7f000000 \ version
ELF f78ad000-f78c2000 Dwarf api-ms-win-core-path-l1-1-0
-PE f78b0000-f78c2000 \ api-ms-win-core-path-l1-1-0
PE f78c2000-f78d6000 Deferred api-ms-win-crt-filesystem-l1-1-0
PE f78d0000-f78d6000 Deferred api-ms-win-crt-filesystem-l1-1-0C:\windows\system32\api-ms-win-crt-filesystem-l1-1-0.dll
ELF f78d6000-f78ea000 Deferred api-ms-win-crt-conio-l1-1-0
-PE f78e0000-f78ea000 \ api-ms-win-crt-conio-l1-1-0
ELF f78ea000-f78fe000 Deferred api-ms-win-crt-heap-l1-1-0
-PE f78f0000-f78fe000 \ api-ms-win-crt-heap-l1-1-0
ELF f78fe000-f7912000 Deferred api-ms-win-crt-process-l1-1-0<el
PE f7900000-f7912000 Deferred api-ms-win-crt-process-l1-1-0
PE f7912000-f7926000 Deferred api-ms-win-crt-environment-l1-1-
PE f7920000-f7926000 Deferred api-ms-win-crt-environment-l1-1-C:\windows\system32\api-ms-win-crt-environment-l1-1-0.dll
ELF f7926000-f793c000 Deferred api-ms-win-crt-stdio-l1-1-0
-PE f7930000-f793c000 \ api-ms-win-crt-stdio-l1-1-0
ELF f793c000-f7950000 Deferred api-ms-win-crt-time-l1-1-0
-PE f7940000-f7950000 \ api-ms-win-crt-time-l1-1-0
ELF f7950000-f7966000 Deferred api-ms-win-crt-convert-l1-1-0<el
PE f7960000-f7966000 Deferred api-ms-win-crt-convert-l1-1-0
ELF f7966000-f797c000 Deferred api-ms-win-crt-runtime-l1-1-0<el
PE f7970000-f797c000 Deferred api-ms-win-crt-runtime-l1-1-0
ELF f797c000-f7992000 Deferred api-ms-win-crt-string-l1-1-0<elf
PE f7980000-f7992000 Deferred api-ms-win-crt-string-l1-1-0
ELF f7992000-f79a6000 Deferred api-ms-win-crt-locale-l1-1-0<elf
PE f79a0000-f79a6000 Deferred api-ms-win-crt-locale-l1-1-0
ELF f79a6000-f79bf000 Deferred api-ms-win-crt-math-l1-1-0
-PE f79b0000-f79bf000 \ api-ms-win-crt-math-l1-1-0
ELF f79bf000-f7ab9000 Deferred ucrtbase
-PE f79e0000-f7ab9000 \ ucrtbase
ELF f7ab9000-f7acf000 Deferred vcruntime140
-PE f7ac0000-f7acf000 \ vcruntime140
ELF f7acf000-f7b45000 Deferred shlwapi
-PE f7ae0000-f7b45000 \ shlwapi
PE f7b74000-f7b88000 Deferred api-ms-win-core-localization-l1-
PE f7b80000-f7b88000 Deferred api-ms-win-core-localization-l1-C:\windows\system32\api-ms-win-core-localization-l1-2-1.dll
ELF f7b88000-f7b9c000 Deferred api-ms-win-core-fibers-l1-1-1<el
PE f7b90000-f7b9c000 Deferred api-ms-win-core-fibers-l1-1-1
ELF f7b9c000-f7bb0000 Deferred api-ms-win-core-synch-l1-2-0<elf
PE f7ba0000-f7bb0000 Deferred api-ms-win-core-synch-l1-2-0
ELF f7bb1000-f7bbe000 Deferred libnss_nis.so.2
ELF f7bc0000-f7bc5000 Deferred libdl.so.2
ELF f7bc5000-f7d7b000 Deferred libc.so.6
ELF f7d7b000-f7d98000 Deferred libpthread.so.0
ELF f7db0000-f7dba000 Deferred libnss_compat.so.2
ELF f7dba000-f7f71000 Dwarf libwine.so.1
ELF f7f72000-f7f97000 Deferred ld-linux.so.2
ELF f7f9a000-f7f9b000 Deferred [vdso].so
Threads:
process tid prio (all id:s are in hex)
0000000e services.exe
00000023 0
0000001e 0
00000018 0
00000015 0
00000013 0
00000010 0
0000000f 0
00000011 winedevice.exe
0000001d 0
00000017 0
00000016 0
00000012 0
0000001b plugplay.exe
00000020 0
0000001f 0
0000001c 0
00000021 winedevice.exe
0000002a 0
00000026 0
00000025 0
00000024 0
00000022 0
00000028 explorer.exe
0000002d 0
0000002c 0
0000002b 0
00000029 0
0000002e (D) C:\Program Files (x86)\pyfa\pyfa.exe
0000002f 0 <==
System information:
Wine build: wine-3.0
Platform: i386 (WOW64)
Version: Windows XP
Host system: Linux
Host version: 4.13.0-41-generic


(Hetty Lang) #73

Yup that’s the problem i have


(Raven's Claw) #74

Crest login I get this Error

error “invalid_scope”
error_description “The requested scopes either don’t exist, or are not valid for this client”

(Giddy McFee) #75

When trying to install PYFA my AV application keeps warning me about dngerous elements of the application and keeps removing them, I cannot recall what the exact alerts were. anyone else getting this issue?


(Micah McCain) #76

Hetty,
Had the same thing happening to me.

I pulled up a fit, selected my character, and then hit the 'Refresh API" button just to the right of my character name - did the trick.

Micah


(Hetty Lang) #77

Cheers for that micah, that worked for me too

Thou it begs the question of why pyfa does not update the char info when you give it your eve sso

Also ‘refresh API’ does refer to something that no longer exists it could of been renamed as ‘refresh ESI’ which would of been somewhat clearer but hey ho it now has my data correctly

Thx again


(Giddy McFee) #78

On downloading 2.0.2 my anti virus still keeps on removing bits and pieces and telling me they are unsafe. One example is threat Heur.AdvMLC, whilst this maybe false i cannot take that risk, why would the software throw up these threats, I do not get it from other eve 3rd party software ive used in the past.

Whilst people may say it is safe It seems unwise for me to ignore my AV warnings based on a comment, can this be solved at all, my AV is Norton if that helps.


(Fire Seller) #80

Tried to install 2.02 with exe-file and got:
OS version: Windows-7-6.1.7601-SP1
Python version: 3.6.1 (v3.6.1:69c0db5, Mar 21 2017, 17:54:52) [MSC v.1900 32 bit (Intel)]
wxPython version: 4.0.0b2 (wxWidgets 3.0.4)
SQLAlchemy version: 1.1.10
Logbook version: 1.0.0
Requests version: 2.18.4
Dateutil version: 2.6.0

####################

Traceback (most recent call last):
  File "C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\pyfa.py", line 135, in <module>
  File "C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\mainFrame.py", line 167, in __init__
  File "C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\bitmap_loader.py", line 65, in getBitmap
  File "C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\bitmap_loader.py", line 87, in getImage
TypeError: initial_value must be str or None, not bytes

I don’t have user “holme” on my comp…


(SEEWOLFas Dragonite) #81

Before I had API for my wife’s characters. Now I can not figure out, how to see her character’s skills without asking her to login on MY laptop for EACH character. Guys-developers of PYFA, that is REALLY stupid… Before I could use API, which did not give password, now I HAVE TO ask someone’s password, to see her’s skills to help with fitting…


(Jenne Wain) #82

The developers of PYFA have absolutely nothing to do with that decision. The old API was retired by CCP, and the (wonderful and hard-working) devs who keep PYFA going are simply working with what they have been given.

It’s ok to dislike the change and be upset, but please be upset with the right folks.

One option to get around this is that PYFA does have the ability to import and export skills in the Character Window. So, if you can have an instance of PYFA where she is logged in and can export her skills, you can import them and work with that set. Of course, that won’t update and it’s a bit of a pain, but it is a workaround.