Pyfa - The Python Fitting Assistant

(Sable Blitzmann) #145

They did, thanks for asking! Everyone is doing well :slight_smile:

(Dragos Highwind) #146

Quick request, as a precursor pilot I’d love to see the DPS changed to show the base damage with the option to hover over and see the spool up damage. Showing the spooled up DPS by default is giving a lot of people unrealistic expectations as you’ll likely never see that number outside of a structure bash.

1 Like
(Sable Blitzmann) #147

There’s currently an idea on giving users the option to change the spoolup amount, defaulted to 100% (because half of folks would want 0% and half of folks would want 0%). Development has been stalled on the UI piece due to time constraints for myself, but hopefully will be included in the release after next.

That being said, regardless of support to change it, the master branch currently has this improvement for the DPS tooltips showing the range one can expect:


Of course, still defaults to 100% for the main display, but at least the base DPS is also accessible. If you’re interested in this now, please take a look at one of the most recent development builds here:

(please note that, as a development build, things might be broken, but it should be relatively stable)

1 Like
(Dragos Highwind) #148

Thanks for the through reply and great work by the way. Mainly just giving a tip that it should default to 0% since there are many that just play around with the precursors, never actually flying them. That leads to people saying their current state is fine or OP because at a glance in Pyfa a Leshak does 2323 dps not realizing that requires maxed out skills and a 2 minutes of continuous lock and firing on a target. Seeing 929 dps gives a more realistic expectation by default.

1 Like
(Sable Blitzmann) #149

As promised, I’ve update the page at

I would welcome anyone to give it a bit more… information. It’s currently bare-bones, and unfortunately I don’t have the time to write out a comprehensive guide to getting development builds. But there you go :slight_smile:

1 Like
(Sable Blitzmann) #150

Additionally, last week I noticed a problem with our updater in that it wasn’t displaying updated releases! /o\ The problem has been fixed without needing a ptach to pyfa, so lots of folks should be getting the latest December build.

We’re working hard to get a new build out with some new features / bug fixes soon (as well as updated database of course)!

1 Like
(darkislife zhang) #151

Guys I need some help. I usually use pyfa in school which doesnt allow exes to be used. However, I can run python files. Problem is I downloaded the source code and tried to run that but I dont have Logbook modules installed. Does anyone have a fix for this? I have tried using pip install Logbook but it says that the install has a syntax error.

1 Like
(Sable Blitzmann) #152

make sure you’re using python 3.6. If this is a Windows machine, running a pip3 install -r requirements should work.

If that doesn’t work, post the exact output

1 Like
(darkislife zhang) #153

Running the pip code in cmd since python keeps giving syntax error. This is what I get: Could not open requirements file: [Errno 2] No such file or directory: ‘requirements’. Also I’ve tried installing Logbook and I get this:

Command ““c:\program files (x86)\python.exe” -u -c “import setuptools, tokenize;file=‘C:\Users\aaaab\AppData\Local\Temp\pip-install-4_ikfykz\Logbook\’;f=getattr(tokenize, ‘open’, open)(file);’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record C:\Users\aaaab\AppData\Local\Temp\pip-record-esgq1k5i\install-record.txt --single-version-externally-managed --compile” failed with error code 1 in C:\Users\aaaab\AppData\Local\Temp\pip-install-4_ikfykz\Logbook\

I’m a complete noob at anything coding related but I think that this is happening due to me not having admin privileges.

1 Like
(Devoros Vyndiver) #154

I can’t get this toon to add to my characters. I’ve signed in with EVE SSO several times, but still don’t see it. I’m kind of new to using Pyfa so I’m not sure what I may be doing wrong. Please help.

1 Like
(Sable Blitzmann) #155

requirements.txt sorry, that was my bad. But it’s very possible if you don’t have admin privs you may not be able to install to global pip. In which case you’ll have to use a virtual env.

Unfortunately You’re gonna have to do the rest of the research on your own. :slight_smile: I dcan’t provide support on getting a dev enviornment up and running - some background with this stuff is expected :stuck_out_tongue:

1 Like
(Sable Blitzmann) #156

Does the character show up in the SSO character manager window? If so, you’ve successfully signed in. However, that does NOT create a pyfa character, which is a completely different entity. To create a pyfa character, go to character editor, create one, then link that character to the sso character through the EVE SSO tab. That way your pyfa character knows how to update skills

1 Like
(darkislife zhang) #157

It’s all good thanks for the info!

1 Like
(dewk) #158

Looks as if the Backup Fits option is still buggy.

Tried three times now and just sits with Backup fits window, no progress on the bar, and then Cancel fails to kill the operation.

Only way to kill it is kill app in Pyfa in Task Manager.

1 Like
(Rotsuda Soikutsu) #159

Are you planning on putting the new implants from the recent announcement into the tool soon?

1 Like
(Gin'no Taki) #160

Any news on update?

(Kadesh Priestess) #161

Update has been released yesterday + small bugfix release today. You can find it here:

Delay was caused by some ongoing development work, sorry for that!

(Kadesh Priestess) #162

No, there are no such plans. But as soon as these implants hit Singularity - I will release new build with them included.

1 Like
(Leah Crowleymass) #163

Thanks as always to all of the contributors who work to keep this app running and updated. We really, really appreciate you all!


1 Like
(Ilana Crawford) #164

Latest patch is great, but, what happened to the “Charge all” option when loading ammo into guns and modules? That was a great feature.


1 Like