[Resolved] 20240607 - Play Button Not Visible In Launcher

Maybe it’s on a lunch break, give it some time, let it finish its meal.



Well the launcher is not working… any tips ?
NVM. Solved.

No but it doesn’t appear if You have only one character and only one account so practicly impossible here :-]

Resolved? Lol what?


I just derped and “updated” the launcher, thinking that the update would be the fixed version. But no, my launcher updated to V140… :facepalm:

And now it detected the correct version … CCP why? :facepalm:

Not resolved.
Can’t start the game. (BST/DST 19:20)

Can now start the game. (BST/DST 21:25)

Update 14:39 - A new version of the launcher has been deployed. It should automatically be detected by the launcher and an update applied within the next few minutes.

Did you forget to push this via Steam?

1 Like

When trying to launch via steam, the error remained…

still have the problem

ok so i downloaded eve-online-latest+setup.exe on this page Download the free EVE Online client (launcher) for Windows or Mac
i ran it and it fixed the problem (it update the launcher to the version 1.4.2)

Yup. Still broken. Actually seems to be fixed finally!

Yes =)

I wasn’t online (in EVE or at all) that day, but I find it funny they managed to accidentally hide the play button.