Can't revoke third party ESI links

o7,

I tried to delete ESI links here: https://community.eveonline.com/support/third-party-applications/

But on all of my accounts it shows “An error occurred while retrieving your third party application permissions. Please try again later.”

Is there any way to fix this?

I just tidied mine up ok, so it’s working. Log a ticket?

Did you try again later?

(It’s working for me)

If it’s still not working for you, I’d recommend a support ticket.

I just tried on a secondary account and there it works.
Back to my main account and it doesn’t work.
I already made a ticket but CCP told me that they can’t help me with this.

Cookies or cache or something? Maybe try a different browser?

Deleting cookies, clearing cache and trying different browsers (Chrome/Opera/Firefox/Edge) didn’t work. :frowning:

The only other related thing i found was an archived forum post from 2016. Someone had the same error messages and someone from CCP had to come in to fix it. :-/

One thing which should revoke any tokens anyone has:
Change your password.

It should revoke everything.

Okay, thanks. =)