ESI not updating current player location on system/WH change


(Luci Mari-Ni) #1

This seems to be happening more frequently. I opened a ticket with the support and they referred me here.

I have 2 programs that work only with ESI updating and it looks like it is not on either.

I use allison from eve-scout and tripwire. I logged on after downtime today and moving wormhole to wormhole is not updating my current location data, which both programs need in order to work.

Usually downtime resolves this problem, but DT was 35 minutes ago. I need the ESI data to update.

i have logged out and back in to each. I have tried a browser i do not use for either (Firefox) I usually chrome. This eliminates the browser being the cause.

is there anyway to force this data to refresh? I went into evemon and refreshed it there and even in there the Wormhole my character is currently in is not what is being reported.

All 3 programs get their data from the ESI. I need it working.


(Annisir Kaugan) #2

Echoed, I logged a ticket with support and their instruction was to direct it at the Devs. Getting a lot of people with the same issue and browsers are freezing trying to access the applications as well. Also gets worse as more people log on to Eve.


(Catherine Solenne) #3

Can you provide any more details? I’ve been testing this a bit and am getting the correct location reported on the 5s cache time.

Headers of the fault response would be ideal to have if you can produce that.


(Krysenth) #4

To follow up on why they’re sending you here- the apps themselves could be at fault, not ESI. If any endpoints get updated, and apps arent updated to follow suite, eventually those features will fail to work.


(Caepio) #5

I can confirm this has happened to me as well. Player tracking seems “frozen” on a specific system and not updated on jump or even on new request.

This is ESI (not apps) since I have tested it directly against the API on /latest (https://esi.evetech.net) and can confirm my location is not the one that is outputted (matches the apps)

I am currently waiting for downtime to see if it refreshes.


(Caepio) #6

As expected, location was updated correctly at Downtime further supporting the idea that this is an ESI issue and so should be solved by CCP support and not directed at forums.


(Blacksmoke16) #7

@Caepio Since this is reproducible, could you create an issue for it? https://github.com/esi/esi-issues/issues/new?template=bug.md

I’ll bring it up in the ESISD ch on slack.

EDIT: I did try this myself and it works fine for me. Have you happened to do an abyssal site before?


(Catherine Solenne) #8

For those following development on this bug, it’s currently being tracked as #988 on esi-issues


(system) #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.