EVE Launcher for Linux

ο7 all :smiley:
for me the problem is the following
i open the client and when i click play nothing happens…
i run the client through terminal so i can see possible errors etc…
any1 had similar or the same problem??
thanks in advance :smiley:

url link in launcher/game not work

Tommy:

Your Plasma installation has newer versions of the QT library than the ones provided with the EVE launcher and they end up conflicting.
One workaround is to substitute the QT libraries in the evelauncher directory - copy from /usr/lib or usr/lib64 depending on where your distro puts them.
If the launcher itself updates in the future you will need to repeat the procedure.

i use symlinks to system Qt libs. 5.7 work fine. 5.9 segmentation at startup launcher

I have followed the steps found here…https://wiki.eveuniversity.org/Installing_EVE_on_Linux but when I run the eve launcher nothing happens. No window, no errors, nothing. I did have to install the gtk module cause I was getting an error with that but now it just sits there.

Im running Ubuntu 18.04

Any ideas?

Maybe you have a look on this thread EVE Installing or here Some notes on Ubuntu 18.04 .

1 Like

wanted to report some recent improvements I have noticed.

It used to be that I would have to fix system links for truetype, libcrypto, etc. after performing system updates on my Arch Linux machine. It appears that after running a full system update, this is no longer necessary for my specific use case and I can run evelauncher.sh after a full system update (pacman -Syy followed by pacman -Syu) without any further modifications.

I recently performed a clean installation of Arch on my chromebook (Acer C720, i3) and was able to get the AUR package for the Eve Launcher to work without any issues. I did have to change the display option to Fixed Window but I think that has more to do with my window manager (i3) than anything else. I also used to encounter bad crashing on my chromebook after playing for maybe ~30 minutes, but this no longer seems to be the case.

Things have definitely improved with the Eve Launcher for Linux and I want to thank the devs for everything they have done to improve the game for people who use Linux.

o7

  • Sabrina Winslow

My problem still persists. Running the linux evelauncher, the download fails within seconds. The logfile mentioned isn’t helpful.

I was in the same problem, just install eve directly on WINE. worked for me first try

I started encountering crashes immediately after start-up after re-enabling sound. I’ve stopped using the launcher entirely and have had success using the following instructions, running Arch Linux and Wine Staging 3.9:

https://wiki.archlinux.org/index.php/User:Mcnster/EVE_Online

https://appdb.winehq.org/objectManager.php?sClass=version&iId=25823

I personally am not using a wineprefix considering EvE is the only thing I really run with wine, but after following all of the instructions on both pages, the game has been running with no issues (well, loglite crashes, but if the game works, I guess I don’t need logs).

Debian / Ubuntu

Sharing my working setup on Debian stable. It should also work on Ubuntu and other derivatives.

Setup:

Install dependencies before running the launcher.

apt install wine64 libldap-2.4-2:i386 libssl1.0-dev

Download the launcher. Make .eve folder in your home directory and extract evelauncher.tar.gz into .eve folder.

The launcher will create symlinks after the first run, which would be broken, if you move or rename the folder. Don’t do it in order to avoid future problems.

cd ~/ && wget https://binaries.eveonline.com/evelauncher-1104891.tar.gz
mkdir .eve && cd .eve && tar -xf …/evelauncher-1104891.tar.gz

Run the launcher, open settings and under wine options leave everything unchecked.
bash .eve/evelauncher/evelauncher.sh

The launcher will download latest wine and setup wine environment for itself. System wide installed wine64 will cover other missing libraries and there is no need to link them to the launcher.

Using winehq-master and then leaving everything unchecked worked for me.

I am using x11 with i3 window manager, but it doesn’t matter which desktop environment you chose as long as you don’t have broken package dependencies.

2 Likes

Installed EVE Launcher for Linux on Slackware 14.2 and it installed flawlessly. Logged in with no problems.

There are some issues with graphics. Most likely due to the integrated (substandard) video card on this machine - an ATI Radeon X1270. Poor rendering on ships, keepstar, no in-game video and approx. 40 fps. All objects in-game were black shadows - not playable. Adding a 2nd card and disabling this one should fix it so I can multibox for fleets.

Good stuff, CCP.

Thanks for the port.

I had similar problems on my 10-year-old PC running Mint 17, I fixed most of them (after consulting this forum) by disabling ‘Anti-aliasing’ in the ‘Graphics Content Settings’ of the in-game settings panel.

The default is to run with DirectX11. And as @Dravick_Afterthought has pointed out does it cause still a problem when anti-aliasing is enabled.

You can change it to run in DirectX9 in the launcher settings. This improves framerate and also allows for anti-aliasing at the cost of a little less visual finesse.

Be sure to have Nine patched wine and mesa drivers and run in DX9 mode like Whitehound recommendation.
If that kind of old card do have Gallium Nine support, of course.

@Whitehound I think he is already running in DX9 mode as his hardware don’t support the OpenGL version required for D3D11_2_OpenGL

1 Like

Did you reply to the wrong post ? I’m working OK.

I’m able to run the launcher from the terminal, but it doesn’t really do anything…
user@computer:~/evelauncher$ ./evelauncher.sh
I can see the process running… then it goes away…
*Edit:
I was able to get past that by redoing everything and following this thread but I’m stuck on this:
The client launches but freezes right after. This is what my error is:

user@computer:~/evelauncher$ ./evelauncher.sh
[0731/100724:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/user/evelauncher/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /home/user/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
[0731/100724:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.
nouveau: kernel rejected pushbuf: No such file or directory

Have a look at this post Help Installing EVE on Ubuntu 18.04.

But first you must install the non-free graphics-driver from nvidia, the nouveau driver doesn’t work with wine and eve online.

That’s already done. Thanks for the link Gharim, I’ll go check that thread.

Hmm, something is wrong with your driver setup. It should say “1 proprietary driver are in use” but it says “No proprietary drivers are in use”. Can you check with nvidia-settings which driver you have running?

1 Like