On Arch (or Manjaro) it's better to not use the "Linux" EveLauncher

I just wanted to share my experience here to help anyone potentially running into the same issues.

I was trying to get the unofficial Eve Launcher to work and after figuring out that a few libs are missing and the already known issue that you have to provide an older version of libssl.so and libcrypto.so, the game would launch, but crash as soon as you click anywhere but the UI elements.

So I tried using the normal Windows Eve Launcher directly, which turned out to be rather painless, but you may want to do it on a separate prefix:
Wine Version: 3.3 (just from the normal Arch repos)
Wine is set to Windows XP mode (run “wine winecfg” to set it globally for the current prefix)

First, I ran:
winetricks corefonts d3dx9_36 vcrun2005 vcrun2008 vcrun2010 vcrun2013

Not sure if it is necessary, but I also installed quite a few qt5 packages with “pacman -Sy qt5” and install everything.

Then the Eve Launcher started for me. You have to launch the clients in dx9 mode. After that, everything seems to work fine.

1 Like

Sup. It used to be the downloaded launcher with eveo files, or just an installer?

UPD: Installed succesfully from the very beginning

I’m not sure I got your question correctly: Using the installer you would normally get from the Eve Online website worked after the procedure I discribed above. Using the unofficial Linux Eve Launcher that packs a bunch of libraries and some custom wine version did not.

It would probably be nice if CCP would provide a snap or a flatpack package with all the dependencies bundled at some point to avoid such issues in the future.

I’m using the Debian Testing distribution with WINE 3.2 aka “wine-development” as described here. None of the winetricks are necessary.

If it wasn’t for the “Windows XP”-mode setting needed to get it to work then you could say that the EVE Online Windows client runs “out of the box” on WINE.

I still enable DX9 in the launcher over DX11 for more FPS, and unless one enables anti-aliasing does it also run with DX11 as far as I’ve seen. I also set the environment variable WINEDEBUG to “-all” to turn off all the debugging channels in WINE for some more FPS, and I already mentioned how to get rid of screen tearing, which can occur in combination with some of the window compositors here. However, none of these are show stoppers.

Confirm I was doing some testing a couple of weeks ago myself on a handful of distros. The newest 3.x versions of wine-devel and such worked out of the box after a quick winecfg and auto setup of those functions and using the plain windows launcher. This did not used to be the case at all. :slight_smile:

I straight up could not get eve working on several of the distros that track their upstream packages closer. Probably due to lack of skill on my part.

The old and crusty (debian stable and ubuntu derivatives) worked ok with the linux launcher after doing the crappy manual libssl links and winetricks installs.

Why I should’t use the “Linux” EveLauncher?

I use Manjaro and all works fine.

The only problem I had, was the left-click space instant crash. Which caused by the newest freetype2 version. But it’s seems to be fixed now. Don’t have to downgrade to an older version while I login and then go back to newest version.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.