Starting game in launcher

Okay so, I can understand that this might not work, but I’m just wondering if anyone has any thoughts on why it wont work:

I have a pixelbook which has a Debian 9 something on it. Now I have installed the EVE launcher on it, it boots, I can log in, etc. But when I click the play button on the launcher, nothing happens.

I am wondering if it is because of the OS or it is how I am starting the launcher (through the .sh script from a terminal). Does anyone have any ideas on how to make it work?

Is your wine version 4.18? If it is, update it to 4.19 and try again (there is a known bug in that version).

My wine version (manually installed) wine-1.8.7, I cant find any updates past that point.

I installed the client through the most recent launcher download in the pinned thread. I am not sure how to update the wine that was packaged in there?

If you use the wine bundled in the launcher and not the one manually installed, then maybe wine is not the problem.
However, if you want to make sure, you can add the wine repository and install a current version on your system (sudo apt install --install-recommends winehq-staging). Then set the launcher to use custom wine (enter the full path: /usr/bin/wine).

I have both the linux launcher installed and the windows launcher with wine and dxvk. The windows launcher just works while the linux launcher does not start the custom /usr/bin/wine for some reason after I upgraded to Fedora 31. I guess some qt lib is missing in the linux launcher but I cannot find any trace.

Yesterday i have a Fedora 31 installed to see, how it works with evelauncher on wayland. After updating the installation i have downloaded the actual linux eve launcher . In short, he doesn’t work under wayland which are in use on Fedora 31 per default. If i use explicit a Gnome session with Xorg he crashes too provoked trough the delivered xcb libraries i guess.
After fiddling with some install and uninstall things i have in the end the qt libs from Fedora used and now he works flawless after some adjustments

[gharim@amd4k3 ~]$ tar xvf Downloads/evelauncher-1548102.tar.gz
[gharim@amd4k3 ~]$ cd evelauncher/
[gharim@amd4k3 evelauncher]$ rm -vf libQt5* libicu* libxcb* libpng* [Qq]*
[gharim@amd4k3 evelauncher]$ rm -rvf plugins/ resources/

After this commands i have the evelauncher directory cleaned up from the delivered qt libs, xcb libs and other not necessary files and subdirectories. To finaly get it to work i have installed following packages

[gharim@amd4k3 evelauncher]$ sudo dnf install qt5-qtwebengine qt5-qtwebsockets

The evelauncher itself works now but the delivered wine not because he try to run the 32bit wine first which are static linked so i cannot find missing dependencies to get this wine version to work. My solution for this situation was just install Fedora’s wine version with his dependencies and use it instead the delivered wine version. You can use the delivered wine now but i prefer the distribution version, she are newer and have more options build in.

I followed these instruction and custom wine does not start.

Some errormessages or logs would be nice. You can acces EVE’s launcherlogs through
Menu->Show in File Browser->Launcher Logs and search in the newest log for wine messages.

Nevermind, turns out I had a failed wine update. I only need to remove libxcb* from /opt/evelauncher to be able to start EVE with a custom /usr/bin/wine environment .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.