Ubuntu 20.04: Launcher stuck on loading animation

OS: Xubuntu 20.04
Launcher version: https://binaries.eveonline.com/evelauncher-1747682.tar.gz

Since last patch on march 29, 2022, the launcher

  • downloads patches
  • does not show login name nor any button to start the game
  • plays without end the loading animation in laucher (the dots animation)

Cache has been verified, it’s first thing to do when having problems.

This was working fine for the last year, nothing changed on my xubuntu install.
To make sure, I reinstalled xubuntu, but still the same issue.

I’m at a loss what I can do to get eve running again.

Can confirm same issue on Debian 11 also using XFCE

I have been using this setup successfully for some time but am now just getting the dots moving themselved about.

Tried removing HOME/.eve HOME/.local/CCP and re-extracting the launcher in various combinations and still getting the same issue.

Tried again after DT, still the same.
With no support for linux from ccp and (for the moment) little interest in the subject, I will at least for now have to put my eve career on hold.

Obligatory “Works on my machine”.

Wine 7 *stable branch
Ubuntu 20.04 LTS / Mint 20 LTS
Desktop environment shouldn’t matter as we use XDG on most and Wine uses prefixes.

Try setting your WINEPREFIX it to Windows 7 compatibility using winecfg tool? Installer needed Windows 10 compatibility but the launcher needed Windows 7 set last time I checked.

$ WINEPREFIX={wine prefix folder here if not default ~/.wine} winecfg

sorry, I have no idea how I should set WINEPREFIX to Windows 7.
wine is included in the .eve map, but wincfg is not able to run.

See Winecfg - WineHQ Wiki

well …
thank you for the link, but …
I don’t see something I can install, sudo apt install winecfg is not something that is available.
Trying to install winehq-stable end up in depcendency problems I can not solve,
like dbus-sessions-bus which sends me down a rabithole of things it can’t install.

But back to the original question: I had a working copy of eve launcher for the last year,
I have a separate partition with xubuntu specially for eve that I don’t update
(bad experience updating Ubuntu and playing eve)
After a patch it stopped working, not sure what all this fiddling with wine will solve.

So you’re not running on Wine, Eve is a Windows game, that requires Wine, or something based on Wine. Not sure how you’re running it without some kind of Windows compatibility subsystem.

Perhaps consider Steam and Proton (customised Valve’s version of Wine).

Alternatively if you are unable to use Wine, you can consider purchasing Crossover perhaps from CodeWeavers.

OK, so sorry for the “it’s working for me” on my side so as a reference point:

Kubuntu 20.04.
Wine 7.5~focal-1 (i.e. the dev version packaged for Ubuntu).
winecfg to run as Windows10.
Launcher version 2023444 (updated a couple of days ago)

I don’t recall having to load anything else in particular to get it all working, but it’s a while since I did the last build to run Eve. There’s some good work been done by Eve players to fix issues in Wine and keep us playing.

If I got it correct, Terak Romaller and Emotional Support Clown,
you both installed wine yourself and run the eve program intended for windows ?

As I said in my opening post, I use https://binaries.eveonline.com/evelauncher-1747682.tar.gz.
The instructions were found here, and I only ever did the basic setup part, which works for me:
Installing EVE on Linux - EVE University Wiki

wine is includeded in that download, so no Emotional Support Clown, I don’t have anything fancy running here, more the opposite, as simple as it can be.

As said before, installing winehq doesn’t work here, and this is now a fresh Xubuntu 20.04 install.

Perhaps their *side project" launcher tarball isn’t being updated as fast. I just went with the official Windows installer running on Wine (or Proton) and that works on Ubuntu based distros. Proton is pretty much self contained in Steam (every game is their own prefix), so that should work on many more distros too if that is an option.

Any time I have had a problem with the Launcher (not often), I simply cleared the Launcher cache on the file system (I simply rm the launcher cache folder) and reran it and it worked (usually any problems occurred during a launcher update).

Also as per Linux launcher key details that launcher is retired. That’s probably why it’s not working.

The native Linux launcher is at this point considered retired, please see this post for details.

We recommend Steam and Proton (5.0-10 works best at the time of posting) as the easiest option for playing EVE on Linux. As always, we caution open source capsuleers that Linux is an unsupported operating system, and we do not guarantee the viability of this option.

Launcher version: retired
Launcher download link: retired
Shipped wine version: Wine-4.4-Staging

14/07/2021 - Retired
17/07/2020 - Launcher 1747682 - Almost a full years worth of changes :sweat_smile:
07/08/2019 - Launcher 1543721 - Bugfix for very old processors experiencing thread starvation
04/07/2019 - Launcher 1532453 - Fix issue with 64bit flag forgetting setting on launcher restart
28/05/2019 - Launcher 1514997 - Added 64bit checkbox to settings
14/05/2019 - Bumped release wine to wine staging 4.4 32/64bit, paving the way for a 64 bit client build

I thought Linux users read changelogs?

To install Wine, follow the instructions on the WineHQ site - the version in Ubuntu is old enough not to have the latest patches Eve needs (you need Wine 7.0 or later, not the Wine 5.0 that is in the Ubuntu 20.04 repo)

The old “linux launcher” is an old launcher build bundled with an old version of Wine. What is probably happening is “old launcher launches, downloads latest launcher, restarts with that new launcher which crashes because of the old Wine that is is with the old linux launcher”.

If you have a good version of Wine you don’t need the “linux” launcher - indeed that is now a liability to you. Wine should run the latest Windows launcher out of the box.

You are not “running a Linux version of Eve” you are always running the Windows version, but on top of Wine - which is a Windows API implementation in Linux (the grease that makes it all run smoothly).

I wouldn’t touch any distro repro (distros should not be app stores) version that I can get upstream direct from the developer themselves, distro builds are usually lagging and out of date.

Ubuntu distro bases can use Ubuntu - WineHQ Wiki instructions to install from WineHQ.

I’m trying my luck installing lutris for the moment.
But that seems to take a lot of time.
I post the result later here.

Installed lutris on Xubuntu.
Eve works, but clicking something takes a minute before it reacts,
in other words, dead slow, not playable at all.

I could try installing Ubuntu 18.04 …

Got it back to work.
What worked for me:
OS: Ubuntu 18.04
Following the instructions on

curious how long it will last.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.