Eve crashes on Ubuntu 18.04 when panning camera or click in hangar or space


(Specific Alduin) #1

Finally got Eve working on Ubuntu 18.04. The game launches fine but the moment i try to pan the camera or click outside of a window the game just closes. I have no idea what could be causing this, any support is welcome. Will provide additional info on request.


(Whitehound) #2

Does WINE give you any messages? Can you check what it says?

Also, which WINE version, graphics driver and which of the two launchers (Windows or Linux) are you using?


(Specific Alduin) #3

No Wine messages as far as I can see. Using the Eve launcher from this link here: https://binaries.eveonline.com/evelauncher-1104891.tar.gz
AFAIK that has a version of Wine with it, so I am using that one.
NVidia Driver 390.77


(Whitehound) #4

I don’t use the Linux launcher. You’ll have to wait for @Gharim_Turen to help you. It sounds like an issue with the WINE version, when it dies during panning.

The alternative is to install the latest WINE version, set WINE to “Windows XP”-mode with winecfg, download the latest EVE installer, and install EVE and go with the native Windows version.


(Specific Alduin) #5

Managed to get it working through wine. Thanks for the help my man.


(Gharim Turen) #6

As long CCP does not update this launcher and users only read how to’s which are older than the launcher himself, such things will always happen. I have not count the ubuntu 18.04 threads in this forum but this is not the first and will not be the last to this behaviour. EVE Online works now with the windows launcher? Fine, i’m done. The actual linux launcher installed with my setup script works for me and the other users which have downloaded it, too.


(Ima Wreckyou) #7

Yeah it is the bug with the wine version I think then fontconfig gets updated or something. I got that bug last week when I updated my Gentoo and it worked for a while when I switched to the dev version winehq master branch. But now this is gone too and it does not seem to like my native wine very much (rambles sometjng like the wineserver version was not correctly updated…)


(Ima Wreckyou) #8

Just for the record I solved my issue by replacing ~/.eve/wine/bin/wineserver with a link to my actual wineserver. It looks like the launcher still starts its own wineserver even if you tell it to use system wine.

@CCP_Snorlax or @CCP_Falcon I know the native Linux launcher is not officially supported. But it is heading the way of becoming obsolete if issues like the no longer working wine version are not fixed. People are already starting to use the windows version again. Any plans to iterate on this?


(Gharim Turen) #9

Are you serious? Did you read this thread Which launcher setting is the right one? Please don’t tell me, that these settings doesn’t work.


(Ima Wreckyou) #10

Maybe I’m just dumb and did something wrong. I set that to /usr/bin/wine because I use Gentoo and can switch the implementation of wine with eselect. That resulted in a protocol error because an old wineserver was started.

I’m not sure why the launcher would even do that.


(Gharim Turen) #11

On console kill all running wineservers with wineserver -k then remove in ~/.eve/wineenv/drive_c completely so that the launcher reinstall the wineenv with the changed wine version. your settings should you backup before you do that.


(Ima Wreckyou) #12

Thanks for the tips but I’m fine, I already fixed it with a simple symlink. There was no wineserver running.


(Gharim Turen) #13

It will work only so long when @CCP_Snorlax did not change the installed wine-version . Then will you have the same problem again.


(Tinkerbell's Evil Twin) #14

@Ima_Wreckyou - thanks, the symlink to my wineserver solved this issue for me also.