Did the last update break Eve under Linux?

Hi there,
I am experiencing the impossibility to launch the game now the last update as been downloaded on my computer (yesterday I had no problem)…
The launcher loaded all the patches without any difficulty but once all the stuff applied, the launcher window remained with the animated CCP logo and the blue bar at the bottom… and nothing more. My account doesn’t appear, nor does the links for the news etc…
I checked my account access on another (windows) computer, no problem and I can loggin on the eve online website too.
I removed all the files and installed the game again from the tar.gz installer (as I always do in fact) but I wasn’t more successful…

I run the game under ubuntu 20.04 with the wine version provided by the tar.gz (but I also tried with the wine 5.0 of my system).

Don’t know if this can help, I check if loglite could give a helpful message. It just says repeatedly the module evelauncher sends the message “channel state: 3”… nothing more.

If anyone here have an idea, i’d be glad to hear about it :slight_smile:

thank you in advance for your help

EDIT : it seems I didn’t post in the good place… hope the message will be moved in the right place… sorry


I hate to be a “Me too” message writer but the launcher just runs the animated CCP logo on my Slackware64 v15.0 box. Just yesterday I was playing just fine.

Same here on Suse Leap 15.3.

Just to add a few datapoints:

Garuda Linux (Arch based)
Kernel 5.17.1-zen1
Nvidia 1060
Wine 7.5 (Staging)
Launcher updated, restarted itself, downloaded game patch, launches fine.

Mint 20.3
Kernel 5.13.0-28
Running under Steam; Proton 5.0-10
Launcher updated, restarted itself, downloaded game patch, launches fine.

Doesn’t appear to be a hard break across everything.

Ubuntu 21.10
Kernel 5.13.0-39
Nvidia 1060
Wine 7.5 (Staging)
Launcher updated, restarted itself, downloaded game patch, launches fine.

1 Like

Same problem. Mint 19.3, I have a non-steam Wine based client I installed forever ago. The launcher gets stuck on the loading icon and nothing seems to help.

So ended up logging in via Steam, the game is free to install and unlike the last time I tried it starts the launcher rather than the client so you can multibox.
I had to pin proton at 6.3-8 to get it to work properly though and after a few attempts at different versions I had to remove it and re-install, probably cos it thought it had installed libraries but that had been for different proton versions.
Slight gripe is it keeps adding my steam account as an Alpha level account, but that is a small thing.

logging in via steam works for me too, and has the pleasant side effect of radically improved performance

I think it broke if you updated to the latest beta launcher yesterday.

This broke on 2 systems of mine (debian bullseye and ubuntu 20.04), I had to revert a backup earlier version of the launcher, re-launch, and disable beta on that launcher. It then ran on the release launcher.

After that, the CCP logo would come up, but the launcher wouldn’t launch.

This may be indicative of a future breakage of the launcher though.

Same here, slackware 15

1 Like

Linux Mint 20.3 with kernel 5.13.0-37.

Launcher updates itself, restart itself, then patches the game and starts just fine on wineHQ 7.0 stable.

For those with problems since yesterday: Which launcher version are you using? Is it the latest release version (which is 2023444)?

In the latest screenshot form @Mevatla_Vekraspek it looks like it is a really ancient version, which is very likely no longer compatible with the latest UI version. Please try to use the latest launcher version (you might have to install it fresh).

1 Like

Thanks, i installed it from the link provided on the Eve Uni guide, as it worked pretty well i never tried to update it.

Someone has a link to the latest version?

1 Like

This is with the (retired) Linux launcher from Linux launcher key details

The reason I’ve been using it (and others I presume) is the fact that the Windows launcher haven’t been working for me for ages, and a lot of issues with it prior to that.

Wine 7/ DXVK and the Windows launcher seem to work quite well now.

Ubuntu 21.04 not working neigther…

That’s (Ubuntu 21.04) just an interim (a testing) release not LTS and it’s been updated to 21.10 and that support ends in July 2022 as 22.04 LTS gets released.

See Ubuntu release cycle | Ubuntu

re downloaded the installer, installed on new prefix.


Tried several times. I got the “sent message to mail” entered the code, then same error.

Tried beta, same issue.

Same in Fedora 34.

Old launcher stopped working.
Installed via Steam and I’m getting the “Login failure” popup after completing 2FA.

Steam version worked when the launcher finished downloading.

1 Like