New launcher... new Linux error?

Hi everybody,

so today the new launcher came with the release… and EVE stopped working for my wine-6.12 (Staging) with this error:

0164:err:heap:HEAP_GetPtr Invalid heap 00000000!
0164:err:virtual:virtual_setup_exception stack overflow 1156 bytes in thread 0164 addr 0x7bc5b97f stack 0x750b7c (0x750000-0x751000-0x850000)

Any ideas?

2 Likes

Also faced the same problem! Already created a topic for this :slight_smile:
Have tried last Proton version, wine 6.12, wine-staging 6.12, wine 5.5 - nothing helped,
So sad

Someone please share previous version of launcher so that we can revert to it.

confirm, wine-vanilla 6.0 (gentoo)

also tried lutris. No luck :frowning:

Howdo, todays launcher update improved the security and fundamental mechanics of how we handle and store tokens locally on Windows & macOS.

This change does not work on Linux, and we have no current plans to support it due to Linux not being a supported operating system by CCP at this time.

3 Likes

https://binaries.eveonline.com/EveLauncher-1916226.exe

Seems to be last version from CCP CDN which works on my rig.

4 Likes

How to prevent it from update?

3 Likes

Just cancel it when prompt to update it is opened.

There was a Native Linux Launcher, does it will work?

1 Like

native should work

Thank you for this open clarification.

What a pity, does this mean that in the long term there will be no reliable way to continue playing EVE under Linux?

5 Likes

You can use native linux launcher, but it has some problems, due it i don’t use him. rollback to old laucnher (copied from my laptop), and waiting fix

How long have you known internally you were going to kill Linux support? This is absolutely ridiculous to just suddenly drop on people. I wouldn’t have given CCP any of my money over the past couple of months if I’d known you were going to kill any and all support on my operating system.

You really owed it to paying users to at least give us a heads up that this was going to happen. Now I’m out a couple of multi-month omega subscriptions as well as other things I bought in the months since I came back.

10 Likes

Dude, this has always been on the cards.
I had hopped that the cloud client would be widely available before the ax fell but alas that does not seem to be the case.

Did anyone else hear the funeral march at CCP Cemetery’s comment?

4 Likes

https://binaries.eveonline.com/evelauncher-1747682.tar.gz

Linux Launcher in case anyone is looking for it …

3 Likes

They killed it a long-long time ago when they dropped the cedega ■■■■■■■■

Bit of a shame really.

Personally run it up until today with over 500 hours just on Linux alone, only to be unable to login today.

Contrary to popular belief, there are people who use Linux as their main driver. Personally going to be seeing what can be done to keep it running my end, being as no official support is forthcoming.

5 Likes

No heads up; truly poor form. I (like others will try to work around this) but if it truly can’t be made to work then it will be bye bye to EVE. Last machine I owned that had an MS operating system on it ran DOS 4.0.1.

5 Likes

I appreciate a definite answer.

But I’m not going back to Windows just to play this game. This appears to be the end of my 14-year journey.

Bummer.

8 Likes