EVE Launcher for Linux


(1eg01as) #21

I have k* packages 5.34. I recompiled this packages, and check later.


(Rounon Dax) #22

The Qt libs bundled with the launcher need to be updated I guess. The launcher has Qt 5.6 bundled with it. Have the same issue here, also Gentoo with Qt 5.7, so there is a version mismatch.

Or a better solution would be, just let the launcher use the system Qt version :slight_smile:


(Elassus Herron) #24

I like your solution better than the previous workaround of disabling dev versions of wine in the launcher config. Thanks!


(Bienator II) #25

anyone tried running it without having wine installed? Because my old setup had it installed and it ran fine (the launcher was set to use the ccp wine version however).

Now i tested it on a fresh linux mint install and the client exits on launch after not finding libldap.

“err:module:load_builtin_dll failed to load .so lib for builtin L"WLDAP32.dll”: libldap_r-2.4.so.2: cannot open shared object file: No such file or directory"

i have libldap installed though, so i pointed LD_LIBRARY_PATH to it and restarted the launcher, result:

“err:module:load_builtin_dll failed to load .so lib for builtin L"WLDAP32.dll”: libldap_r-2.4.so.2: wrong ELF class: ELFCLASS64"

which kinda makes sense since the client is 32bit and everything else is 64bit these days. I assume installing wine locally would install loads of 32bit libs? Anyone tried to run eve on a 64bit system WITHOUT having wine installed?

edit:
nevermind fixed it by installing 32bit libldap

apt install libldap-2.4-2:i386

client now launches but crashes a bit later. But we are a step further…

edit2:
was an issue with xaudio, had to disable audio and it started
so success, client is running again


(Elassus Herron) #26

you can regain audio by going into wineconfig (see above) and disabling xaudio2_7.

Annoyingly, I think this is necessary every time the launcher installs a new/different wine version.


(Solon Ardishapur) #27

Hi everyone,

this is something of a newbie question:

I am running Manjaro Linux 64bit and tried the evelauncher mentioned above.
After I started the evelauncher.sh script, the launcher does not appear on the screen. The process is still running but nothing is coming out of it. The 32bit Graphics Driver is installed.

I tried some of the stuff mentioned above, but nothing worked.

Has anyone experienced a similar problem or can give me some advice?

Kind regards


(BeunWa) #28

Hello!
Running a version of the evelauncher that doesn’t work anymore, I wish to do a fresh install.
How do I uninstall properly without keeping any old config files plz ?
Thanks a lot!


(Joke Bear Edge) #29

Hi m8! Just wanted to say that I am also using Manjaro 64bit and experiencing the same problem.

When I follow this guide: https://wiki.eveuniversity.org/Linux or the guide at the top of this post the launcher don’t start. The terminal just sits there blinking and doing nothing =(

I created a post on the Manjaro forums about this (https://forum.manjaro.org/t/need-help-installing-eve-online/28257) however the end result has been the same, even after the good folks over there tried to help.

It’s important to note that I am not at all experienced in Linux, as i just started using it a couple of weeks ago. So any help must be written for a first grader =)

Here’s hoping for a solution :slight_smile:

Best regards
Joke


(Roesjka) #30

Instead of making the symlink in evelauncher directory make the symlink in the same directory as where it was installed like:
ln -s /usr/lib/libcrypto-compat.so.1.0.0 /usr/lib/libcrypto.so
ln -s /usr/lib/libssl-compat.so.1.0.0 /usr/lib/libssl.so

In that way you don’t have to worry abt. the launcher updates anymore.

cheers


(Roesjka) #31

Delete the directories/folders where you installed EVEOnline, don’t forget the hidden folders .eve and .EVE and look in .cache, .config, .local/share for CCP.

Cheers


(BeunWa) #32

Thanks a lot! .eve and .EVE required elevated privileges but it’s all good :slight_smile:
Cheers!
edit: also found EVE files in /home/yourname/Documents. Mainly logs and captures.


(Tux88) #33

I switched to ubuntu 17.04 to ubuntu 17.10 for testing wayland, gnome and other stuff and sadly Eve wasnt able to work.
I move back to continue playing but ubuntu will update to 17.10 in october and i hope the trouble will be sold.


(Merkwurkdigliebe) #34

Wow this thread is long considering its not the real eve launcher thread! Anyone know where one goes for an updated link?

Edit: That was a bit snarky so… https://binaries.eveonline.com/evelauncher-1156239.tar.gz is the newest I have, which at least is newer than the original and now perma locked eve launcher post. Obviously the automagical, isn’t, and hopefully we’ll see a new post when things are smooth again…

  • M

(Eisso) #35

Why Ahlo fellow eve players and Linux users, I was just wondering if anyone else is having the issue where when you try to launch an account after putting in the account info in the launcher nothing comes up, IE click the play button or launch account, it turns into a square like it would normally then proceeds to change back into a triangle play button.


(Blacksmoke16) #36

Someone posted this issue on Reddit a little while ago. Try installing Wine and Steam. Said that those gave him whatever dependencies he was missing.


(Joke Bear Edge) #37

I’m having this exact problem but do not know how to troubleshoot it unfortunately.


(Joke Bear Edge) #38

Do you happen to have the reddit link?


(Blacksmoke16) #39

Yes but there isn’t much to it. All it says pretty much is what i said in my post above:


(StinGer ShoGuN) #41

You could: just edit the evelauncher.sh file and remove the env variables to let use system Qt installation. But this will not work: Qt is checking version and finds a version mismatch, 5.7 instead of 5.6.

And even if version were not check, you could not guarantee the symbols in the .so files are the same (this is compiler dependant and I’m not sure they’re using gcc 5.4 to build the launcher.


(Charles BawngBlower) #42

Actually I did just that to my launcher a while back, because of some Qt version conflicts between EVELauncher-supplied libs and my system.

I went at it the hard way, but it’s been working for me ever since:
$ cd evelauncher
$ rm libQt5*.so.5 QtWebEngineProcess (Those are the symlinks the launcher is bound to)
$ ln -s /usr/lib/x86_64-linux-gnu/libQt5*.so.5 . (Or fix your system’s Qt Path accordingly…)
$ ln -s /usr/lib/x86_64-linux-gnu/qt5/libexec/QtWebEngineProcess .
$ rm -r plugins/
$ ln -s /usr/lib/x86_64-linux-gnu/qt5/plugins/ .
Add Locales files
$ mv resources resources.old
$ ln -s /usr/share/qt5/resources .
$ ln -s /usr/share/qt5/translations .

Then you’re all set, and you can launch the launcher with the simple:
$ ./evelauncher

As a KDE user, the Qt Libraries are already loaded, so I do get a speed benefit from using my system’s libs instead of those supplied by CCP.
(Works on my Debian Sid/Buster KDE laptop…)

(EDIT: Added symlinks for locales)