EVE Launcher for Linux


(Swizzles Saissore) #124

Tried installing Eve on my Arch laptop now. The best I’ve been able to get is the launcher to install, run and the screen to blink when it tries to launch Eve and that’s it.

Then, when I try to restart the launcher after that, I get the xcb plugin error again. I have quad-checked my plugin directory is pointing at the right spot and it ran fine without changing anything the previously. It’s very strange.

[user@lappy evelauncher]$ ./evelauncher.sh
This application failed to start because it could not find or load the Qt platform plugin “xcb” in “”.

Reinstalling the application may fix this problem.
./evelauncher.sh: line 14: 6212 Aborted (core dumped) “$dirname/$appname” “$@”

Things I have tried:

  1. Tried both 64x and 32x wine installations
  2. Tried the AUR package, doesn’t make any difference and same problems happen
  3. Tried removing the whole lot and following the instructions in this thread re creating symlinks
  4. Tried doing a whole fresh install
  5. Tried doing an install of the entire Qt5 via pacman
  6. Made sure to install the Qt5X11Extras
  7. Checked ldd to see where evelauncher is expecting libxcb.so.1 to be. It’s currently listed as the following which is the correct location for it:

libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f4e289fc000)

About ready to give up ever getting it running on my laptop. As far as I can tell everything is in place for it to run and it does run the launcher sometimes. Most times it just gives the XCB error.


(elitatwo) #125

Does your laptop have a discrete graphics chip like an NVIDIA or AMD one? EVE doesn’t support the Intel i915 (i915 is the kernel module) graphics, even though the chip is more than capable.


(Pobega) #126

I don’t think this is true, I’ve been playing on my i915 X1 Carbon for the last few weeks.


(Moon Mydriasis) #127

Hi!

I hope it’s the right place to ask, I have downloaded the archive, installed libcanberra-gtk-module and now when I execute evelauncher.sh nothing is happening eve

I have waited for 5 minutes, but no launcher has started or anything.

I’m on Debian Stretch, everything is up to date!

I tried to launch the following command: LD_LIBRARY_PATH=$PWD ./evelauncher
But it’s the same result.

Thank you for your attention, have a nice day! :slight_smile:


(andrei haiducul) #128

Take a look at the launcher log in ~/.local/share/CCP/EVE/Launcher. You most likely have the same issue with mismatching OpenSSL version as already mentioned in this thread (the launcher relies on an older version). For Debian Stretch, you can install openssl1.0 and follow the instructions from this post

I made a simple script that does this on every launch, since the updater removes the links:

#!/usr/bin/sh

ln -sf /usr/lib/libssl.so.1.0.0 libssl.so
ln -sf /usr/lib/libcrypto.so.1.0.0 libcrypto.so

./evelauncher.sh

(Moon Mydriasis) #129

Thanks a lot for your answer!

I struggled a little because my share libraries where in the folder /usr/lib/x86_64-linux-gnu/ and their version was 1.0.2, but with this modification it works well! :smiley:


(Moon Mydriasis) #130

Well, the launcher seems to work, but now I have these errors:

2018-02-19T15:20:40.394Z wine error “err:module:load_builtin_dll failed to load .so lib for builtin L"WLDAP32.dll”: libldap_r-2.4.so.2: cannot open shared object file: No such file or directory"
2018-02-19T15:20:40.394Z wine error “err:module:import_dll Loading library WLDAP32.dll (which is needed by L"C:\\tq\\bin\\blue.dll”) failed (error c000007a)."
2018-02-19T15:20:40.405Z wine error “err:module:import_dll Library blue.dll (which is needed by L"C:\\tq\\bin\\exefile.exe”) not found"
2018-02-19T15:20:40.407Z wine error “err:module:LdrInitializeThunk Main exe initialization for L"C:\\tq\\bin\\exefile.exe” failed, status c0000135"
2018-02-19T15:20:40.408Z default debug Process 2119 finished with exit code 53


(andrei haiducul) #131

Try installing wine and setting the launcher to use that. Hamburger menu (top right) -> Settings -> Use custom Wine. By default it uses its own build which, again, is linked to old libraries.


(Moon Mydriasis) #132

(I’m using PRIME to activate my graphic card)
When using the launcher, it doesn’t work, however when doing directly in a console: DRI_PRIME=1 wine .eve/wineenv/drive_c/tq/bin/execfile.exe
It launches the game, but it asks me to log in and it seems to be forbidden to log outside the launcher

EDIT: I found this error message: “wine client error:0: version mismatch 504/490.”

EDIT2: I managed to make it work, I installed the 32b version of the LDAP lib, made a symbolic link from the lib to /usr/lib and used the given wine version.
Is there a way I can define a launch option for enabling my graphic card? I need to put DRI_PRIME=1 before the command


(elitatwo) #133

Silly question (I hope not) but that requires you to enter a directory. I tried /opt/wine-stable/bin but no luck on Ubuntu 16.04 with wine from the wineHQ repository.
I have another directory /opt/wine-staging/bin. Which one is it?


(andrei haiducul) #134

You need to indicate the wine binary. Since that directory is most likely in your PATH already, you can just write “wine” (the default value), otherwise /opt/wine-staging/bin/wine


(elitatwo) #135

Ah okay. Cheers!


(Moon Mydriasis) #136

For DRI_PRIME I tried to check custom wine, and then use the launcher’s wine with adding DRI_PRIME command like it:
DRI_PRIME=1 /home/xobtah/.eve/wine/bin/wine

But it doesn’t launch anymore, and there is no error in the log files


(Cipher Jones) #137

Ive had Eve running in linux several times in the past, I always had to use some 3rd party stuff…
There was the dx file you needed to inject, corefonts, and some other winetricks stuff…

In Mint 17.2 I did a $sudo apt-get install wine and then winetricks first. I then simply had to check off the 4 C++ apps. Im not sure if you still need to install corefonts to sign the EULA or not. I have always had trouble getting winetricks to play nice with the hidden versions the devs use, so I just install my own wine and it solves the problem.


(Shenkhan Kafshaz) #138

And after every update this soft link creation of ssl libraries should be repeated :frowning:
I just experienced it after the initial update. I hope this will be fixed.

And not a problem for now but openssl v1.1 alread on the system. Maybe it will be better to use it since on recent systems, by default, this library is taken into account. Actually this may be the source of the problem already.


(Rhyme Bittern) #139

For more than a week now, the launcher fails silently on ubuntu 18.04. This is what I get in the logs:

2018-03-03T03:07:28.772Z qt.network.ssl warning QSslSocket: cannot resolve CRYPTO_num_locks
2018-03-03T03:07:28.772Z qt.network.ssl warning QSslSocket: cannot resolve CRYPTO_set_id_callback
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve CRYPTO_set_locking_callback
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve ERR_free_strings
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve EVP_CIPHER_CTX_init
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve sk_new_null
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve sk_push
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve sk_free
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve sk_num
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve sk_pop_free
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve sk_value
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSL_library_init
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSL_load_error_strings
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSL_get_ex_new_index
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSLv2_client_method
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSLv3_client_method
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSLv23_client_method
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSLv2_server_method
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSLv3_server_method
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve SSLv23_server_method
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve X509_STORE_CTX_get_chain
2018-03-03T03:07:28.773Z qt.network.ssl warning QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
2018-03-03T03:07:28.774Z qt.network.ssl warning QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
2018-03-03T03:07:28.774Z qt.network.ssl warning QSslSocket: cannot resolve SSLeay
2018-03-03T03:07:28.774Z qt.network.ssl warning QSslSocket: cannot resolve SSLeay_version

(Lagair en Marland) #140

Has anyone put together a snap for Eve Online yet?


(Dabljuh) #141

Trying to install/launch results in an error, after deleting all the files and trying different available version of the launcher I couldn’t find any approach that would fix it. It downloads 6 of 7 files, aborts with an error and refers to the log. Here’s the log:

2018-03-18T17:12:59.048Z qt.network.ssl warning QSslSocket: cannot resolve SSLv2_client_method
2018-03-18T17:12:59.048Z qt.network.ssl warning QSslSocket: cannot resolve SSLv2_server_method
2018-03-18T17:12:59.109Z default warning Installed Qt WebEngine locales directory not found at location /home/dab/evelauncher/translations/qtwebengine_locales. Trying application directory…
2018-03-18T17:12:59.109Z default warning Qt WebEngine locales directory not found at location /home/dab/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
2018-03-18T17:13:12.303Z default error Couldn’t open index file "/home/user/.eve//ResFiles/56/5610a6eb8b5a4975_ae842ceacb02cb6ed2971efc753d34cd"
2018-03-18T17:13:12.309Z default warning Update failed for Tranquility with error: 5

Checking manually for the file, it is indeed missing, permissions on the directory seem to be in order.

Deleting ~/.eve again and letting it download everything again with the latest launcher results in no enumerated directory structure, it being replaced by bundles, and the logfile throwing slightly different errors:

2018-03-18T17:21:36.640Z default warning Update failed for Tranquility with error: 5
2018-03-18T17:21:39.626Z default error Couldn’t open index file "/home/user/.eve//ResFiles/1d/1d34143a37d4b739_f85289a0bbf768243fa18fe8a63b81e7"
2018-03-18T17:21:39.626Z default warning Couldn’t get resource index for tq
2018-03-18T17:21:43.112Z default error Couldn’t open index file “/home/user/.eve//ResFiles/56/5610a6eb8b5a4975_ae842ceacb02cb6ed2971efc753d34cd”

The “Shared Cache Settings” do nothing except produce Qt errors in the console (Ubuntu 17.10)


(ChipotIe) #142

hey how did you fix this?


(Jeff Fighter) #143

I almost had no issue to make it work on Fedora 27, but I have noticed I am unable to make the game run on my Nvidia card using optirun.

Has anyone experienced this issue?

It is weird because I am able to run other games, like the one on steam with my Nvidia GPU.

There is got to be way to run a wine with optirun! :slight_smile: