EVEMon 4.0.18 - ESI Edition

Many folks simply don’t want others to have access to any information. ESI doesn’t expose any information that could be used to steal an account, regardless of which scopes are chosen – the concern is instead about keeping things opsec to entities that are hostile in-game. A malicious programmer could, yes, write malware into something, but to do so for an open-source program would be… odd, and to then distribute the malware would be a criminal act.

Distributing malware would be a criminal act in most countries of the world. Most, but, unfortunately, not all.

As for open source, yes would be great if you can download and compile yourself. Would also help if you know how to configure the firewall to allow that program to access only the CCP server and only on the 443 port. If people would know how to do that and actually apply that knowledge to every exe they download, then there would be no viruses in the world and i would have a different job :slight_smile:

Is there a mobile version coming? I’d like it on android please.

Testing the new version now for a few hours, first without wiping v303 and then a complete wipe/reinstall. Made actually no difference for me. Current problems, even after some hours no industry jobs showing and market orders are outdated (orders i made the last ~5 days are not showing).

After a while i now get this error for some chars and decided to shutdown evemon:

EVEMon 4.0.0.4737

API Error:
An error occurred while querying the skill queue.
HTTP error: A request to esi.tech.ccp.is failed with status: TrustFailure.

I dont wanna risk my account for this tool and have no idea what could cause a ban, due to maybe some bugs in evemon. The whole procedure of registering evemon like i was a developer is really bad.

Fixing Evemon is very appreciated though!

I too am getting TrustFailure errors. None of my characters are updating.

The error text, ironically, is “This text should not be seen”. A handled unhandled exception I’m guessing.

That said, thank you very much for taking up this fight. Very much appreciate your attempts thusfar to get an ESI version of EveMon into production.

Thank you for catching EveMon. Great work, hope you will continue.

Only my main has a valid account for developer’s licence, my alts don’t even though they are registered with the same e-mail address. Can this be fixed in future releases, or the fault entirely goes to CCP?
Also, when I try to enable “Research” for my character, EVEMon crashes.

For some reason, I cannot get past the screen below. I’ve been waiting 10 minutes so far and it;s still doing it.

https://prnt.sc/jhm4ny

Any ideas? I have tripple checked the secret code etc that I put in and they are correct.

Clicking on that button should open a browser window where you log in with your eve account credentials. Check your browser.

I’ve tried all 3 browsers on my PC: Chrome, Edge and Firefox. That part of the process works fine for all 3 browsers; it accepts my login credentials, then I get a message stating I can now close it. But for all 3 browsers, it will not progress past the image I linked above.

You only need 1 account with Dev access, that is so you can generate the Key.
Once you have that account set up, just add the rest of your accounts.
When you get the scopes screen select cancel and re-login with your other accounts.

And yea, I have the same problem with research.

EVEMon does not pull my industry jobs either. Soon™, I guess.

Hi Peter

Button Login with Eveonline generate authorization link with query param as “scope”, but required “scopes”. Еhis causes an error form esi server

so, I wiped the old installation of EVEMon and made a clean new one with the installer provided.
creation of the dev account and application went smooth and w/o problems.
entered Client ID and Client Secret Key where it belongs -> everything fine so far… :slight_smile:
now, adding a new API Key brings me to the Authentification button (LOG IN with EVE Online) and clicking that gives me this:

pictured above is Firefox, IE gives me an HTTP 400 error. and developers.eveonline.com gives me an Error 500 “Server unavailable” or sth similar afterwards but works now again…

any ideas?

What are you putting in for the Callback URL?

I am just getting endless loading its like its frozen trying to connect my eve online ESI and the Client, no error just no completion how long should I give it? I have Malwarebytes Professional and Windows Defender that could both be interfering but I added exceptions for them both but nothing.’

EDIT: when I put in the client ID via copy and paste it will show it as have empty space characters ahead of the alpha numeric key those spaces are required.

the one provided in the instructions above (http://localhost:4916/callback), I tried both http and https.

Just an update on my previous issue. It now seems to be working. I wasn’t able to copy and paste the secret key and client ID across to EveMon for some reason yesterday. I tried to do that again this morning and it’s now allowed me to do that. I’ve now been able to add my characters successfully.

Hey!

Just wanted to say thanks for updating EVE Mon. It’s been an invaluable tool for me for years!, and I appreciate your work on keeping it alive. I’ve downloaded, installed and configured it, and it seems to be working perfectly.

Thanks again!

How do I get EVEMon to load in my Alt? Main works fine, but can’t get alt to load in.