Installing pyfa on ubuntu 18.04

(MorsMortis Shiyurida) #21

I did not know that I was logged in as root. I thought that I was logged in as my normal username. The command was not ran under root.

(Anderson Geten) #22

my bad then.
I already had issues with pip complaining I was running as root, so I did not check twice, and assumed your “$” was a “#”

(Anderson Geten) #23

@MorsMortis_Shiyurida
had this issue on a different install, removed the pip install wx and put it as a apt dep ; then added pip and packaging as pip dependency, solved it.

(Gisele Serebriakova) #24

This new sequence of commands worked on the first run through.

2 Likes
(Anderson Geten) #25

which one ?

You mean you just tried the last modifications I brought and it works ? I yes, then yeah \o/

1 Like
(Gisele Serebriakova) #26

Yes(?)

I mean the command sequence in the OP worked for me and pyfa is running now.

1 Like
(Anderson Geten) #27

then yeah \o\ :slight_smile:

(I update the script in the OP every time I find a bug fix so I was not sure if you got the correct one or were referencing a previous update)

Just need @MorsMortis_Shiyurida to confirm this works too.

1 Like
(Anderson Geten) #28

:up: !

1 Like
(Blacque Jacque) #29

So I installed pyfa pretty much along the lines of the OP, and it runs but I encounter a few issues:

  • Implants & Boosters don’t seem to have any effect on fitting stats.
  • The Skill list in the Character Editor doesn’t show the skill names, just levels.

Anyone else experience these on Linux? I’m using Ubuntu 18.04 as well.

(Anderson Geten) #30

so installation works, nice.

Considering pyfa in itself, I think there is a thread on this forum for it.I means, I have issues with it too, but this is just for installation (all I can do is update the script)

(Blacque Jacque) #31

Yes, I saw that thread. I just thought there may be more Linux guys seeing it here, and I was looking for some confirmation. But I will probably report it over in the other thread as well.

(Caleb Maken) #32

Looks like I needed to add pip3 install --user bs4 as well.

(Anderson Geten) #33

I had it installed, tried pip3 --uninstall bs4 then launched pyfa and had no issue.

(Caleb Maken) #34

Interesting, wonder why it didn’t want to launch without it.

(Anderson Geten) #35

maybe you’re right though.

(Anderson Geten) #36

with last github update you need to upgrade pyYaml

pip install -U pyyaml --user

(Arount Four) #37

Kind of out-of-topic, but is there a reason why Pyfa don’t comes with a setup.py file (using setuptools)?

Would be easier to install.

(Anderson Geten) #38

ask the dev ? No idea, I just provide what I did to make it work.

(taca) #39

After following the instructions, the first time tried to run pyfa i get this

ImportError: No module named logbook

Looking at internet to solve the problem i saw this https://github.com/pyfa-org/Pyfa/issues/1271 were the problem is solved by installing python-logbook

sudo apt install python-logbook

Then i have this output in console when try to run pyfa

python3 pyfa.py
platform: 1.0.8
sqlalchemy: 1.3.2
config:
re: 2.2.1
os:
traceback:
sys:
inspect:

But pyfa don’t work. Any clue on how to solve it? i’m running Kubuntu 18.10

(Halvorsen) #40

There is a new thing.
Let me know if it helps.
Also, if it doesn’t. :slight_smile: