Linux - Launching Eve in Separate X-Server


(Tyrak Amphal) #1

I’ve been using Eve on Linux for a while now with no real errors other than occasional performance drops. Today I decided to run it on a separate X-Server using “sudo xinit /home/***/Desktop/EveOnline/evelauncher/evelauncher.sh – :2” and all seems to run smoothly. The issue I have is that the launcher doesn’t launch the game, I can log in and interact with the launcher fine, however after clicking play it just sticks on the launcher.

Launcher used is from this thread: https://forums-archive.eveonline.com/topic/482663/


(Whitehound) #2

Did you set the DISPLAY variable?

If it’s not a missing DISPLAY variable then also do a xhost + to temporarily disable access control and to see if it’s a problem with access rights.


(Tyrak Amphal) #3

I don’t think this is what’s causing the issue, I’ve tried both and neither seemed to help.

I’m able to switch to the launcher and log in, but when clicking play I see “Launch Process Started” and then it almost ‘gives up’.

It’s only simple but here is what I’ve been using to run the launcher:

#!/bin/bash
DISPLAY = :0.2
sudo xinit /home/*/Desktop/EveOnline/evelauncher/evelauncher.sh – :2


(Whitehound) #4

This won’t work. Firstly, always use export for the DISPLAY variable or it won’t be seen by applications. Secondly, and more important, sudo won’t carry over the DISPLAY variable even when you’re exporting it.

Try this and see if it gets you anywhere:

sudo xinit env DISPLAY=:1 /home/*/Desktop/EveOnline/evelauncher/evelauncher.sh -- :1

Also :0.2 is not the same as :2.


(Whitehound) #5

Not to be cheeky, but may I ask why you want to run a second X server?


(Tyrak Amphal) #6

Having errors with xterm now,

When runnig
sudo xinit env DISPLAY=:1 /home/*/Desktop/EveOnline/evelauncher/evelauncher.sh – :1

I was getting error:
xterm: Explicit shell already was /usr/bin/env
xterm: bad command line option “DISPLAY=:1”

Followed by xterm usage options

Changed command for:
sudo xinit -display :1 /home/*/Desktop/EveOnline/evelauncher/evelauncher.sh – :1

No errors but same issue as before, stuck on the launcher after login


(Whitehound) #7

My bad. Use /usr/bin/env instead of just env.

sudo xinit /usr/bin/env DISPLAY=:1 /home/*/Desktop/EveOnline/evelauncher/evelauncher.sh -- :1

(Tyrak Amphal) #8

Encountering the same issue with this, stuck at the launcher.
Seems to me like it’s not able to open the game through the launcher once in a new X server, but I don’t see any way the launcher can be bypassed on Linux


(Whitehound) #9

You do know that when you start a new X server like this then it will run it as user root, because you’re running it without anything, meaning without a login manager or a window manager. Is this what you want?


(Tyrak Amphal) #10

Probably not, I’m a little inexperienced with setting up a new X.
I was encountering the same issue when using fvwm earlier but saw some posts on the old forum where they’d used a similar method to my current bash script, the only difference being that they were running the Windows client with Wine.

It’s not that big an issue if I’m unable to run Eve on a separate X, it runs fine although a bit choppy anyway and I was only interested in potentially improving my performance. Other people also seem to have performance issues with Linux, especially Mint so this might be why I’m having issues with it. Might try a dual boot if it comes to it and just running Eve on a Windows partition although I’d prefer not to have Windows on my laptop.


(Whitehound) #11

Well, I don’t use the Linux launcher for starting EVE, but I use the standard Windows launcher. So I can really only tell you how you can do it with the standard launcher.

I’ve just tested it for myself and this is how it works for me without running the game as root and with the launcher starting the game on the second X server.

sudo xinit /bin/su USER -c '/usr/bin/env DISPLAY=:1 WINEDEBUG=-all WINEPREFIX="/home/USER/.eve" /usr/bin/wine "C:\\Program Files (x86)\\EVE\\Launcher\\evelauncher.exe"' -- :1

You obviously need to replace USER with your username and also correct the paths to what you’re using.


(Tyrak Amphal) #12

I’ll give the Windows launcher a try now, the only thing that did confuse me about the Linux launcher is that it runs without errors, the game just doesn’t even open. Makes me think this could be an issue with the X server but I’m inexperienced with X.

Will post Win launcher results


(Whitehound) #13

By the way, if you’re doing this just to get a few more fps from the game then maybe just change the window manager. I’m using Xfce4 and it gives me the same fps as on a second X server. So it’s pretty optimal as it is with Xfce4.

If you’re using an Nvidia card can you also try setting the following variable:

export __GL_THREADED_OPTIMIZATIONS=1

It enables multi-threading in the Nvidia driver for OpenGL-based applications, which is what WINE does when it emulates DX9 over OpenGL.

Another pretty common variable to set is this one:

export WINEDEBUG=-all

It turns off all the debug messages from WINE and can make your applications sometimes run faster, too.

When you’re running some fancy window compositor then it can already cost you a few frames per second. So turning it off can give a boost. Also know that when you run a compositor and you use an Nvidia graphics card then you should go into nvidia-settings -> X Server Display Configuration -> Advanced… and force a composition pipeline. This will remove screen tearing for example.


(Tyrak Amphal) #14

When running the Windows launcher I’m now encountering issues with Qt platform plugin “windows”, will this be an issue with qt5 configuration? I haven’t messed around with it before.

I’ll give Xfce4 a try now and see if I have better results, from what I’ve heard a lot of Linux machines struggle to provide decent performance with Eve. Will look into driver related issues now as well.


(Whitehound) #15

I cannot say. I’m using Debian with WINE 3.8 and Xfce4 and a GTX 960. It gives me 120 fps inside a station, up to 150 fps outside, with DX9 and all set to maximum, including AA turned on.


(Tyrak Amphal) #16

It’s definitely running a lot better, I ended up checking a thread about increasing performance slightly with linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

Also apparently my GPU is set by default to powersaving so I’m required to run echo performance | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor for performance settings.

I’ve also changed around some grub settings to allow better performance but haven’t rebooted yet, mid-high settings I’m now getting around 70 FPS in station which is a lot better, mainly due to Xfce4.


(Whitehound) #17

If you have the sysfsutils installed or if you can install them, then you should write the CPU governor into /etc/sysfs.conf. You then no longer need to do it manually, but it will set it for you during boot:

# Set CPU 0-3 to use the 'performance' governor
devices/system/cpu/cpu0/cpufreq/scaling_governor = performance
devices/system/cpu/cpu1/cpufreq/scaling_governor = performance
devices/system/cpu/cpu2/cpufreq/scaling_governor = performance
devices/system/cpu/cpu3/cpufreq/scaling_governor = performance

I myself prefer the ondemand-governor, which allows for some additional parameters. So I use the following in my sysfs.conf file:

# Set all CPUs to use the 'ondemand' governor
devices/system/cpu/cpu0/cpufreq/scaling_governor = ondemand
devices/system/cpu/cpu1/cpufreq/scaling_governor = ondemand
devices/system/cpu/cpu2/cpufreq/scaling_governor = ondemand
devices/system/cpu/cpu3/cpufreq/scaling_governor = ondemand
devices/system/cpu/cpu4/cpufreq/scaling_governor = ondemand
devices/system/cpu/cpu5/cpufreq/scaling_governor = ondemand
devices/system/cpu/cpu6/cpufreq/scaling_governor = ondemand
devices/system/cpu/cpu7/cpufreq/scaling_governor = ondemand

# 'ondemand' CPU governor, switch up at 50% load and stay up 10x longer
devices/system/cpu/cpufreq/ondemand/up_threshold = 50
devices/system/cpu/cpufreq/ondemand/sampling_down_factor = 10
devices/system/cpu/cpufreq/ondemand/ignore_nice_load = 1

If you have an Nvidia card and are willing to over-clock it then you can do this by setting the “Coolbits” in the X11 configuration file:

...
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "255"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
...

When this option is set and you are using nvidia-settings will it now show text fields under PowerMixer where you can enter clock offsets. USE AT YOUR OWN RISK.


(Tyrak Amphal) #18

The ondemand seems like a better option rather than adjusting settings frequently, I’m still relatively inexperienced when it comes to anything in-depth in this area but it seems to run with no errors so far.

It’s not worth overclocking as my laptop has in-built graphics, I only really have Eve on it for when I’m not able to get on my desktop for any reason, but I’m at least able to dual-box at a stable 60 FPS with current set up. X Server issues were only really down to me assuming I would get better performance and the new environment seems to have cleaned up most of the problems I had. Now just cleaning up after all the messing around I’ve done.


(system) #19

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.