Pyfa - The Python Fitting Assistant - v2.3.0 (Mutaplasmids!)


(Sarmatiko) #83

You might want to use another antivirus if it throws too much false positives on you (that is a common tactic, otherwise how would they lure you into regular subscription?)
Nowadays you will be fine with firewall (router or software solution like Comodo) and just Windows Defender (or Security Essentials on Win7).

As additional measure, if you download any executable\archive from internet, check those with Virustotal. If you see 1-3 results out 70 - it’s more likely false positive (especially if there is a generic\heur words in names).

With Pyfa 2.0.2 as you can see with check results, out of 53 available engines not a single one detected any threats (including Symantec engine):
https://www.virustotal.com/#/file/df3a8e35fe73dbb540d37e46240745253808727eac6a840202721b99aa32584d/detection

Ofc it’s your choice in the end, but I’d uninstall Norton to save system resources, and subscription money can be spent on something more useful (like backup storage or something).


(Giddy McFee) #84

Thanks for the links, If I can see that there are false positives then that is fine. Whilst there may be other/better options I think Ill still be keeping the AV that I have. I’ll admit though Ive never really looked at other options.


(Kaivarian Coste) #85

My characters’ skills aren’t updating, even though my characters are listed under the SSO Character Management window, and I’ve already put in my password. Does anyone know how to fix this?


(Praetor Serpe) #86

I had the same problem with the latest Pyfa on Wine, but solved changing my winecfg library configuration.

Try this:

1 Open winecfg from terminal
2 Go to Libraries tab
3 Find api-ms-win-core-path-l1-1-0.dll and add it to new substitution (not sure how is called in english, my wine is in italian)
4 Edit the new entry as set it Native (Windows)

Let me know if it works


(Praetor Serpe) #87

I’ve got a problem with fonts and/or text not showing in the latest Pyfa.

In the main fitting panel text doesn’t show.
I can see the icon on the left, i can click on the row, but no text.
Other panels like drones or cargo show the text successfully.

I run Pyfa on Ubuntu 16.04 with Wine


(David Euler) #88

I just updated to v2.1.1., but SSO page seems in grey, no button is available for click. It means I can’t upload my character into Pyfa, a little inconvenient. Is that a bug? or something new I missed?


(Kaivarian Coste) #90

I finally figured it out. Don’t click on the “refresh” arrow button next to your character’s name in the top RHS corner.

Instead, go to Window>Character Editor>EVE SSO>Get Skills. This worked, but the “refresh” arrow button does not.


(Or'es'ka) #91

Attribute overrides breaks graphs. It somehow believes that if you put a web holding at 98.6% speed redutction, that torpedos do not apply until you are t about 20km. throw a max rolled fed web on a virtuoso and pit it against a cruor


(Crularii) #92

Since a couple of versions ago pyfa takes up to a couple of minutes to start up on my rig.


(Durarara Onnlin) #93

hello there :smiley:

i am trying to install pyfa on ubuntu 16.04 can you help me with how to do it? :smiley:

thaaaank you :smiley:


(Alice P Liddell) #94

does not work

OS version: Linux-4.16.0-1-amd64-x86_64-with-debian-buster-sid
Python version: 3.6.6rc1+ (default, Jun 22 2018, 08:07:48)
[GCC 8.1.0]
wxPython version: 4.0.1 (wxWidgets 3.0.4)
SQLAlchemy version: 1.2.8
Logbook version: 1.3.0
Requests version: 2.18.4
Dateutil version: 2.6.1

####################

Traceback (most recent call last):
File “pyfa.py”, line 128, in
from gui.mainFrame import MainFrame
File “/home/USER//Pyfa/gui/mainFrame.py”, line 64, in
from gui.updateDialog import UpdateDialog
File “/home/USER/Pyfa/gui/updateDialog.py”, line 28, in
import markdown2
ModuleNotFoundError: No module named ‘markdown2’


(Sable Blitzmann) #95

Huh, totally forgot this thread was a thing! Apparently I don’t forum very well haha!

Since my last post, pyfa has undergone some major revisions on the backend. We moved from 1.x to 2.x, which updated the codebase to support Python 3 and wxPython 4. Development is still chugging along - v2.3.0 was just released with support for mutaplasmids!

Thanks to everyone that uses pyfa, supports pyfa, and contributes to pyfa! You guys rock!

I’ll try to check on this thread more regularly, but the best way to report a bug is to post it on GitHub. I’m also on TweetFleet slack if that’s more appropriate for you :slight_smile:


(Sable Blitzmann) #96

This is because you did not install the markdown2 package. Once you get that, should work fine :slight_smile:


(Sable Blitzmann) #97

This is a known issue, and one that I haven’t tracked down yet. See https://github.com/pyfa-org/Pyfa/issues/1605


(erg cz) #98

Thats what I get 4 times afer start of the exe file. Pyfa starts none-theless after that. But I still can not import fits from clipboard.

Thank you for your work. Using PYFA long time already, awesome tool.


(Alice P Liddell) #99

“python3-markdown2” also has no package in Debian sid.


I do not know how to install this package.
I can not keep track of libraries.


(Famine Aligher'ri) #100

Did something change with the boosters section on the market tab? I no longer see the standard boosters anymore such as Blue Pill, etc. Just Cerbral Accelerators, etc. I can search for them fine, but I could have sworn every booster was listed under the Implants & Boosters section. Tried updating to latest release, no go.


(Marcus Gideon) #101

Somebody already reported this issue, they just haven’t gotten around to fixing it yet. =)


(Famine Aligher'ri) #102

Thanks! No big deal, just making sure it wasn’t just me!


(StormLead Erquilenne) #103

Hello,

I don;t know if anybody reported this yet:

Small Polycarbon Engine Housing I doesn’t seem to affect agility, aka the align time remains the same.

thanks.