Pyfa - The Python Fitting Assistant - v2.3.0 (Mutaplasmids!)


(Fluffy Moe) #124

Nice !!!

I knew I was missing something. Thank you very much for the explanation and pointing this out to me. I really appreaciate it.


(Birk Ernaga) #125

Tried to delete a fit, I had this several times, sometimes it worked tho

OS version: Windows-10-10.0.17134-SP0
Python version: 3.6.1 (v3.6.1:69c0db5, Mar 21 2017, 17:54:52) [MSC v.1900 32 bit (Intel)]
wxPython version: 4.0.0b2 (wxWidgets 3.0.4)
SQLAlchemy version: 1.1.10
Logbook version: 1.0.0
Requests version: 2.18.4
Dateutil version: 2.6.0

####################

Traceback (most recent call last):
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinShipBrowser\sfBrowserItem.py”, line 333, in OnLeftUp
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinShipBrowser\sfBrowserItem.py”, line 50, in DoCallback
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinShipBrowser\fitItem.py”, line 369, in deleteBtnCB
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinShipBrowser\fitItem.py”, line 387, in deleteFit
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\service\fit.py”, line 220, in deleteFit
AttributeError: type object ‘type’ has no attribute ‘processors’


(Xenobia) #126

tried to create a new fit for marshal and got this:

pyfa vv2.5.0
EVE Data Version: 1399820 (2018-10-10 02:27:02)

OS version: Windows-7-6.1.7601-SP1
Python version: 3.6.1 (v3.6.1:69c0db5, Mar 21 2017, 17:54:52) [MSC v.1900 32 bit (Intel)]
wxPython version: 4.0.3 (wxWidgets 3.0.5)
SQLAlchemy version: 1.1.10
Logbook version: 1.0.0
Requests version: 2.18.4
Dateutil version: 2.6.0

####################

Traceback (most recent call last):
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinViews\fittingView.py”, line 86, in fitSelected
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinViews\fittingView.py”, line 339, in fitSelected
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinViews\fittingView.py”, line 353, in updateTab
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\bitmap_loader.py”, line 76, in getImage
AttributeError: ‘NoneType’ object has no attribute ‘ConvertToImage’

p.s.: works fine with other ships.
p.p.s.: https://i.imgur.com/uXoNE9z.jpg - no icon for marshal


(Jacks Medulla Oblongata) #127

when trying to create/load a pacifier fit with the latest release:

pyfa vv2.5.0
EVE Data Version: 1399820 (2018-10-09 17:27:02)

OS version: Windows-10-10.0.17134-SP0
Python version: 3.6.1 (v3.6.1:69c0db5, Mar 21 2017, 17:54:52) [MSC v.1900 32 bit (Intel)]
wxPython version: 4.0.3 (wxWidgets 3.0.5)
SQLAlchemy version: 1.1.10
Logbook version: 1.0.0
Requests version: 2.18.4
Dateutil version: 2.6.0

####################

Traceback (most recent call last):
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinViews\fittingView.py”, line 86, in fitSelected
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinViews\fittingView.py”, line 339, in fitSelected
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\builtinViews\fittingView.py”, line 353, in updateTab
File “C:\Users\holme\Documents\Sync\Git\blitzmann\Pyfa\gui\bitmap_loader.py”, line 76, in getImage
AttributeError: ‘NoneType’ object has no attribute ‘ConvertToImage’


(Leah Crowleymass) #128

I’ve got a bit of an odd issue. I have one character that refuses to update. The other characters on this account update just fine, but not this one. This has been a persistent issue across multiple versions of PYFA, so something is definitely wonky with ESI or how it is pulling the data.

  • I’ve deleted the character and recreated it in PYFA
  • I’ve revoked the character from PYFA and re-logged with SSO to pull the skills
  • I’ve revoked app access from the EVE Help Center.
  • I’ve done all of the above in different combinations and orders and still no love.

The odd thing is that I get the “Successfully Fetched Skills” message when using either the Update API button in the mail window or the Fetch Skills button in the Character Window and have never seen an error, but the skills do not update.

I’m currently using V2.5.0.

Any ideas?


(Leah Crowleymass) #129

OK, weird- I just logged in, moved around one skill in my training queue on a lark, went back to PYFA and clicked the Update API button, and everything updated properly for that character.

So…problem “solved” I guess?

I’ll leave this here in case anybody else runs into this.


(Luscius Uta) #130

Can you add icons for Concord ships in the next release?


(Anderson Geten) #131

@Sable_Blitzmann

can you update the installation for ubuntu to add the instructions I gave here

I guess adding a specific file like instructions/ubuntu.txt and linking this file in the readme.md should be the correct approach.


(Blacque Jacque) #133

I’m using Pyfa 2.7.0 on Ubuntu 18.04, but I notice a few issues:

  • Some implants & Boosters don’t seem to have any effect on fitting stats (e.g. SP-60x or MP-80x don’t increase damage output of small/medium projectile turrets).
  • The Skill list in the Character Editor doesn’t show the skill names, just levels.

Anyone else experience these?


(Gerry TheViking) #134

Since EFT is dead, there is no other and of course no better fitting-assistant. Thank you very much for your time and efforts invested to keep this tool up to date. What I’m still desperately missing, is a color-code of the items in the market window. For easier fitting I have set the tool to show different colors for the high, medium and low slots. It would be perfect if the different items in the market window could be shown in the corresponding colors so it would be easier to see into which corresponding slot they are supposed to go.


(Sable Blitzmann) #135

Hi guys!

Friendly reminder that bug reports should really be submitted through GitHub. As you can see, I rarely monitor this thread due to lack of time. :slight_smile: If you think there’s an issue, simply post it on GitHub and there’s a good chance I or someone else will at least respond with an initial reply.

This is doublyh, triply important if you’re having issues which actually prevent you from using pyfa. I would always like to get those cleared up so that you can theorycraft away!

Thank you all for your continued support of the project. :slight_smile:


(Sable Blitzmann) #136

I feel like there was a reason we didn’t do this way back when, but I’ll put a feeler out on GitHub to revisit this and see if it’s possible these days. :smile:


(Sable Blitzmann) #137

Also, I should mention that my wife and I are expecting our first child any day now! As such, the time that I can dedicate to this project will probably be reduced, so please be patient when reporting bugs if you don’t get a reply for a few days :slight_smile: Additionally, Kadesh recently started becoming active with the project again and has been helping out, so I don’t expect any hiccups when it comes to keeping up to EVE releases at the very least

As always, pyfa is open source, so if you’re interested in helping out, by all means! You can contact me on Tweetfleet or pyfa’s slack (I don’t check my EVE Mails, so don’t bother)


(Sable Blitzmann) #138

I’m not seeing the issue for the implants, the affected by tag is properly showing the modification from the implants.

  • The Skill list in the Character Editor doesn’t show the skill names, just levels.

I haven’t tested in Ubuntu in a long while, so this might be a GUI bug. If you hover over this area, you may be able to “drag” the skill names back into view:
image
Let me know if that works, otherwise please post a screenshot (better yet, please post issue in github issues page)


(Leah Crowleymass) #139

Congratulations, man! That’s awesome news, and RL always (ALWAYS) should come first.

Best wishes to you and your wife for a smooth delivery and a happy, heathy new arrival.

o7


(Highwir5) #140

NEED HELP ! ! For some reason I thought it would be a good idea to drag and drop all pyfa related folders into one main folder. Now when loading Pyfa, my characters are missing and I don’t see any of the fits I had. Could someone let me know where the data should be so I can move the folders back and see my fits again??


(Sable Blitzmann) #141

User data is stored in a file called saveddata.db that is normally located at %UserProfile%\.pyfa\. I’m not sure what you mean by you put everything in the same directory, but if you look for this file and back it up, you should be able to reinstall pyfa using the exe file and then move that saveddata.db file back to it’s original location