Adding Omega time with PLEX not working on Singularity

When trying to use PLEX on the test server, the pop up window appears to add omega time and that’s it. There is no actual way to add omega time. All you can do is close the window. I tried with an Alpha account and my main, which is already an Omega account.


Bump, because i have Omega on my main, but on the test server it is still an alpha.

Its annoying as hell. Why is /omega disabled?


same problem there. omega-tranquility but alpha on test.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.