Cannot add Omega time with PLEX and NES store is unavailable


(James Amril-Kesh) #1

On Singularity right now it seems most people (but not everyone for some reason) are having trouble adding Omega Game time or accessing the New Eden Store.


(Dorvard Dallocort) #2

on the server singularity I can not switch to omega, paid by plexes and NES does not work



(Ria Vyvorant) #3

I’m having the same issue. I was able to play on my account with Omega for several hours before logging out and back in. After I logged my Omega time lapsed. The store is unavailable so i cannot reactivate the account on Singularity.


(CCP Goliath) #4

While we work on a fix for this, please try clearing your settings if you are getting the store behaving like OP*s pic above (and then do not sort it by price if it reappears).

You could also try a fix that worked for me - call someone over to your machine so they can see how it’s broken, and it might just start working again…


(Rusty Boon) #5

The work around to this is manually search the new eden store for omega you will then be able to use your plex to get omega status. I had this issue a few days ago.


(CCP Goliath) #6

The store isn’t working for everyone either unfortunately - looking into it.


(Ria Vyvorant) #7

I logged on today and was still unable to open the store. I cleared all settings and then was able to. I then searched for Omega and was able to purchase it resolving my issue. Seems like it’s related the settings some how.


(James Amril-Kesh) #8

Instead of clearing settings I’ve found it’s easier to make a new blank profile in the EVE launcher, then log into that and use the NES, then log back out and switch back to your profile.


(Lucas41) #9

It’s been a long time since I’ve logged into SiSi. Today I tried jumpping on sisi to do some testing with the new game content. However, upon login I was greeted with a message that my omega account was now an alpha account and I needed to purchase Omega time. What’s going on with this? This account has never been alpha.


(system) #10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.