Alpha can't join an alpha-CEO corporation?

Ok. So I’ve returned after 2 years absence.

I have an alpha account that is the CEO of my old player corporation with just him in the corp.

I have applied to join that corp with my OTHER alpha account. But the application doesn’t show up anywhere. (corp>recruitment>applications> nothing!)

Is there some mechanic that doesn’t allow the alpha CEO to see applications? or is there a rule that doesn’t allow alphas to join a corp?

help pls thx

btw membership applications are enabled

I invited him to join and he got in… problem solved.

I checked and it said his application was withdrawn, although I did not withdraw it.

Glad you solved your issue.


Somehow CCP has managed to screw up the corp interface in a way that causes people to accidentally withdraw their applications. I don’t know why, but it happens.

I’m having the same issue with my (3rd) alt who is also an alpha. Applied to join the corp, but the CEO of the corp doesn’t see the application anywhere. Tried inviting him to corp but that doesn’t show up anywhere either.

nvm. found the application.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.