Beta Launcher v0.4.x

The winetricks on a clean prefix got the installer/launcher running for me. Sadly, the launcher/installer was completely unable to find my previous EVE installation, so I’m going to have to copy over my settings manually, save all my screenshots somewhere else, and delete the old prefix.
Completely changing the install paths for the new launcher was a real galaxy-brain move :confused:
Update: well, I got to the point of trying to launch the client and got an error that “Windows 10 or higher required.” I have winecfg set to Windows 10. So, stuck again.
Update 2: I needed to run winecfg -v win10 on both prefixes – the one where the launcher is installed, and the one where the client files are stored – to get it working. But it seems to be running. Now I just need to copy my settings files over.

I am still running wine 8.0.2, I made a backup of the wine prefix and removed it. Then I ran the string you recommended. That seemed to cure the launcher issue, then I pointed the installer at my existing Eve folder. After login, I spent the next hour resetting my settings and individual characters back to their “normal” UI. This made me so tired, I decide just not to play today. Thank you for doing the most exhaustive work of debugging the needed modules.

Note: This launcher is really a clock cycle and memory pig. I shut it off completely using the quit option in the wine system tray. However this will not appeal to players wanting to operate multiple omega accounts.

This worked perfectly for me, thanks.

Greetings

I have followed the instructions below to the letter and no matter what I try, the installation insists on trying to install dotnet45 which fails at the end when it asks to “Restart Now”.

This is the Terminal output if helps find a solution:

wineserver: using server-side synchronization.
002c:err:wineboot:process_run_key Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -r" (2).
011c:err:kerberos:kerberos_LsaApInitializePackage no Kerberos support, expect problems
0140:err:kerberos:kerberos_LsaApInitializePackage no Kerberos support, expect problems
0158:err:ole:marshal_object Failed to create an IRpcStubBuffer from IPSFactory for {659cdeac-489e-11d9-a9cd-000d56965251} with error 0x80004002
0210:err:wusa:install_files_copy Required file L"C:\\users\\myuser\\Temp\\msu2.tmp\\amd64_netfx4-servicemodel_mof_files_b03f5f7f11d50a3a_4.0.9600.17187_none_7f79f6c9b36ef700\\ServiceModel.mof.uninstall" not found
0210:err:wusa:install_assembly Failed to install all files for L"NetFx4-ServiceModel_mof_files"
0210:err:wusa:install_updates Failed to install update L"Package_for_KB2934520"
0210:err:wusa:install_msu Dry run failed, aborting installation

I have managed to Eve Installed on Steam but it’s a resource hog … no more dual-boxing for me and I have a rather beefy laptop. I am hoping that Bottles would be a better solution if I can get it working.

Regards
m

have you tried the simple method, that is create wineprefix, add the deps with winetricks, set the win10 version, then start with wineconsole ?