Beta Launcher v0.4.x

thanks, trying it.

Is there something special to make dxvk work ?
I had to remove it because I had errors

I confirm using wineconsole is required to not have js error
so far

  1. install winbind
  2. winetricks msdelta
  3. replace wine by wineconsole
  4. remove dxvk

new installation, cp -l the previous core_user_.dat and cp core_char_.dat (not -l for the latter) and I found my config again (including shorcuts) . The previous core_user already were linked of a comon one .

I don’t have it running yet. I just clicked on update and it came to a halt - using wine staging 9.1:

04a8:fixme:shcore:SetCurrentProcessExplicitAppUserModelID L"com.squirrel.evewine1.eve-online": stub
04a8:fixme:kernelbase:AppPolicyGetProcessTerminationMethod FFFFFFFFFFFFFFFA, 000000000081E5E0
04a0:fixme:kernelbase:AppPolicyGetProcessTerminationMethod FFFFFFFA, 0077FECC
003c:fixme:ver:GetCurrentPackageId (000000000021FEB0 0000000000000000): stub

So now i restart eve.exe using wineconsole? or should i run eve-online.exe with wine or wineconsole?

I tried running eve.exe and eve-online.exe both with and without wineconsole…nothing happens…it just halts like this:

0130:fixme:shcore:SetCurrentProcessExplicitAppUserModelID L"com.squirrel.evewine1.eve-online": stub
0130:fixme:kernelbase:AppPolicyGetProcessTerminationMethod FFFFFFFFFFFFFFFA, 000000000081E5E0
0128:fixme:kernelbase:AppPolicyGetProcessTerminationMethod FFFFFFFA, 0077FECC
0120:fixme:ver:GetCurrentPackageId (0081FECC 00000000): stub
0118:fixme:ver:GetCurrentPackageId (000000000021FEB0 0000000000000000): stub
003c:fixme:ver:GetCurrentPackageId (000000000021FEB0 0000000000000000): stub

What now? Complete reinstall?
I run wine staging 9.1 with msdelta, corefonts, dxvk, vs2019 and dx9.

Using Steam myself to launch EVE on Linux. The launcher died after I updated it but reinstalling EVE via Steam got it running again. Downside is I’m downloading the game again and will need to setup all of my accounts from scratch but at least it is running.

Edit: using Proton Experimental

no error in the previous messages ?

I downloaded the latest client install now that my previous eve install wouldn’t run anymore and started the client install eve-online-latest+Setup.exe

This now sits displaying the EVE logo and again does nothing. I am lost, as i don’t know how to get it running again. Guess no EVE tonight for me. Pls. someone help how to do it with wine staging if you got it running!

6.7.2-arch1-2 + wine-ge-8.0 (Staging), also ran into black box with text. Reading the wine logs, I noticed warnings that might have been related to com and issues creating a window.

However, since I knew that prefix was tainted prior to the upgrade, I nuked it and redid from scratch. So, here are my manual steps (no steam, lutris - just system package managers). Hope it helps until someone a bit more patient finishes tracking down the root cause.

  1. Back the old prefix up. You can back up only drive_c/users/<user>/AppData/Local/CCP/EVE/c_eve_sharedcache_tq_tranqulity if you don’t mind redownloading the client.
  2. wineboot, create new prefix
  3. winetricks -q msdelta arial tahoma vcrun2017 (Shamelessly ripped from the lutris installer here, it’s a small set that seems to work ok)
  4. Switch to a wine version that can install (see: UAC issue, I used wine-8.21 (staging) which was wine-staging for arch at the moment of installation for me).
  5. Install dxvk if you’re using dxvk, don’t be a goof like me and forget to add the overrides
  6. Start up the launcher, log in your characters. It appears that settings_Default will be used as a base for your new settings.

There. Done. Your new executable to launch EVE will be $WINEPREFIX/drive_c/users/<user>/AppData/Local/eve-online/eve-online.exe


Thank you all for your input and insights.

I really had to nuke everything for the new launcher to even open up and appear. I deleted my installation directory as well as the wine-prefix.

Then i have set up a new wine-prefix and did:
winetricks corefonts msdelta vkd3d vcrun2022 dxvk2030

So this seems to run and is installing right now with dxvk on Debian 12, wine staging 9.1, nvidia drivers.
Now i have to figure out how to transplant my old settings or if it is better to start anew anyway.

1 Like

as I did, find the old core_user_.dat and char and copy it.
It did it (actually linked the core_user since I don’t want to change the shortcut for every account -.- ) and it works.

To where should i copy the core_user_.dat and char files?

It seems the structure is now completely different and i don’t or do not yet have have an AppData/Local/CCP/EVE/x_xxxxx_xxxxx_sharedcache_tq_tranquility folder. Do i have to add a character first through the gui before this appears?

Also the new launcher is not residing in the installation directory of eve online.
I have to run it like this - taken from the autocreated EVE launcher icon on the desktop:
env WINEPREFIX=“/home/xxx/.wine” wine C:\users\xxx\AppData\Local\eve-online\eve-online.exe

This is an entire different location as before. A location that i don’t like and is not easy accessible. Any ideas for a shortcut? Just do a symlink somewhere to the target directory?

1 Like

find oldprefix -name “core_user*.dat”
find newprefix -name “core_user*.dat”

you need to have logged on at least one character of the account to have the corresponding core_user
you need to have logged with corresponding character to have the core_char

So I managed to install the new launcher from scratch without Steam using the following method:

  1. Install Bottles
  2. Add the following runner: Preferences → Runners → Caffe-8.21
  3. Create a new Win64 bottle called “EVE”. Choose “custom” and disable both DXVK and VKD3D.
  4. Once the bottle is created, go to Settings and choose the Caffe-8.21 runner
  5. Also add the following dependencies to it: dotnet45, vcredist2019, arial32, consolas
  6. Download the new launcher and put it in a folder accessible to bottles. Typically under ~/.var/app
  7. Choose “Run executable” inside the new bottle and select the launcher

At this point the game installed and started as expected.
At first I thought my graphics card wasn’t detected because the graphics settings was all low/disabled.

So I exited EVE and enabled DXVK in the bottle Settings, and I also selected the Vulkan renderer under “Advanced Display Settings”

After logging back into the game the graphics was still low/disabled, but once I changed the shader settings suddenly stuff got enabled and I could choose whatever display settings I wanted.

It seems to run fine at this point but I haven’t tried running it for hours yet. Crossing my fingers…

1 Like

what was your driver when using “ctr f” ingame ?

I didn’t know about CTRL+F but I suspect it was using my Radeon card all along. I just had to select better display settings ingame for some reason. I noticed the FPS was 60 and I had no lag so it was probably just bad default display settings.

1 Like

Well I said this before, since I just attempted to run the game and it is hanging on the EVE splash, I am not busting my ass to fix this right away. Apparently some of you are having a better time of it. I knew the new launcher might knock me out of this game. Well too bad for CCP, I might not be omega but I was buying Plex from them. I don’t know when I will have time to debug this mess, but it won’t be right away. In the meantime my friend has been wanting me to play another game with him.

Fly safe my friends o7

Yeah same here with Lutris, no runners work. Trying the above mentioned “Bottles” now…

edit: can confirm the “bottles” solution works. Sound is choppy here and there, so there is still room to improve. FPS seem to be around 10% better on my amdgpu (APU) around 58fps with bottles than with Lutris and GE runner…

I had the same issue (but using vanilla wine). It seemed to be caused by some issues accumulated in wine prefix over years. On clean wine 9.1 prefix, with winetricks verbs msdelta arial tahoma vcrun2017 dxvk vkd3d installed, and EVE data moved manually from the old prefix it worked just fine.

1 Like

That’s great, I guess the launcher doesn’t like Proton too much, the game probably doesn’t have a problem with it.

If anyone else here are using bottles, here is how to make a shortcut to a program inside bottle:

[Desktop Entry]
Name=EVE Standalone
Comment=Play EVE Online
Exec=flatpak run --command=bottles-cli com.usebottles.bottles run -b EVE -p eve-online

Put this in a text file named “EVE.desktop”, or whatever, and save it under ~/.local/share/applications
and make it executable. It should show up in the menus after that.
The reference to “EVE” in the desktop file is the name of the bottle, so you would have to change that if your bottle has a different name. Also update the icon path to your liking.


I was able to get it back running with Lutris. Did a clean re-install in a new prefix and switched to wine-ge-8.26 runner. Works excellent again.

I have tried a lot of things lately, including Lutris+GE, but I kept getting the UAC issue. Maybe the latest wine, or the latest launcher did something to fix that issue

Try the latest Lutris 0.5.16!