Blackscreen after Launching Client

Hey Guys,

i just installed POP OS 20.10 and installed KDE desktop on it… its almost completely fresh.
I downloaded the eve package, extracted it, launched the launcher and added my accounts…

but (now it gets weird) i get only a black screen after i launched a client. I can select blindly a character, and now after some seconds, i can see EVE. But i am missing the UI completly.

CTRL F9 and CTRL Shift F9 does nothing… any one a clue how to get the UI working?

I installed it on Steam, with Proton —> Same Issue
I installed it with the windows installer with Lutris on wine 5.0 --> Same Issue

GPU Drivers are up 2 date…

any Ideas?

1 Like

Just as an idea: set the client to directx 9 in the launcher. I don’t expect it to solve it but it would at least check that it’s not due to that.

Launcher starts, but ingame UI fails to load, getting message:

Failed to get a valid ballpark in time after trying 30 times channel michelle
Failed at storing client achievement events, e = ‘NoneType’ object has no attribute ‘UpdateClientAchievmentsAndCounters’

Assume its related

Ok so I dont know if you have sorted this out yet but today I came home and ran the usual pacman upgrade when it told me that there were new llvm packages that iI could not update because I was using the mesa-aco-git package. After I installed the new mesa -20.2.2.2 (had to install a second vulkan-driver package so that pacman could remove mesa-aco-git without breaking steam) that replaces mesa-aco-git I was able to install the new llvm packages with a bunch of other ones. When I fired the client up (which worked fine yesterday) got the same issue as you; black screen but the game is there selected character blindly could see the my ship but no ui visible. I then reverted all the updated packages to yesterday’s version and it fixed the game. Now I narrowed it down to 25 packages that i believe are related to graphics but I dont know exactly the one thats causing the issues. Its late right now over here but ill have some time tomorrow to go over and try to find the gilty one. I`ll list them over here so you can compare to your packages and maybe help you fix the issue. Dont know if you using AMD GPU but since the issue is the same I think is more than likely.

Packages clang-11.0.0-1 compiler-rt-11.0.0-1 glslang-11.0.0-1 js78-78.4.1-1 lib32-libdrm-2.4.103-1 lib32-llvm-11.0.0-1 lib32-llvm-libs-11.0.0-1 lib32-mesa-20.2.2-2 lib32-vulkan-radeon-20.2.2-2 libclc-11.0.0-1 libdrm-2.4.103-1 libffi-3.3-4 liblphobos-2:1.23.0-3 libmfx-20.3.1-1 libnftnl-1.1.8-1 libunistring-0.9.10-3 libxml2-2.9.10-6 llvm-11.0.0-1 llvm-libs-11.0.0-1 mesa-20.2.2-2 openshadinglanguage-1.11.8.0-2 shaderc-2020.3-1 shiboken2-5.15.1-2 spirv-llvm-translator-11.0.0-1 vulkan-radeon-20.2.2-2

PS: sorry for the long reply, english is not my first language

1 Like

Ok so I’m back i narrowed it down to the LLVM 11 packages and Mesa 20.2.2-2. I tried installing only the mesa package but it broke X11 so i installed the llvm packages and it fixed X11 but broke the game again in the same manner as before. So I guess you should try downgrading llvm lib32-llvm llvm-libs lib32-llvm-libs spirv-llvm-translator to version 10.0.1 and lib32-mesa and mesa to version 20.2.1

Hope it helps

I am getting similar problem, cannot solve it… HELP!!! Advice would be more then welcome…

On main computer, using rx590, running blender easy peasy, Dying Light, Metro Exodus, even Sekiro… but EVE, no… srs company like CCP should have proper EVE support for Linux users as there is some of us that do play games on Linux… tried rollback for amdgpu, tried different wine, tried full reinstall of xorg, on/off openGL, hardware rendering, no good results there…

On an old laptop, with the hybrid mx150 nvidia, using old school bumblebee, no problems, eve runs with decreased fps

I have a feeling its just one guy in Iceland, a fan of Linux, trying to do all the fixes etc…

I got exactly this after a few weeks of inactivity on the Linux install.

I run EVE on a self-managed WINEPREFIX on Arch Linux. (EDIT: wine-5.21)

It seems all that I had to do was install dxvk through winetricks (in addition to all the other things already installed that way).

Not sure how to do this in your situation, though.

Yeah. A clean 64bit wineprefix and install latest dxvk through winetricks made it.