errors / api access not working


somehow the site is throwing errors if you click on the “Manage Application” button. Also, the logout function is not working anymore.

Some ClientID’s are not able to connect to the api anymore. Here an example from my pathfinder instance.


Developer EVE Website:

got the same problem

May be of use.

(yes, the developer’s site is broken. But that’s not why your application isn’t working.)

The developer EVE site is still down but if your pathfinder is not working anymore you can fix it manually.

Go to the file:


Replace the function getAccessRequest as follows:

protected function getAccessRequest(array $credentials, array $requestParams = []) : RequestConfig {
    $requestOptions = [
        'form_params' => $requestParams,
        'auth' => $credentials

    return new RequestConfig(
        WebClient::newRequest('POST',  $this->getVerifyAuthorizationCodeEndpointURI()),
        function($body) : array {
            $accessData = [];
                $accessData = (new Mapper\Sso\Access($body))->getData();

            return $accessData;

This will change the auth request from json to form-data

1 Like

Unfortunately, those that did not have a previous existing EVE Application cannot create a new one since the website is returning 500. Still stuck on the same issue :frowning:

Which particularly sucks as I was going to take the opportunity presented by the hr bot I was using now going dark to set up my own self hosted option. Guess that’s on hold too.

The eve developer site is fixed and working again


Fixed API auth by changing HTTP POST requests content type from application/json to application/x-www-form-urlencoded

And can you create a new application? Cause I want to make my own pathfinder, and I can’t create my api. Nothing happens.

I am still unable to create new applications or update existing ones.

I cannot create new applications too. I fill out the details, hit the button and it loads the list but the new app doesn’t get created. I’ve tried it about 10 times same result.

I also cannot create or update applications

Their developer page is simply broken. They announced changes on a blog no one has access to even read. CCP get your prioritized straightened out and fix your own developer site ASAP.

They have fixed everything but the blog. And they did repost it here.

The developer application process is NOT fixed. It remains broken.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.