ESI SSO: Always gives an error for me, and error is uselessly vague. Please help!


(Egon Magalhaes) #1

Every time I redirect to the SSO from my little programming project, I get the following response (after entering my account username and password if not already signed in,) no matter what I try:

{“error”:“invalid_request”,“error_description”:“Some parameters are either missing or invalid”}

This is the URL my app is generating: https://login.eveonline.com/oauth/authorize/?response_type=code&redirect_uri=eveauth-emma%3A%2F%2Fcallback&clientId=MY_CLIENT_ID&scope=characterAssetsRead%20characterMarketOrdersRead&state=396464

…where “MY_CLIENT_ID” is replaced with the 32 character Client ID from https://developers.eveonline.com/applications, of course.

I’ve carefully read & re-read Eve Online Third Party Docs Authentication Flow and the Third Party Developer Blog article on ESI Step by Step but as far as I can tell the URL my app is using to initiate SSO is correct according to all the documentation. I’ve checked and double-checked that I had everything the same between the URL I’m generating and settings for my application at the Eve Developers site. I’ve experimented with changing the scopes (updating them at the Eve Developers site each time too) from one, to all, to none, to no effect, I still got the same error (well except in the all scopes case, where I got a 404 instead, which I believe is a separate issue already reported here as issue 267 on Github) I tried leaving off the optional state parameter, to no effect, I still got the same error. I’ve tried variations on every part I can think of, and I cannot get it to work.

Please help! How do I get the SSO to redirect to my callback URI and give me an authorization code, rather than giving me an error?


(Blacksmoke16) #2

you have clientId= should be client_id=.

Also not sure if it’s an issue or not but you dont have http:// or https:// for your uri callback.


(Egon Magalhaes) #3

facepalm

Yup, that’s it. Changing it to client_id= fixed it. Thanks so much for finding that, I can’t believe I missed that. It’s totally working now.

The weird uri callback is intentional, I’m working on an iOS app, and it triggers a registered URL handler specific to my app, which is also working now.

Thank you so much for catching my camel-casing there, I really appreciate it!!


(system) #4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.