ESI Wallet Transaction help


(Taleonn) #1

Has anyone had any issues with the ESI Wallet Transaction API the last few days. When I use the swagger interface to test what previously worked I am now getting the following:

Response Body
[]
Response Code
200

When I use the same character and token for wallet journal it returns a response body as expected.

Any assistance would be much appreciated.


(Blacksmoke16) #2

Are you sure that character has wallet transactions? i.e. bought/sold something within last while. From what i can tell now is it was completed successfully but didn’t return anything.


(Taleonn) #3

Yeah definitely transactions. Seems strange had been working fine then stopped returning results since the 28th of Aug. thought it might have been the token or something but that is working fine with the character journal


(Golden Gnu) #4

Sound likely it could be a bug, as the endpoint was updated to fix a bug on that date.
You should properly report it on GitHib or you can ask on slack, Monday.


(Taleonn) #5

Thanks posted on the GitHub forum. Still receiving same result also when using all three routes. Anyone else have same issue or just me haha


(Freka Thursik) #6

Same problem here. Wrote a script to track my wallet transactions, and it hasn’t updated in a week. Date of last transaction was “2017-09-02T14:17:00Z” - I’ve definitely had transactions since, though.


(Tribal Trogdor) #7

Im having an issue where I just get “error”: “Unhandled internal error encountered!” for my corps master wallet. All other divisions work fine. I tried it on the master wallet of a different corp and it worked fine. Seems there are still a few issues to hammer out on this one :smiley:


(Golden Gnu) #8

@Tribal_Trogdor That is not the same error. You should create an issue for that on GitHub too


(system) #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.