EVE Launcher Debian (Ubuntu?) install help


(Roesjka) #1

I am running Debian stretch/buster 64bit (Multiarch) on my desktop pc and notebook
Lenovo y50-70.

Shortlist:
Wine-Staging 2.13/2.14
EVELauncher Linux (no steam needed) with Custom Wine (Wine-Staging)
Install from jessie-backports, stretch or buster (whatever you are running):
sudo apt-get install libssl1.0.2 (this installs libssl.so.1.0.2 and libcrypto.so.1.0.2)
If nothing else depends on it remove/purge libssl1.0.0

To avoid pitfalls with updating/reinstalling Linux EVE Launcher make 2 symlinks:
sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2 /usr/lib/x86_64-linux-gnu/libcrypto.so
sudo ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2 /usr/lib/x86_64-linux-gnu/libssl.so

For installing EVE Launcher for Linux see:


Two hidden directories will also be made in you home directory .eve and .EVE.

Steam isn’t needed for EVEOnline unless you have an subscription via Steam.
The warnings you see abt. Steam and/or qtwebengine_locales are just warnings nothing else,
just ignore them. You can solve the qtwebengine_locales warning, in stretch/buster/sid, by installing:
sudo apt-get install libqt5webengine-data
ln- s /usr/share/qt5/translations path/to/evelauncher/translations

Start EVE from the terminal with:
Desktop/notebook with dedicated video card: path/to/evelauncher/evelauncher.sh

Optimus notebook: optirun/primusrun path/to/evelauncher/evelauncher.sh

If you installed Linux EVE Launcher correctly it should run else check permissions.

Don’t start evelauncher.sh when you are in the directory itself, it doesn’t work.

In the EVE Launcher settings check DX9 and if you have wine already installed you can try
check Use custom Wine -> Custom Wine path: (whatever/path/to)wine

From wine-devel/wine-staging 2.4.0 should be able to run DX11 instead of DX9. Try it.

For DX11 you may have to set post-processing to High, turn the brightness in game settings higher and Interior Shader Quality to Low.

With DX11 outside station you might encounter some flickering when looking into a bright sun/star. Haven’t been able to solve or find a workaround for this yet.

Tested the evelauncher with DX11 and I must say kudo’s to the Wine devs
for the progress they made in the last 9 months.

Desktop: AsRock 990FX Extreme4, FX-8320, 16GB mem, Nvidia GTX 1070,
Debian buster 64bit, wine-staging 2.14
Notebook: Lenovo y50-70, i7, 16GB mem, Nvidia GTX 860M Optimus,
Debian stretch 64bit, wine-staging 2.13


(Merkwurkdigliebe) #2

Hi Roesjka! Long time listener, first time caller!

Edit: Answered own question: "I have apparently mistaken M-a: same for M-a: any or its state of readiness at least… " This made me think the WOW64 stuff was outdated so I only skimmed it, it wasn’t. That was also my problem with freetype :slight_smile:

Someone sometime offered an arch build tutorial for 2 bil… thats actually a great price I don’t play and I’ll pay half!

Anyways your thoughts on stream lining 64bit buster et al appreciated as is all your fine work :slight_smile:

  • M

P.S. Some wine notes I always have to dig for:

# evelauncher
winetricks corefonts d3dx9_36 vcrun2005 vcrun2008 vcrun2010 vcrun2013
winecfg settings list-all
# eve installer
WINEDLLOVERRIDES="*msvcrt,*msvcr100,*msvcr80=b,n" wine "/home/user/evelauncher/EveLauncher-1156237.exe" 
# wine-ccp winetricks etc
WINEPREFIX="/home/user/.eve/wineenv" 
WINEARCH=win32
PATH="$PATH:/home/user/.eve/wine/bin"

(Charles BawngBlower) #3

One question:

Did you actually manage to run EVE on your optimus laptop using the onboard GPU?

Even when I load the EVELauncher with
$ primusrun evelauncher
(I had to override CCP-provided Qt Libraries, they were conflicting with my system’s (Debian Sid w/ KDE))
When I start a game process, the graphic processor selected is always the Intel HD Graphics, even if the launcher is running on my onboard GPU…


(Roesjka) #4

Make sure you have bumblebee with the right video drivers installed like if you are on Debian:
sudo apt-get install bumblebee-nvidia primus primus-libs:i386

EVE is started like: optirun/primusrun /path/to/evelauncher/evelauncher.sh it is evelauncher.sh and NOT evelauncher.

And yes I have Nvidia Optimus working like a treat from day one when I installed it in july 2014 when I got this notebook.

you can check if it started with optirun:
ps -ef | grep optirun

if its not there it means your Bumblebee install is somewhere buggered.


(Roesjka) #5

With wine-staging (natively installed) only needed to install vcrun2015.

Do note I only use the Linux EVEOnline Launcher and not the windy one.

Cheers


(Charles BawngBlower) #6

Yeah, the launcher loads on bumblebee/optimus just fine. (Onboard GPU is active and all, according to nvidia-smi)

But when I kick the FPS manager in the game (ctrl + F), the reported GPU is the Intel HD Graphics instead of the onboard GPU.

Does your FPS manager report your onboard GPU as active?


(Blacksmoke16) #7

In game you are able to select the display adapter:

ESC -> Display & Graphics -> Display Adapter -> Change to GPU


(Charles BawngBlower) #8

Turns out my issue was caused by Primus: I didn’t have i386 libs installed.

According to the interwebs, installing primus-libs:i386 should have fixed that.
($ sudo apt install primus-libs:i386)

There’s no joy yet, but wine now detects the display. Guess I’ll have to add in a few i386 libs…
I’ll try to update if/when I have a list of those…